Jump to content

Installer problems for uTorrent v 1.7.1


GCS

Recommended Posts

Installer problems for uTorrent v 1.7.1

1. Does not allow user directed install path (1.6x version did)

2. Uninstall option seems to be missing (1.6x version had this)

3. Install process deleted source install file (this can be defeated by marking the source file as read-only).

While I'm on the subject of install options, one additional feature would be nice. Currently uTorrent's setup and preference data files are automatically written to a subfolder under Windows "Documents and Settings" tree with no option for change that I can find.

It would be better and more portable if these files resided under the user selected install folder. Such an option makes user data easier to backup and a tad safer from Windows crashes and re-installs.

Thank you

Link to comment
Share on other sites

Yes it's a self-contained EXE but it's also a full installer.

When you open the EXE file downloaded from the uTorrent site the following happens:

You get a popup asking you to "Install uTorrent?" Yes/No with check boxes to create desktop, start menu, and quick launch shortcuts.

Click Yes and the installer auto creates the shortcuts, creates the program directory(s) and install the program file(s).

Link to comment
Share on other sites

I guess I would call it an "installer" as it perform all the basic functions an automated install program as I stated above.

However my question here is not over the semantics of what you call your distribution EXE, but of features missing in the "install" process that were included in version 1.6x.

If you can address my original question I would appreciate it.

Thank you

Link to comment
Share on other sites

Installed v 1.7.1 on two different systems and neither registered an uninstall option in the "Control Panel->Add/Remove Programs" that I could fine.

Noting my old 1.6x version had both the utorrent.exe and uninstall.exe files in the program directory.

The new 1.7.1 installs only have utorrent.exe in the program directory.

Link to comment
Share on other sites

  • 1 month later...

When I upgraded to 1.7 I got a shock.

The file vanished from the directory where I keep everything.

I eventually found it in '\program files\utorrent' but everytime I moved it back to

where I wanted it, it moved itself back.

Just upgraded to 1.7.2 and does the same (#*$@^&%$# thing.

How do I make it quit?, convince it to stay?

I put the .exe where I wanted it and moved itself, bad exe, no cpu cycles for you

until you learn to behave.

Can anyone help me?

Thx in adv.

Link to comment
Share on other sites

Yeah,

The previous versions just ask if I wanted shortcuts made then ran.

Worked great.

Don't like having it move itself or where it went.

I also tried renaming it based on version.

utorrent.1.7.2.exe then ran it.

Copied itself without prompting to '\program files\utorrent' as utorrent.exe

I keep old versions around just in case I need to gop back.

Am thinking about it given the weird behaviour of this one.

Link to comment
Share on other sites

I don't run much.

-----

Process PID CPU Description Company Name

System Idle Process 0 98.44

Interrupts n/a Hardware Interrupts

DPCs n/a Deferred Procedure Calls

System 8

smss.exe 164 Windows NT Session Manager Microsoft Corporation

csrss.exe 192 Client Server Runtime Process Microsoft Corporation

winlogon.exe 188 Windows NT Logon Application Microsoft Corporation

services.exe 244 Services and Controller app Microsoft Corporation

Ati2evxx.exe 368 ATI External Event Utility EXE Module ATI Tech

svchost.exe 424 Generic Host Process for Win32 Services MS Corp

svchost.exe 468 Generic Host Process for Win32 Services MS Corp

spoolsv.exe 520 Spooler SubSystem App Microsoft Corporation

avgamsvr.exe 560 AVG Alert Manager GRISOFT, s.r.o.

avgupsvc.exe 576 AVG Update Service GRISOFT, s.r.o.

avgemc.exe 600 AVG E-Mail Scanner GRISOFT, s.r.o.

hidserv.exe 632 HID Audio Service Microsoft Corporation

MsgAgt.exe 696 Promise Message Agent Promise Technology, Inc.

regsvc.exe 720 Remote Registry Service Microsoft Corporation

MSTask.exe 760 Task Scheduler Engine Microsoft Corporation

stisvc.exe 840 Still Image Devices Monitor Microsoft Corporation

ULCDRSvr.exe 884 ULCDRSvr Ulead Systems, Inc.

VC5SecS.exe 936 Virtual CD - Security Service H+H Software GmbH

WinMgmt.exe 956 Windows Management Instrumentation MS Corp

svchost.exe 944 Generic Host Process for Win32 Services MS Corp

lsass.exe 256 LSA Executable and Server DLL (Export Version) MS Corp

Ati2evxx.exe 1096 ATI External Event Utility EXE Module ATI Tech

Explorer.EXE 1212 Windows Explorer Microsoft Corporation

VC5Play.exe 1332 Virtual CD - Player H+H Software GmbH

VC5Tray.exe 1480 Virtual CD - Quick Start Utility H+H Software GmbH

HPLamp.exe 1348

avgcc.exe 1356 AVG Control Center GRISOFT, s.r.o.

jusched.exe 1368 Java Platform SE binary Sun Microsystems, Inc.

SOUNDMAN.EXE 1396 Realtek Sound Manager Realtek Semiconductor Corp.

mozilla.exe 332 Mozilla Mozilla Foundation

procexp.exe 1472 1.56 Sysinternals Process Explorer Sysinternals

uTorrent.exe 1268

-----

Previous versions have run fine with the same setup.

MS & ATI names edited for readibility, no other changes.

EDIT : System is Win2k Sp4 W/RUv1v2

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...