Jump to content

Adding uTorrent as a service in Vista


Recommended Posts


I've been doing some research into this and i'm finding it difficult so if anybody has any tips on how to achieve this that would be great. I'll explain what I've done so far.

There's a few articles out there about doing this in XP where you use the Windows 2003 toolkit to create the services entry and then do a bit of hacking in the registry.

Anyway I thought I'd try something similar in Vista. The main reason for this is that I'll be able to administor uTorrent from my laptop or at work whilst the desktop Vista machine is running with anybody logged in (there are 3 users of the machine with seperate accounts).

Here's what I did.

1. Got the WebUI installed and working ok when running uTorrent as normal.

2. Used trial version of FireDaemon to install uTorrent as a service.

3. Opened regedt32 and replaced the links to the firedaemon entry with uTorrent as I don't want to use FireDaemon to run this.

So now I see a service installed for uTorrent, I've played around with the user settings so that it's been tried with an Administrator and the LocalSystem accounts with both desktop interactive checked and unchecked.

When the service tries to start it bombs after about 30 seconds with an error about the service not responding to a start or control request (error 1053). In trying to figure out what was going on I discovered that with the interact with desktop checked on LocalSystem that a warning flashed up, which when clicked switched to the uTorrent client interface on a blue background (not the normal desktop). After the service manager indicates the 1053 error I get returned back to the desktop and the UI disappears again. OK so I switch it back to running as Admin so this doesn't happen but whilst the service is "starting" I can use the WebUI no problem until the serivce manager indicates the error and stops the serivce.

I'm going to look at writing some kind of wrapper for the .exe and hopefully this will work, but if there's a simpler workaround I'd like to hear about it. I'm using Vista Ultimate and have the most recent version of uTorrent installed.


If I get this working I'll post how I did it here and any code I use for a wrapper.

Link to comment
Share on other sites

I've started investigating coding it myself.

I've got as far as writing a service wrapper and installer which can stop and start a process (uTorrent in this case). Unfortunatly I'm on XP whilst I do this so I'm hoping that this wrapping solution will work but given that I'm effectively doing what FireDemon does without a nice administration dialogue I'm hoping it will work on Vista too.


IT WORKS!!!!!!!!!!!!!!!!!!!!

If anyone is interested in doing this I can supply the setup.exe that I created for installing the process runner send me an email from the profile page. It needs .NET Framework v 1.1 and the service pack update to be installed.

I wanted to add in the executable as the start parameter in the service but it doesn't seem to work properly so I hardcoded in utorrent.exe as the wrapped application. I might have a look at changing this if I have time.

Link to comment
Share on other sites

SvrAny will do the job too. I have running uT on 3000 desktops (at the end 6500) as a service on Vista and on XP. It is not possible to start uT as a service without the wrapper. I have tried this too for several times. Maybe worth a request for a real service support??

Link to comment
Share on other sites

  • 1 month later...
  • 10 months later...

Sorry for the kick of the topic. But it has exactly my problem but not a fix for me.

When i try to start utorrent as a service aftter 30 seconds it says it can not start (although webui is working during that time). So i have to switch to the gui of utorrent to probably klik on a message or something. But i cant.. i tried the boss-key, running as different users, interacting with desktop and all that.

Is there a way to start utorrent without mesages (a startup parameter) or anything else that could fix my not starting u torrent as a service?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...