Jump to content

Utorrent 1.7.2, Wine, and Linux compatibility issues


Recommended Posts

Dear Utorrent Admin,

I decided to upgrade to the latest Utorrent Client 1.7.2. I had been using 1.6.1 and it worked faithfully well. No problems at all. After having downloaded and launched 1.7.2 via wine; I decided to launch a torrent file and download a file. I was successful. However, when I right clicked it to delete it in the context menu (delete and delete torrent file) it only removed it from the list. I still noticed that file system registered( "df -h" and "du -sch" ) the size of the file in the directory but it was not viewable via "ls -l" or "ls -la". It was really strange. It was as if it only partially removed the inodes? I was able to confirm the OS could still see it using the "locate" command. The "find" and "grep" commands failed. To make a long story short, I decided to reinstall the OS for good measure and experiment to see if I could replicate the error. I like to experiment.

This is my current linux build:

[root@Plutonium Desktop]# cat /etc/redhat-release

CentOS release 4.5 (Final)

[root@Plutonium Desktop]# uname -a

Linux Plutonium 2.6.9-55.0.2.EL #1 Tue Jun 26 14:08:18 EDT 2007 i686 athlon i386 GNU/Linux

[root@Plutonium Desktop]# rpm -q wine


[root@Plutonium Desktop]#

Well, I wasn't able to replicate the error because Utorrent is no longer able to connect to any torrents. It launches but doesn't connect. I checked throughout the utorrent preferences options and saw nothing that would prevent me from downloading. I checked my firewall via "lokkit" and saw no setting blocking it. I checked my internet connection with is fine and my NIC is functioning in "ethtool eth0":

Settings for eth0:

Supported ports: [ TP ]

Supported link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full


Supports auto-negotiation: Yes

Advertised link modes: 10baseT/Half 10baseT/Full

100baseT/Half 100baseT/Full


Advertised auto-negotiation: Yes

Speed: 1000Mb/s

Duplex: Full

Port: Twisted Pair


Transceiver: internal

Auto-negotiation: on

Supports Wake-on: pumbg

Wake-on: g

Current message level: 0x00000033 (51)

Link detected: yes

I am at a loss as to what and where the problem might be. Since the operating system is working then I am going to rule that out for now. Therefore that leaves Wine and Utorrent 1.7.2 to be in conflict. I am going to try compile wine from source ( dependency hell and all that ) to see if that is the resolution. I hope I have provided the correct information. I know this is long winded but I am interested in solving the problem. An intelligent response would be appreciated. Thank you for your time. I hope someone will want to touch this.



Link to comment
Share on other sites

Thank you Ultima for responding. The problem was entirely a Wine and Linux issue and what a headache it was. Here what I did to solve it( I wrote this yesterday). I hope someone will read this post thoroughly and benefit from it. Thank you.

Dear utorrent Admin,

I managed to get utorrent 1.7.2 to run successfully after some serious Wine compiling. I first started by downloading and compiling the latest source code from Wine's main website which is wine-0.9.42. After running "./configure && make depend && make", I took off to have some breakfast and read the news. When I came back it errored out stating failed dependencies for a gui launcher. Ouch!

I decided that maybe I should narrow my wine installation to my version of CentOS 4.5. Since my YUM updater repository didn't include a wine package I had to add an extra repository to to my /etc/yum.repos.d/ directory. I followed directions from this website to help me with that: http://centos.karan.org. It was enlightening.

After downloading wine via "yum install wine"; I launched a terminal and ran "winecfg". Wine launched its GUI console; however, it had no fonts for any of the tabs, LOL! I had the GUI console memorized beforehand so it wasn't to much of a hardship. I managed to track down a webpage on how to repair those fonts on website: http//corefonts.sourceforge.net. I had a hunch that repairing the broken Wine fonts was much easier than the previous directions; so I recompiled Wine with the original source code. I walked away and let the machine do it's job for awhile with my fingers crossed.

I came back later and relaunched "winecfg" and behold; it worked! My tab fonts were back. I then started Utorrent. I launched a torrent file and was able to start downloading immediately. I did hit a wall a minute later. Utorrent gave me an error message stating: ERROR: Access Denied. My heart sank. I combed through the Utorrent settings and found nothing in conflict to cause this error. I ;then, looked up Utorrents toubleshooting notes about this type of error and voila! It was literally a permissions problem. The folder was set to (0755/drwxr-xr-x). I set it higher value with "chmod". I have been successfully using 1.7.2 since.



Today 8/3/07 10.51am

Apologies, Ultima for not understanding your response. I lost my focus trying to get Utorrent working under Wine that I forgot that deleting downloaded files is still a problem. I did uncheck the "move to trash option" under the remove button. However, I am back to the same problem. The files appear removed in the Utorrent window and the directory via "ls", "ls -l", "ls -la" but are visible to the "locate" command and the "df -h" option. Weird stuff. I think this might be a bug in Utorrent 1.7.2 since it wasn't under 1.6.1?

8/3/07 11:

Problem Solved for now


I solved the problem of the deleted but undeleted files issue. Since only the "locate" command and df -h could verify my beliefs; I read the STDOUT of "locate" more slowly this time via "|less" option. You can also do locate "filenamehere" | tail and get the same effect. I managed to catch these directories at the end of the STDOUT:

/home/mydirectory/ .local/share/Trash/info/"myfilennamehere"

/home/mydirectory/ .local/share/Trash/info/"myfilennamehere.torrent"

Then I used du -sch * to verify the file size which was correct. I then cd'd into the Trash directory to view the contents and it was all there. I went online to verify ./local/share/Trash problems and there was plenty of information available. I solved the problem by deleting the "files" and "info" directories there via "rm -rf *" command and that reclaimed the disk space used. I knew at this point the problem was fixed.

Since Wine is a Windows emulator; I guess Utorrent isn't completely functional under CentOS 4.5. Some features work ( the most important ones ) and others might be broken or partially functioning like the remove option. I finally came to that realization after all that, =8^0 whew!. Sometimes ignorance isn't bliss. In the future I'll let Utorrent do the downloading and use Linux to delete the files. It's a recipe now sure to work. Good day and thanks Ultima for keeping me on track with the original problem!



Link to comment
Share on other sites

thanks Ultima for keeping me on track with the original problem

lol :P

I remember seeing a problem like this a long time ago, but it was before 1.7.x even... I don't remember what I did, but looking into some Trash directory looks familiar. You definitely didn't have to do this for 1.6.x?

Link to comment
Share on other sites

Hello Ultima,

No, I never had to do much of anything with version Utorrent 1.6.1. It worked the moment I launched the program(under Wine of course) without a hitch. The context menus( right click the file and select) appeared to be fully functional? Whenever a torrent or torrent file was downloaded and needed to be deleted; I used the Utorrent application to remove it. Before all of the confusion, I was using Wine 9.22 with Utorrent 1.6.1. I only upgraded to version 9.42 after having problems with Utorrent 1.7.2 hoping it would be the fix. It wasn't. It's very confusing. Since I had to troubleshoot both the OS, Wine, and Utorrent; I makes me think the problem lies with the middleman, Wine. Perhaps, I'll experiment on another distro to replicate the problem sometime during the week. Have a good weekend.



Link to comment
Share on other sites

Hm, now that I think about it again, I'm not so sure it was before 1.7.x that I noticed the problem...

There were lots of tweaks to the way µTorrent deleted files so that it wouldn't lock the interface up while deletes were going on during the 1.7.x branch. Probably in the midst of all those changes, compatibility with Wine was broken somewhere? At any rate, I still think that if it works fine on Windows 98 and XP, it should work fine on Wine. If it doesn't, then Wine needs to (re)implement *something* correctly :P

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...