Jump to content

net.outgoing_port, net.outgoing_max_port and WINE


Recommended Posts

I am running uTorrent 1.7.2 on CentOS4 with WINE 0.9.24 using Windows XP emulation. I have also tried Windows 2k emulation related to this problem.

I have set net.outgoing_port to 10000 and net.outgoing_max_port 10004. One thing I notice is, when I set these options, they become *10000 and *10004 respectively. None of the other options I have set do this. Does this mean they are not usable? If they are usable, I do not believe they are working. I have ran wireshark (ethereal) and the ports used by torrent are still random (for outgoing).

This is very frustrating. I want to restrict uTorrent to a specific range of outgoing ports as I have traffic shaping implemented on my router. It doesn't do me much good to have traffic shaping if I am unable to control a given application. And no, I cannot simply limit it by IP. If I did that, I would (virtually) kill the connection on the router, which is even more pointless.

If anyone could provide some insight as to why this isnt working I would greatly appreciate it.


Link to comment
Share on other sites

Well, as someone who doesnt develope uTorrent and has very limitted experience with WINE, I would have no way of knowing if it is indeed a WINE problem.

All I know is this: I have net.outgoing_port set to 10000 and net.outgoing_max_port set to 10004, and in my logs I get this:

[00:10:49] : Connecting: port 62222 source: HX

[00:10:50] : Connecting: port 21012 source: T

[00:10:50] : Connecting: port 45690 source: T

[00:10:50] : Connecting: port 8824 source: T

[00:10:51] : Connecting: port 16881 source: T

[00:10:53] : Connecting: port 47709 source: T

[00:10:53] : Connecting: port 4662 source: TX

[00:10:56] : Connecting: port 47220 source: T

[00:10:56] : Connecting: port 6881 source: T

[00:10:56] : Connecting: port 48410 source: T

[00:10:56] : Connecting: port 24375 source: T

[00:10:58] : Connecting: port 57807 source: THX

[00:10:58] : Connecting: port 39578 source: TX

[00:10:58] : Connecting: port 31834 source: THX

[00:10:59] : Connecting: port 22562 source: T

[00:11:01] : Connecting: port 63754 source: TX

[00:11:02] : Connecting: port 24744 source: T

[00:11:04] : Connecting: port 64233 source: T

[00:11:04] : Connecting: port 46512 source: TX

[00:11:04] : Connecting: port 6881 source: T

So either uTorrent isn't honoring the ports for some reason, or there is a compatiblity issue with WINE that needs to be addressed.

Any help is greatly appreciated as this feature not working for me is really screwing with my network stability.


Link to comment
Share on other sites

Ok, I can accept that. Maybe the logging should display the port uTorrent is using to connect from. Might clear stuff like this up.

I ran wireshark for a brief moment and the filtered everything cept uTorrent traffic out.

http://www.vadtec.net/uTorrent.wireshark (saved in wireshark/tcpdump libpcap format)

Have a looksie if you want. Some of it was from the right ports, but most of it was not. And yes, there are a few things in there that didnt filter out. But I checked most of the ips in the Destination field against my logging and they matched. (forgot to save the loggin from uTorrent)

I guess if I have to Ill just use uTorrent with BW limitting on. Oh well.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...