Archived

This topic is now archived and is closed to further replies.

Firon

µTorrent 1.7.7 released

Recommended Posts

I have reports from ADSL users they have very high decrees of d/u performance with rate 8/1(512/64Kb). I redirect them to bit calculators but with no + effect on performance do we have any solution for that problem or should I suggest them to change type of connection with better rate 4/1(512/128Kb) or 2/1(512/256Kb) which I prefer more than 8/1(512/64Kb)?

Share this post


Link to post
Share on other sites

All the "bit calculators" are based on upload speed. Just increasing the download bandwidth only increases the potential to download faster...it doesn't guarantee it!

If you're only uploading at ~100 KiloBYTES/sec max (about all that's possible with 1 megabits/sec upload bandwidth), then you'll likely only see about 2x that in download speed on "average" torrents that don't have lots of seeds per peer...even if your line is capable of 4x (8/1) that speed.

Share this post


Link to post
Share on other sites
On the other hand, if you are done downloading and are only uploading, you're not quite a leecher. You're an un-person.

There are no leechers. Only seeds and (other) peers.

The fact is you don't have all the pieces and even though you might (you could always enabled a file you filtered out before) be done downloading no other peer (with the exception of peers that excluded the same files as you) would consider you a seed. Your viewing this whole thing from your own perspective instead of looking at the whole swarm.

Also I agree with system that because partial downloads aren't part of the specification 'completed' can safely be assumed to apply to the whole download.

Share this post


Link to post
Share on other sites

Just wanted to say thank-you for this wunnerful little program. I'm running 98SE on a Presario 5012, and the simplicity and small footprint of uTorrent allow me to leave my PC on day & night without worrying about lockup. Bless all of you who had a hand in birthing and raising it!

Share this post


Link to post
Share on other sites

Just to tell you that I have downgraded to 1.7.4 because since I've installed 1.7.5 my up/download speed had decreased enormously and I cannot do anything else at Internet at the same time (as my whole bandwith was used by utorrent). Even being compeltelly ignorant about tecnic details I supose this must comme of a bug, because I have checked the firewall and ports are open and no other change has been made in my sentings between one version and another.

Share this post


Link to post
Share on other sites

Die Spinne

I have the exact same problem. Ever since upgrading to 1.7.5 utorrent eats all my bandwith up. I can not search the web even if I have it at low upload speeds.

Share this post


Link to post
Share on other sites

The 1.7.5 cannot allow the seeder to connect to my computer, only connect for a while and disconnect and repeat again after a while. The seeder cannot seed as well, only the leecher can seed to my torrent. the old torrent don't have this problem. The seeder 1(2) is shown. The old torrent always 2(2).

Share this post


Link to post
Share on other sites

Well, before posting i took your advice about removing the firewall rules. It didnt work. Before upgrading to 1.7.5 i had no problems but as soon as i upgraded i can't connect to any torrent. It tells me the target machine actively refused it on EVERY torrent. I have the same ISP, I removed the firewall settings and re-entered them on both my windows firewall and my wireless network and I have restarted my pc each time but nothing changes. I can't get Ut to work, any suggestions?

Share this post


Link to post
Share on other sites

vdub2 wrote:

i took your advice about removing the firewall rules. It didnt work. Before upgrading to 1.7.5 i had no problems but as soon as i upgraded i can't connect to any torrent. It tells me the target machine actively refused it on EVERY torrent. I have the same ISP, I removed the firewall settings and re-entered them on both my windows firewall and my wireless network and I have restarted my pc each time but nothing changes. I can't get Ut to work, any suggestions?

I am having the same problem. I'm using trend micro's virus buster, is this the problem possibly? Is it possible to download the old version and try it?

Share this post


Link to post
Share on other sites

Sorry I forget to notice people that ISP changed minimal type of connection from 4/1(256/64) to 8/1(512/64) and everything what is depend of upload become a problem and this is not a problem of utorrent 1.7.5.

On the other hand I update from 1.7.4 to 1.7.5 on 3 of my fast servers for seed our software products and didn't find any problem.

As network ing. and administrator I don't use any kind of firewall cause all new routers have lot of functions of firewalls there is no need for filtering traffic which is all ready filtered.

I have a case 3 weeks ago , lamer install Kasperski 7.0 and block all p2p traffic my only suggestion was to uninstall and he's problem was solved . All new antivirus products have some kind of firewall be very careful with anything what have firewall .

Share this post


Link to post
Share on other sites

I'm having the same problem to stay connected.Sometimes the icon don't even show up.Tried many times with firewall rule but no sucess.With too many complains about the same problem,this only can be a bug.But I like Utorrent anyway,sh...happens.

Share this post


Link to post
Share on other sites

Suggestion for those having speed/port problems after updating (the same thing happened to me): In [options] [preferences] [connections] press [random port] and then update the port forwarding rule for your router to reflect the new port. My speed immediately returned to normal.

Share this post


Link to post
Share on other sites

Yep, that'd fall (somewhat) under the "recreate your firewall rules" suggestion that we give people whenever new versions come out :P It doesn't make sense that the router rules would have to be changed, though, as the router doesn't get affected by a version change; only a software firewall local to the machine might.

Share this post


Link to post
Share on other sites

I understand and completed those changes before posting. I have even uninstalled utorrent, removed all router and firewall rules restarted the pc then reinstalled utorrent and re-added new firewall and router rules with a new port # and it's still not working. I will seriously pay money to the person who can get this fixed for me.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.