Jump to content

utorrent and WD Elements 500GB


Recommended Posts


I recently bought a WD Elements drive and I have encountered a serios problem. I am not really sure if this question is supposed to be adressed in this forum but I might as well give it a shot cause the problem only occurs while using utorrent.

It started 2 days ago while i was downloading a pretty huge torrent, suddenly windows gave me a "delayed write error". I started the torrent again and after awhile the toorent stopped with the message "The request could not be performed because of an I/O device error".

I deleted the torrent but i seems like this has corrupted a couple of RARs on the drive. Two torrent that i downloaded at the same time as trhe one that gave me the error are now CRC damaged. All the files that i had downloaded earlier still works and i have managed to download torrents afterward that works.

I ran a test on the HD and the RAM and they both passed. WD have their own Diagnostic tool that confirms that the drive is running properly. The WD diagnostic tool is however unable to give me the SMART status of the drive.

All this may seem like a small problem since I am able to download torrents, but whenever I try to download the exact torrent that gave me the error it always stops at 0.1% with the same error message and no one else is experiecing this problem. Isnt that wierd????

Any suggestion? I also have 320GB WD MyBook and I have never had any problems with that drive. I am on Win XP btw.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...