Jump to content

Can't connect torrents: "procedure call table is invalid"


Recommended Posts

Hi all!

Finally I moved on to Vista (32), and there's only one more program to adjust: utorrent.

On XP SP2, I did the port forward thing and it always work flawless, so with those configs kept, I tried on Vista.

I tried some torrents, but all I got was an error: "procedure call table is invalid". And the torrent wont connect. I checked the port test and it failed. Then I ran to XP and it was working (same port, same configs).

Vista again: I tried again and unnistaled uTorrent and then reinstalled it. When the program was running for the first time, the port test indicated a green working port and my torrents worked. But from the moment I closed the program, the port test was always red and the torrent wont work, then I open the program and it wont work anymore, unless I unninstall and reinstall it, and work just the first time! I did the thing (unninstall, reinstall, test, close program, test, open program, test) a lot!, and the result was the same.

Before I forget, firewall disabled and all.

Please, any help?

Link to comment
Share on other sites

Hello Ultima, thanks for the reply.

I did it manually. I tried disabling almost everything.

Searching, I googled a site with some more info related with this case.

"Winsock error:



Procedure call table is invalid.

The service provider procedure call table is invalid. A service provider returned a bogus procedure table to Ws2_32.dll. This is usually caused by one or more of the function pointers being NULL."

I installed the newest Realtek Lan driver (by the way: P5B, realtek onboard LAN driver 8168B + d-link router 502g).

I googled and googled but there's no event like this. I'm lost and really want to leave my Vista running µTorrent.

(Just in case: tried others torrents clients and no sucess. Well, I think it's good not to be forced to use other client than µTorrent)


After a LOT of google searching, I finally found a fix solution:

"TCP/IP stack Winsock settings in Windows Vista may get corrupted, causing errors and problems with Internet connectivity. Corrupt Winsock or Windows sockets configuration can be due to a lot of reasons such as installation of a networking software, or due to virus, trojan or malware infection, or sometime even due to disinfection of spyware by security software.

When Winsock corrupts, the networking errors that you may face include unable to surf the Internet with "Page cannot be displayed" error message in Internet Explorer or AOL even though the DSL/ADSL/cable Internet connection is connected. Sometimes, Windows Firewall/Internet Connection Sharing (ICS) service is terminated as well.

To repair and reset the Windows Vista

1. Click on Start button.

2. Type Cmd in the Start Search text box.

3. Press Ctrl-Shift-Enter keyboard shortcut to run Command Prompt as Administrator. Allow elevation request.

4. Type netsh winsock reset in the Command Prompt shell, and then press the Enter key.

5. Restart the computer.

What netsh winsock reset command does are it resets Winsock Catalog to a clean state or default configuration. It removes all Winsock LSP (Layered Service Providers) previously installed, including the potential malfunctioned LSP that causes loss of network packets transmission failure. So all previously-installed LSPs must be reinstalled. This command does not affect Winsock Name Space Provider entries."

There you are, one more for our database.

See ya!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...