Jump to content

Maybe my processor is too FAST? Terrible speed issue.


Recommended Posts

My speed seems to cap around 32kB/s. I have never gotten over this, except on other computers.

My laptop has no problem downloading 300kB/s with the same settings between uTorrent, plugged in to the same ethernet port.

This new computer can download 300kB/s through internet explorer/firefox, and upload 100kB/s through ftp. It can do this and has no browsing issues even while uTorrent is open.

My processor is an Intel E6850 (2x 3ghz, overclocked to 4.2ghz, but the problem is the same at stock clockrate).

I have 4GB of RAM, 2GB of it in a ram drive.. this was happening before I created the ram drive

My router is 3wire brand.

My ISP (Telus/Canada) does not throttle torrent bandwidth.

I have tried with protocol encryption on and off, including legacy connections both ways.

Speed guide - Affected Settiles: Upload Limit 5kB/s (while testing) Upload Slots 10 Connections 50 Connections(global) 300 Max active torrents 8 Max active downloads 5

Checking port 35939 on

OK! Port 35939 is open and accepting connections.

Green checkmark on the status bar.

Tried with UPNP on and off (manual port forwarding)

If I have multiple torrents running, the 32kB/s is split between all torrents, not per torrent. Download rate unlimited. Tried with DHT on and off.

Peer transfering has the same speed issue with my laptop having the other file nearly completely downloaded..confirmed it is a peer. This works between my old desktop and my laptop to transfer 2+ mB/s

I do not get negative pings.

This is for any torrent, any tracker. Including private trackers, linux ISOs, large amounts of seeds, etc.

TCP hack set to 1000 max half-open.... uTorrent set to 8 on both computers.

No firewalls or AV applications installed. Hijackthis shows a clean system.

Even more curious is that all connected peers seem to give the same transfer rate... either 0.4k/s or 0.5k/s depending on when it was updated.


Please help! Thanks

Link to comment
Share on other sites

Bad µTorrent settings are causing "Download Limited".

Try running Speed Guide (CTRL+G) and choose a setting that matches your UPLOAD bandwidth in kilobits/sec.

You might want to restart the forced torrents regularly -- those override at least some settings limits.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...