Jump to content

Web UI refuses to work on multiple clients, FF plugin partially works


Recommended Posts

Note: this is resolved.


Running uT 1.7.5 4602 on my fileserver, and 1.6.1 (because a private tracker isn't allowing the more recent versions) on my PC, but that's only for occasional use, I'm focusing on the fileserver here.

I've tried everything I can think of, but I can't get the Web UI to work properly. The zip's in the right place (the uTorrent folder), any and all ports are forwarded, making sure that no two ports clash, and a username and password is configured.

If I try http://server:5000 I get "invalid request" - if I try with /gui it prompts me for user/pass then displays nothing at all. This is happening on my fileserver (WS2003) and my PC (2000SP4).

The FF Web UI Plugin is installed and currently partially functioning on my laptop - i.e. it's showing the current DL/UL stats in the status bar, and if I hover over it I can see the torrent statistics - so that's working great. However, the sidebar (which is just loading the Web UI in the frame) still displays nothing.

The FF plugin's debug pane shows the array of torrents with their hashes, so I know the Web UI is enabled and my machines can access it... I just can't get any kind of Web UI at all!

I've tried with FF2.0.0.8, IE7 SP1 and even the great unwashed IE6, I've followed installation instructions to the letter, retried them, tried them again a different way just to make sure, and nothing makes it work.

The fact that I can't get it to work on multiple machines with multiple versions of uT points me to the fact that something's awry with the actual Web UI code itself. Can someone help me here? I'm just using webui_v0.310_beta_2.rar, the one linked from the top of the sticky and the one reached via clicking on the Public Beta banner on the utorrent.com front page.

This problem's driving me barmy! Any help is appreciated.

[techy info]

Wireshark capture of the client-server traffic shows something interesting: content-length is 0 unless I specify ?list=1.

GET /gui/ HTTP/1.1

Host: server:5000

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv: Gecko/20071008 Firefox/

Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5

Accept-Language: en-gb,en;q=0.5

Accept-Encoding: gzip,deflate

Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Keep-Alive: 300

Connection: keep-alive

Authorization: Basic <snipped ;)>

HTTP/1.1 200 OK

Connection: keep-alive

Content-Length: 0

Content-Type: text/html

... ?list=1 returns what you'd expect:

HTTP/1.1 200 OK

Connection: keep-alive

Content-Length: 10001

Content-Type: text/html

Cache-Control: no-cache

{"":"","label": [



,"torrents": [

... and so it continues.

[/techy info]

What am I doing wrong? Please help.



Link to comment
Share on other sites

Note to self: don't try and do seemingly simple installations at 5:30am in the morning, it's doomed to failure.

Right, if you'll excuse me I have to go put on my Captain Obvious cape.

For some reason my brain never made the association with %appdata% and docs and settings\utorrent - maybe that should be spelt out for the people like me who think they've covered all the bases but are, in truth, way off :( Thanks for the reply man. ;)

Link to comment
Share on other sites



But its true this webui install isn't newb proof.

In our current age of simple installs and obvious manuals its hard to get people to carefully read and explicitly follow instructions :P

Lets just say its still (!) beta and thus still aimed at the more computer savvy people amongst us. And even then a chronic misread can happen to the best of us.

Link to comment
Share on other sites

A "chronic misread" would be an apt description for how I feel my brain is functioning these days... I'll have to use that one again ;)

I checked the Web UI page again - and nowhere does it say on the page that you have to place the file in the app's appdata dir, it just says that "everything you need is in the one file" - maybe a mention of this up the top of the readme would be useful for people like me who just completely miss the mention of where to put the file! :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...