Jump to content

Speed Issues


Recommended Posts

i've looked for answers but none have been found...

i just don't understand why azureus can dl at 300k and why utorrent will only dl at maybe 10k.

Torrent Stats:


Seeds: 51(305)

Peers: 16(81)

DL avg: 10.1k

UL avg: 10k (max i set)

Lunar Bleach 1-50

Seeds: 13(15)

Peers: 22(57)

DL avg: 6.2k

UL avg: 10k (max i set)

Network OK on both

DHT gets peers on both

UPnP enabled on both

Ports tried: 10625, 37891

Max UL 10k (my max is 32K)

Max DL 300k (my max is 364K)

Max Global Connections 250

Max per torrent 100

Max upload slots per torrent 5

tried both with and without the peer.lazy_bitfield enabled

i'm behind a d-link router. the ports are forwarded and the firewall has a rule to allow those ports to my ip.

no firewall is turned on

NOD32 is my AV, IMON is set to high effiecency for utorrent and azureus

with azureus i get 243k avg DL on OpenOffice and 267k on Bleach

any ideas on or help on this would be welcomed. cheers

Link to comment
Share on other sites

You still say that you see "Network OK" in the statusbar, so that shouldn't be the case. Run this thing to verify that everything is like it should:


Also, follow every step in this guide to make sure the portforward is correct:


I'm not saying that you don't know how to do it, but most of the times, this is the cause of the problems. And I don't know what model the D-Link router is, so I just pasted the most common one. I think the config looks the same in most wired D-Link routers.

Edit: And about no remote connections: Please make sure that the Windows Firewall/Internet Connection Sharing (ICS) service is stopped.

Link to comment
Share on other sites

so the first link works fine.

and the port is forwarded just right, there is even an exception rule on the routers firewall...i have left myself completely open on the main port that i am using.

i just dont get this then, if everything is fine why i do 10k max on utorrent

Link to comment
Share on other sites

well i feel like i talk to myself on here, but some more developments

so i know my upload works fine, i can limit at anything upto 50k and it will upload at my max (U in the flags)

now downloading is another story, i have noticed that when i start the torrent i will initially download at very high speeds from the peers as i connect to them, but after only a few seconds of great speed i drop to 1k or less. the Peer Flags go from D to d in no time at all.

btw, i have also tried the OpenOffice torrent on many different clients now:

bittornado = 270k avg

bitcomet = 385k avg

azerues = 319k avg

bitlord (i know this one is lame) = 264k avg

utorrent = 12k avg

UL on all the clients was set at 30k

i just dont know what to do, i have fucked with basically everything i can. oh yeah the other clients took NO TUNNING other than changing the port.

Link to comment
Share on other sites

Attempting connect to: *.*.*.* port *****


The connection was successful but a timeout occured reading or writing the BitTorrent client data.

this is from that first link, i worked fine last night, but this morning it started this.

I see NETWORK OK still too.

Link to comment
Share on other sites

When troubleshooting things like this, it is best to get as much complexity out of the way as possible. Here are some ideas (for testing purposes)

- disable UPnP and have everything manually forwarded.

- take the router out of the way (and have only Windows firewall, for example).

- disable NOD23, IMON, IP blocker, whatever else...

- disable advanced features in your D-Link (gaming mode, UPnP, PPTP, IPSec, ...)

By progressively turning things off you get a better chance of finding the culprit.

I'm assuming you created a direct firewall rule in your D-Link, DON'T use the "Virtual Server" feature, I find it is not reliable.

Link to comment
Share on other sites

UPnP is disabled, i did this right away

i have removed the router, same speeds with utorrent

Windows Firewall is never on

I have no person Firewall on

NOD32 and IMON have been disabled with no difference

just tried your last suggestion and disabled those advanced features, but still nothing new. the torrent still goes slow

and yeah its a direct firewall rule :-p, that virtual server is crap

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...