Jump to content

uTorrent kills my internet speeds


NavyTweak

Recommended Posts

First, this is only a recent problem (maybe 2 or 3 weeks).

Basically, when I have torrents downloading/uploading, my internet browsing slows to a major crawl. For instance, right now I have one torrent seeding. Uploading a little over 100KB/sec, connected to 20 peers... and my internet speed is horrible.

For reference, I'm on a 1Gb/sec fiber optic connection, and have had no problems in the past with browsing performance, even when uploading/downloading at over 10MB/sec. Until recently... now, just having one torrent going kills my browsing performance.

I've tried using different browsers (opera, firefox, IE), but nothing changes.

I've gone through the speed troubleshooting guides and followed all recommendations there for tweaking uTorrent, but nothing seems to have helped.

Any ideas?

Link to comment
Share on other sites

Well, I've basically confirmed that the issue does, in fact, originate with uTorrent.

Just to try something else, I went back to Azureus to see what would happen. I'm currently downloading 3 torrents at around 1.5MB/sec, and my internet browsing is good as new.

Any ideas when the next version of uTorrent will be released?

Link to comment
Share on other sites

DWK:

- Network status light is green.

- Port checker says port is ok and allowing connections.

- Speed guide is currently set for 20Mbit (tried everything from 1Mbit to 100Mbit.. no change)

- net.max half open set to 8 (tried switching to 4, no change)

- OS is Windows XP SP2

- No firewalls or antivirus software installed (use Housecall web-based virus scan)

- AdAware installed (last scan was 2 days ago... only cookies)

- No router, and no model number than I can find on the modem (Japanese NTT modem)

- ISP is HeroNet (infoaomori.ne.jp)

- Connection type is fiber optic

- Speed test results from Yokohama (recommended hub on speedtest.net) are 15879 kb/s down, 4889 kb/sec up.

- Motherboard is Asus K8V-X

- CPU is AMD Athlon 64 3400

- RAM is OCZ Platinum (2GB)

- Primary drive is a WD Raptor 74GB, 10000 RPM

- Secondary drive is a Maxtor 160GB 7200 RPM

Process Explorer:

Process PID CPU Description Company Name

System Idle Process 0 100.00

Interrupts n/a Hardware Interrupts

DPCs n/a Deferred Procedure Calls

System 4

smss.exe 608 Windows NT Session Manager Microsoft Corporation

csrss.exe 688 Client Server Runtime Process Microsoft Corporation

winlogon.exe 736 Windows NT Logon Application Microsoft Corporation

services.exe 784 Services and Controller app Microsoft Corporation

ati2evxx.exe 948 ATI External Event Utility EXE Module ATI Technologies Inc.

svchost.exe 964 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1048 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1156 Generic Host Process for Win32 Services Microsoft Corporation

InCDsrv.exe 1176 incdsrv Ahead Software AG

svchost.exe 1448 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1548 Generic Host Process for Win32 Services Microsoft Corporation

spoolsv.exe 1856 Spooler SubSystem App Microsoft Corporation

scardsvr.exe 1904 Smart Card Resource Management Server Microsoft Corporation

AppleMobileDeviceService.exe 1988 Apple Mobile Device Service Apple, Inc.

oodag.exe 176 O&O Defrag Agent (Win32) O&O Software GmbH

HPZipm12.exe 188 PML Driver HP

PnkBstrA.exe 252

svchost.exe 408 Generic Host Process for Win32 Services Microsoft Corporation

UAService7.exe 428 SecuROM User Access Service (V7). Sony DADC Austria AG.

alg.exe 1356 Application Layer Gateway Service Microsoft Corporation

iPodService.exe 2612 iPodService Module Apple Inc.

lsass.exe 796 LSA Shell (Export Version) Microsoft Corporation

ati2evxx.exe 1252 ATI External Event Utility EXE Module ATI Technologies Inc.

sdmcp.exe 1360 MCPServer Stardock

explorer.exe 1708 Windows Explorer Microsoft Corporation

CTHELPER.EXE 1468 CtHelper MFC Application Creative Technology Ltd

MBM5.exe 1540 MBM 5 Core EXE Alex van Kaam

hpwuSchd2.exe 1592 Hewlett-Packard Product Assistant Hewlett-Packard Development Company, L.P.

PDVDServ.exe 1636 PowerDVD RC Service Cyberlink Corp.

jusched.exe 1672 Java Platform SE binary Sun Microsystems, Inc.

iTunesHelper.exe 1756 iTunesHelper Module Apple Inc.

ctfmon.exe 1896 CTF Loader Microsoft Corporation

Azureus.exe 3760 Azureus Inc

procexp.exe 3248 Sysinternals Process Explorer Sysinternals

Opera.exe 3280 Opera Internet Browser Opera Software

Link to comment
Share on other sites

I just wanted to say that I have the same problems. It's become a habit for me to turn off uTorrent when browsing. There were many threads about this already, like this one for example. (Check my finding about the delay in achieving full UL speed with the browser. ;))

I also wanted to try with Azureus, but I got so turned away by the bloatware it is that I skipped that test. But I will try it in the next few days (or some other torrent program), just to see if it's related to uTorrent or not.

Link to comment
Share on other sites

Try these "CONSERVATIVE SETTINGS CHANGES":

Turn off DHT (both kinds).

Disable Resolve IPs under the Peers Window. (That's expensive window-dressing considering it doesn't help download+upload speeds any.)

Reduce half open connection max to maybe 1-4. (You're not firewalled in µTorrent, right? ...so it shouldn't hurt as much as you might think!)

Disable resolve country flags in advanced.

Disable "Enable Local Peer Discovery".

If you've manually port forwarded your router, or don't have a router, Disable UPnP in µTorrent.

Lastly, if nothing else helps, reduce total connections to 100 or less.

...maybe even as low as 20 per torrent, though 40 is probably better.

Link to comment
Share on other sites

Switeck:

DHT is already disabled, as most of the torrent sites I use require it.

Reducing half open connection max has no effect on my browsing (and yes, no firewall). Reducing total connections (both global and per torrent) has no effect either.

Everything else, I tried before my initial post here.

Ultima:

Last Windows Update was maybe a week ago (after this problem began).

I don't recall if I've ever "patched" TCPIP.sys, but I did tweak some settings a few years ago when I upgraded to a fiber line (MTU, RWIN, etc...)

I've talked with friends (local here in Japan, in the US, Australia, etc) and several of them are having the same problem... anything running in utorrent causes their browsing to slow down.

I'm not too worried about it, as I've found a temporary fix (Azureus) until the next release of utorrent is released as stable, but I do appreciate you guys trying to help out. I'll continue to try new suggestions (unless you suggest a reformat lol) as long as you provide them.

Link to comment
Share on other sites

Honestly, I'm not really sure what the maximum stable speed is, as it's never been an issue in the past. On average, though, I generally upload between 1-2MB/sec.

For reference, Azureus shows my current session stats (for the past 2 days) as 175GB uploaded, and I've had no browsing speed problems at all. My current torrents have slowed down a bit, and are currently uploading at around 600KB/sec.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...