Archived

This topic is now archived and is closed to further replies.

ludde

utorrent-1.2.3-beta-358 (Unicode)

Recommended Posts

This version of 1.2.3 works both with Windows 9x/ME and 2K/XP. Of course, unicode works only on 2K/XP.

Please note that significant changes have been made to the 9x/ME code (It supports both ANSI/Unicode from the same executable), so things might have broken.

The torrent maker wasn't working in the previous beta. The new beta also enhances support for chinese torrents.

Download it here:

http://utorrent.com/download.php

Share this post


Link to post
Share on other sites
... Of course, unicode works only on 2K/XP.

Of course smiley5.gif but we were counting on you to make it work on Win 98 as well using this ... :( What happened ?

So is there a real reason for Win 98 users to update from V 1.2.2 yet ?

BTW - I see that the notification thread is working well... ;)

Share this post


Link to post
Share on other sites

ludde doesn't want to make users have to download a 160KB dll. And it doesn't provide full unicode support anyway, I think.

And there is, various fixes, additions, and the client won't choke on UTF-8 torrents (I believe) even on 9x systems.

there's been a few new advanced options and whatnot, look around the FAQ to see. (it's updated already)

Share this post


Link to post
Share on other sites

I can say from personal experience that uT is not the first application that will be using this Unicode DLL on Win 98 . I had this file on my PC for ages... and I really cannot say for sure which app. has put it there... I don't think downloading this DLL should be a concern.

But since I'm curious in nature, let's try a quick survey in the "general" section - of how many have it allready...

Share this post


Link to post
Share on other sites

µTorrent doesn't use that DLL.

unicows does not give unicode to win98 apps, it just means you can use the same exe on win98 and winxp.... on win98, it will still be ANSI, and not unicode.

Share this post


Link to post
Share on other sites

basically, it's a unicode -> ANSI wrapper.

ludde decided to forgo the 160kb dll and just do it himself (it only increased the size <1kb), making it easier since no one has to install a DLL.

Share this post


Link to post
Share on other sites

As far as I know Unicode can work only on NT systems (NT/2000/XP). However it can work on Win95/98/ME systems, but you must implement some additional code to translate it to DBCS (double-byte character set) – which is compatible with ANSI, and is used to display Japanese, Chinese,… letters . Translation could be implemented, but in this case it would use significant amount of memory. Am I right?

Share this post


Link to post
Share on other sites

this one fixed a lot of minor stuff.

like the "utorrent" text under the "Help" tab and in the About... there is a copyrighted © and 2005 displays properly.

chinese characters are supported as well.

Share this post


Link to post
Share on other sites

Wow....i just had this beta crash hard on me. BSOD the moment i click to run it. Never happen on other builds before. Revert to 1.22 and worked fine.

I tried turning off my firewall (outpost), antivirus (kav), microsoft antispyware, same BSOD. No error message on BSOD also, just "Stopped: and some numbers".

Any ideas as to how can I find out the cause of this crash?

Share this post


Link to post
Share on other sites

Can you try with the beta again? What OS you on? Which service pack? And next time you should write down what the BSOD says if it happens again.

Share this post


Link to post
Share on other sites

ok, the exact error message is this:

"***Stop: 0x0000008E (0xC0000005, 0x80501CD0, 0xF11E955C, 0x00000000)"

I'm running XP sp2, stable Nvidia drivers 71.84 and SB Audigy 2 official drivers. Other than this I don't think I have any funny programs running in the background :)

Both utorrent 1.2.2 and 1.2.3b356 didn't crash.

Share this post


Link to post
Share on other sites

hmm, isn't so for me :P

Does all peers client names looks wierd or is it just a few.

If it only a few client names that looks wierd, then those could be fake/hacked/unknown clients.

Share this post


Link to post
Share on other sites
ok, the exact error message is this:

"***Stop: 0x0000008E (0xC0000005, 0x80501CD0, 0xF11E955C, 0x00000000)"

I'm running XP sp2, stable Nvidia drivers 71.84 and SB Audigy 2 official drivers. Other than this I don't think I have any funny programs running in the background :)

Both utorrent 1.2.2 and 1.2.3b356 didn't crash.

I've exactly the same BSOD with the last build, I'm using an ATI Radeon IGP 320M on Athlon XP, Windows XP SP2.

I cannot start at all the program, every time it gives that BSOD. Older builds works well for me too.

Share this post


Link to post
Share on other sites

I had clients with garbled names since day 1 (I had them in Azu as well)

These are hacked/faked clients

It's not µtorrent....it just displays, what these clients transmit...and the wannabe hackers obviously weren't capable of altering the correct bits :D:D:D

@ the guys with the BSOD...next time look down on that blue screen and write down, which file (usually a .dll) is involved

-DG

Share this post


Link to post
Share on other sites

I seem to be able to open multiple instances of the client, by clicking on the executive file or a torrent file that prompt the add torrent window. The only way to add torrent without opening another instance is either draging torrent files into the actuall utorrent window or using the add torrent function.

Share this post


Link to post
Share on other sites
ok, the exact error message is this:

"***Stop: 0x0000008E (0xC0000005, 0x80501CD0, 0xF11E955C, 0x00000000)"

I'm running XP sp2, stable Nvidia drivers 71.84 and SB Audigy 2 official drivers. Other than this I don't think I have any funny programs running in the background :)

Both utorrent 1.2.2 and 1.2.3b356 didn't crash.

WOW! :o Talk about old drivers! Update them to 81.95 WHQL if you can, or the most recent WHQL version available for your particular GPU. :)

Here's what WoW Technical Support has to say about your STOP error (follow the links for even more info):

http://www.blizzard.com/support/wow/?id=aww01662p

Sounds like your nVidia driver is the cuplrit... :|

Markuz Nightwind: try updating your driver too to the latest WHQL Catalyst. ;)

If these things don't help, try loosening your RAM timings a bit, I've seen it mentioned a few times somewhere...

Share this post


Link to post
Share on other sites
I seem to be able to open multiple instances of the client, by clicking on the executive file or a torrent file that prompt the add torrent window. The only way to add torrent without opening another instance is either draging torrent files into the actuall utorrent window or using the add torrent function.

Confirmed. I'm having this problem too. Beta-356 works fine.

Share this post


Link to post
Share on other sites

I tried running this beta on my Win98 SE (4.10.2222A) . It crashes right on startup with this "illegal operation" message:

UTORRENT-1 caused an invalid page fault in

module KERNEL32.DLL at 019f:bff8b0ff.

Registers:

EAX=00000000 CS=019f EIP=bff8b0ff EFLGS=00010213

EBX=00000000 SS=01a7 ESP=8314bf3c EBP=8314bfc4

ECX=ea1518c0 DS=01a7 ESI=81b21bec FS=4327

EDX=bffca320 ES=01a7 EDI=0044519c GS=0000

Bytes at CS:EIP:

89 18 e8 6d da 00 00 85 c0 74 0d 80 4e 14 20 8b

Stack dump:

81b21bec 81b598b4 81b53578 00560020 bff8b2ac 81b598b4 00000008 81b53578 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.