Jump to content

Strange behavoir with LinkSys WRT300N


Recommended Posts

I'm really sorry to be asking this, but I read everywhere in the forums and I can't find a solution to this situation... Out of desperation I even install a clean copy of Windows thinking that perphaps it was a virus.

Ok, to the specs:

Cable Modem 2Mb connection. ISP don't throtle BT

LinkSys WRT300N router (port forward correctly set up, and uTorrent says the port it's "open")

uTorrent 1.7.5

Windows Firewall disabled

The problem:

When I plug the cable modem to the router i get awfull speeds, say 2KB ~ 5KB

When I plug the cable modem DIRECTLY to the PC, I get 210KB ~ 230KB

I think it's also important to say that when connected to the WRT300N, I first get the "yellow" icon in uTorrent status bar, 2 minutes later it turns green. When directly connected to the PC, I get the green icon inmediatly.

Taking in consideration that the port forwarding it's ok, I really dont know what else to do...

- ISP has nothing to do with the issue (but I also try with "encryption" just to be sure, same result)

- the router is correctly configured for port forwaring

- uTorrent says that the port is open

Clearly, it's an issue with the router, but I dont know what to do :(

Any help will be appreciated.

Thanks in advance for taking the time to read this.-

Link to comment
Share on other sites

Immediate download speed like that without a router on the same swarm with the same peerlist suggests an overload of some kind.. number of connections, number of peers, number of torrents. I know many people run customized firmware on Linksys brand, so i would suggest starting there and researching the viability.

Then again other people may know about this specific 300N.

Link to comment
Share on other sites

It's not a swarm problem. I'm testing with very well seeded torrents, that's why i get that kind of instant speed.

I also tried with Slackware as suggested in the forum and the speed goes to 230KB in less than a minute.

There is no saturation (at least on uTorrent), also I'm testing with a clean installation with ony 2 torrents.

I'm pretty sure that the port forward ISN'T wroking (dispite uTorrent sayinf the port is "open") and that why it is going so slow when connected through the router.

Any suggestion on for what should I look on the customized formaware?

Thanks in advance.-

Link to comment
Share on other sites

Well i know its "WRT". I've heard of Tomato and HyperWRT.

Also, DISCLAIMER: be sure you know what you're doing when you flash your firmware.

Make sure it is a problem with the existing and current version of your firmware, as unauthorized firmware will probably void any warranty you have.

In any case, to verify port forwarding, all you need is incoming connections "I" in Flags column under Peers tab in a swarm. This will/should change the status icon in the taskbar to the green check, otherwise it should stay yellow.

Link to comment
Share on other sites

Pleas take a second a look at this images taken now... I'm connected through the router:


As you can see, the icon is GREEN, and there is some "I" flags (although I dont know what that means)

I know what you are thinking... "there aren't enough seeds"... wrong... this torrent was just downloading at 80KB ~ 90KB a minute ago when i was connected directly to the cable modem.


Here's the portforwarding configuration, and uTorrent says that 51999 ips OPEN

I'm really desperate with this :(

Link to comment
Share on other sites

OK A little about the Flags column, which says alot. I means incoming, which is what makes the icon go from yellow to green.

D means you can download from them, but S means they are snubbed. THIS page provides some more in-depth descriptions of those terms, as will the µManual in my signature.

Also i wouldn't dream of telling you the availability is the issue. I can tell this is a frazzling situation. Also please tell me you are on as far as i know forwarding the same port range to multiple IPs is a bad idea. Have you tried a smaller port range that is only being forwarded to your IP.

All I can tell you about the peer configuration as you're seeing it is wait for O to rotate through the D and hopefully S will be removed. I'm not sure on the interval on that.

Edit to include alternate firmwares from a guy who knows his stuff. Here he also mentioned the firmware I forgot about which is DD-WRT.

Link to comment
Share on other sites

Well, the multiple IP forward was a desperate call i made, but I tried before just with port 51999, and no result.

But if you want to get "bananas", check this out... I reconected the cable modem directly and continue downloading, but now, I can't pass 6KB!!!

I tried with other well seeded torrents, same problem...

Now i think it's the connection! But uTorrent speed test are working fine...

Thanks anyway for taking the time to answer.

Link to comment
Share on other sites

One problem with all of this plugging / un-plugging. While you're testing your computer / network settings other peers are getting all of these conflicting signals from you, which is more than likely the reason you're snubbed.

I'd recommend testing each scenario for at least 10 minutes, as the inactivity timer is set to default to 5 min.

I know its a long process this way on the same torrent. To try and ... lessen this you can always try each setting with a different swarm that doesn't know you exist...

Link to comment
Share on other sites

I just format (again) my PC... now i have Vista 64

Rigth now, there are only 3 things installed on my system

1) Gefroce driver

2) Flash Player

2) uTorrent

I'm directly attached to the cable modem (no more router, I swear to god I'll be happy if a can download at least direct connected and I promise I will not mess around anymore with the router!!!)

So, here you have the speed test:


And here you have uTorrent screen. I wait more than 10 minutes as adviced:


Of course, uTorrent says the port is OPEN.

If you pay attention, tou'll see that the second torrent is very well seeded. I should get 230KB on that torrent in no time (less than 1 minute) like i get it in the past.

Although i dont except to get my problem resolved, I would like the encourage the developers of uTorrent to make things easier to "read" in the future releases. For example, adding tooltips to the flags column will be great!


Link to comment
Share on other sites

Again as I said before pay attention to the flags column. most of those D peers are S...

Without the S you can download from them.

How long has that specific torrent been running? Just becuase your line is rated for XXX megapetabits per second doesn't mean you will always download at that speed. The rotating nature of peering means that it can take a minimum of 5 minutes for peers who want to talk and download to you, ESPECIALLY if you have nothing to offer in return. On lots of peers like those represented in your screenshot are cable or dsl users with limited upload amounts. Couple that with the tendency to overload one's client with active torrents and you can see how you won't always be downloading at your maximum since someone else has to contribute to that through their upload.

Link to comment
Share on other sites

Dear jewelisheaven, regarding your question, let me explain (i didnt explain it before because of the source of torrent, but well... if you ask, I tell you). That torrent is from a private site (BC-G / hope you can figure it out, I don't want to violate forum rules), and in that site, you need to "seed" for 3 days or else you will be accounted for a "hit & run" and your "ratio" will suffer greatly. There are torrents in that site that have +500 seeds and 2 or 3 lecheers (sounds crazy, but those people "need" to continue seeding in order to fix their ratios and not be penalized). That's why I normally get 230KB in less than 1 minute, because everyone is "waiting" to seed you. I hope that explains why I'm confident that isn't a torrent / tracker / swarm problem. I have downloaded almost 20 torrents from that site, all 8GB, and they were done in 8hs ~ 10hs ALWAYS.

Regardinf Switeck comment, I dont see any "download limited" anywhere and I have tried both minimizing and mixing out my upload speed, no result.

What I don't get is, why the peers from whom I "CAN" download, I'm downloading at 0.1KB or 0.2 or 0.3KB??? Looks suspicious to me... let say that, in prom., everyone is having 6 upload slots... with a "low" 10KB upload connection that will be almost 2KB... but no, i'm getting 0.1 or 0.2 from everyone I can download from!!!

Edit: A quick note, please understand that "I know" uTorrent has nothing to do with the problem (until today morning I have downloaded without problem with uTorrent)... but after 2 formats, I'm almost sure is something with the connection. But i keep posting trying to find "why" this happens and, perphaps, help other with the same problem.

Thanks again for you time.-

Link to comment
Share on other sites

The (in)frequent transmission of data rates that low are probably piece communications. Do you notice that at times other than when switching from d to D or u to U.

Have you double checked trying to access your modem via HTTP... you can try for starters.

Edit : I also presume you're not choking the upload by going any higher than XX/768 under Ctrl-G

Link to comment
Share on other sites

No, I'm not "choking" the upload

mmmhh... you got me there with the modem, I can access the modem with the IP you provided. I quickly browse the info, I noted that there are a ton of error messages like:

"IGMP: ERROR - Group address is not a legal multicast" under the "Logs" page of my Motorola Surfboard

Also, i want to metion that i DID NOT install the nForce drivers because i read somewhere that they have problems. Instead, I'm using Microsoft out-of-the-box drivers for my 2 network adapters. Is that ok?

Thanks again man!

Link to comment
Share on other sites

Choking is an automated response part of the protocol. I'm not sure about IGMP, it's possible that's Local Peer Discovery... IS there a place on there that "logs" information. As I'm not sure the sensitivity of that information, I would recommend keeping captures of it when you are both directly behind the modem and when you are behind the router behind the modem.

I'll see if I can get someone else to pop in here who know's what's what in relation to surfboard modems.

It doesn't appear that there is any problem with your drivers, as you said in the top-post.. the router is doing something hinky...

Link to comment
Share on other sites

Oi, those were the days.. before visualization caught on mainstream, beta Vista (Longhorn) Testing / re-testing / breaking... 4 formats a week wasn't uncommon.

I still say thats why my 120 GB WD died. :'( R.I.P. little buddy.

I have to admit whenever this problem is solved I certainly won't forget the solution... lol Cheers for keeping such a diligent troubleshooting mantra.

Link to comment
Share on other sites

ok, I'm back again, now with XP 32

Well, i will not settle for anything less than 200KB/s, you can bet on that :) Even if I have to install Ubuntu!

Well, back to business

What i have installed rigth now:

- GeForce drivers

- nForce Drivers (without the Network Access Manager)

- Flash player

- McAfee 8.5 + AntiSpyware (don't fear, i know the product well and it's not interfering with uTorrent)

- uTorrent 1.7.5

- Daemon tools


Aside from that, it's a clean install.

I must say that the internet connection isn't going quickly rigth now... here in Puerto Rico is Sunday 9:00PM and there a lot of people surfing rigth now...

Also, the uTorrent speed test applet is taking ages to download... i think rigth now it's not a good moment to make tests with these conditions

mmmhh... Speed test is saying 50KB... that bad news. I think there nothing more i could do today. I'll need to wait until tomorrow when the traffic downs a bit.

Anyway, I let you know.



wake up this morning and guess what?

230KB download speed!!!

I guess now if yesterday was simply a bad day for the ISP (traffic congestion, T1 down, etc.)

Looks like all those "formats" where in meaninless... :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...