Jump to content

uTorrent 1.2.2 killing the network?


nord1899

Recommended Posts

Running uT 1.2.2 with the following options:

- 30/50 upload cap

- uPnP enabled

- 500 global connections

- 100 connection per torrent

- 5 upload slots

- Rest default

System setup:

- Shuttle NF2 computer with built-in 100mbps NIC, Barton 2500+ CPU, 1 gig PC2700 RAM

- WinXP Pro SP2 fully patched

- No firewall enabled, Symantec Corp AV 9.0.3 with latest upgrades/definitions

- Linksys WRT54GS w/ DD-WRT v22r2 with changes as suggested here http://forum.utorrent.com/viewtopic.php?id=2878

- Moto SB5120 cable modem

- Comcast HSI 8mb/768kb (I've seen sustained uploads right near 100kB/s)

What happens is the following. I load up uT with a torrent (say the latest Fifth Gear episode) and only 1 torrent running total. After a moment, web pages start having major issues loading up, including the router admin page and the cable modem status page. IRC (mIRC 6.16) will timeout and disconnect. Online streaming radio will hickup for a few seconds then restart. Using Ping Plotter against sites like Google will show the 2 closest hops to me being instead of 10 to 100ms pings, like 400 to over 1000ms pings.

This happens if I have my computer plugged into the router or straight into the cable modem. So I know its not the router. I don't recall this happening to me when I was running uTorrent 1.1.7, but that doesn't necessarily mean it didn't.

Within a few seconds of stopping all torrents (well the 1 I have loaded) in uT, my network gets back to normal. uT is still open, just not actively doing anything.

Any ideas why this is happening? Would upgrading to a 1.2.3 beta resolve this?

Thanks.

Link to comment
Share on other sites

DHT appears to be the problem.

I turned it off, was running thru the router. Using ping plotter refreshing every 1 second to 2 hops down network (so still on a pseudo-local node in comcasts network).

Tried with just an upload (so cap at 50). No spiking noticed. No lag on web pages.

Tried with a torrent to download and the existing one just uploading (so cap at 30). Again, no issues.

Not sure why the Surfboard would be the issue. Reason being that I was having issues even loading the routers admin page. It would time out on me. Unless there is some weird network connections problem between WinXP Pro, the router and the modem that kills all network traffic, even local stuff.

But again, thanks for the help. It is much appreciated.

Link to comment
Share on other sites

The Surfboard doesn't handle UDP packets properly. A lot of modems (and routers, Linksys can handle them though) can't handle them and have assorted problems, even completely crashing and forcing you to reboot them.

You'd experience similar issues if you used Kad or other UDP-heavy networks.

I'd call Comcast and try to get them to give you a better modem. :/

Link to comment
Share on other sites

i have the same problem here... after a while of downloading with utorrent... internet dies...

the option "enable upnp mapping" in the preferences is disabled...

should i turn off upnp in the router settings as well? it's a dlink 624+

would disabling upnp be enough or do i have to disable DHT as well?

thanks

Link to comment
Share on other sites

D-Link routers have LOTS of problems.

Turn off UPnP, don't use Virtual Server. Create a forward using a direct firewall rule. Turn off DHT.

http://forum.utorrent.com/viewtopic.php?pid=26898#p26898

You should see if your 'net dies if you connect directly to the modem. If it doesn't, then it's your router. Junk it and get a new (non D-link) one. :P

Link to comment
Share on other sites

I'm also experiencing these network spasms. I've never had this problem with Bitcomet, Azureus, the original client, or any other BT program. I think that's a key datum; i.e., it ain't the router or modem... it's utorrent. Is there some kind of network analysis dump that can provide some insight for those that know what's up (which would not be me) or any other info that could prove helpful? I'd like to solve this problem because I do like utorrent and would like to continue using it; but I cannot if this persists. Thanks for any help.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...