Jump to content

Can't get good speeds on wireless cable modem

Bad Badger

Recommended Posts


I'm having trouble getting torrents to download at a decent speed, and can't get rid of the yellow triangle. As far as I can tell I still haven't managed to set up port forwarding properly, though I've been through the instructions on portforward.com for my modem and firewall.

The cable modem is a Motorola SBG900, I'm downloading wirelessly to a laptop with Vista and I've set up a program specific rule for the port I want to forward on the firewall. The ISP isn't on any lists of providers that restrict torrents but I've checked the encryption box anyway. Both up and download speeds are set to unrestricted. I had two attempts at setting a static IP address. First time I was connected wirelessly, but all it did was prevent any internet access at all so I put it back the way it was. Second go I plugged the network cable in and followed the same steps, and more or less the same thing has happened. Wireless connection works fine but if I disable the wireless off and plug the cable back in I just get no internet access. And when I use the speed guide in uTorrent it says the port is not forwarded properly.

Do I need to forward for both the wireless and LAN connections? If so, any guide on how to do it? If not, what have I missed? I'm not going to be downloading huge amounts, but when I do it would be nice if the average speed is better than 24 kB/s.

Thanks in advance,


Edited to add: every now and again it does pick up speed. From 10-15 Kb/s earlier on today it's gone up to 30 or so, with a very very brief peak of about 135. Shame it never lasts. Part of my problem is that I'm not too sure what sort of speeds I should expect from a cable modem, but Windows thinks it's using a pretty microscopic amount. I also forgot to mention that the first four torrents uploaded much more slowly than they downloaded and it's taking a long time to get a 1:1 ratio, while the current one I'm doing is the other way round and I'm at roughly 1:4 with less than 60% downloaded. Connected or coincidence?

Link to comment
Share on other sites

Is there a reason why you're not using the Speed Guide (Ctrl-G) to auto-setup most of the BitTorrent and Connection information for uT? Your process seems to have gone well, but if you can't forward the port it's kind of moot. Does the modem/router allow UPnP? Regarding your question about wifi vs lan... you should only have one connection, wifi, which in your case functions as your lan ip. To double check this Start -> Run -> cmd -> ipconfig (or ipconfig /all to see EVERY detail) .

If this were 1998 and you were using 802.11a, i'd say 24 KiBps were good ;)

Link to comment
Share on other sites

D'oh. Forgot to say that I have used the speed guide - that's what saying I've not forwarded the port properly (although I followed the portforward.com instructions carefully and double checked each step). The speed tests varied a huge amount, but 500 down and >100 up was probably round the average. I've also double checked the port number and IP addresses since to make sure I haven't transposed a digit anywhere.

Don't know if the modem/router allows UPnP. I'll have to ask my missus where the instruction book and CDs ended up, and since it's midnight here that'll have to wait till tomorrow.

Have already done ipconfig/all and the wifi is the only one there unless the network cable is plugged in, in which case it shows both. As I said, when I tried the static IP using the wireless connection I got no internet access at all, so put it back the way it was and repeated the process for the LAN connection while plugged into the network cable. Seemed to wrok fine as far as the static IP is concerned but strangely the laptop chose to ignore it and use the wireless connection in preference. And when I disabled that, bosh, no internet again.

If this were 1998 and you were using 802.11a, i'd say 24 KiBps were good :)

Tell me about it. I was still using dial up till a few weeks ago. Hmm, suppose I shouldn't moan really. :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...