Jump to content

Force Re-check results in 99% over and over


Recommended Posts

Hi there...

Is there anyone who can explain to me how the "Force Re-check" works?

When I download small file(s) (up to 250 mb) there is usually no problem doing a "force re-check"... and it returns 100% indicating all is ok.

... but when I download something like a 2 gb file or files, and do a "force re-check" it almost without fail ends in something like 98%, and I have restart to download again, to get 100% ... but then again and again, after a "force re-check" it goes back to 98%, sometimes other files, sometimes the same. I normally put the priotity of the incomplete files to HIGH, so I can identify them later, to see if they are the same every time. They are not.

Is it needed to increase the cache, or some such solution to fix this? It would be great if uT rechecked the file when they arrive at 100% and restart automatically until they are truly 100% there.

I posted about this before, but am still having this problem.

Perhaps if someone explains how the "force re-check" works I can find out why it is doing this.


Link to comment
Share on other sites

HijackThis log:

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 19:33:34, on 17.1.2008

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v7.00 (7.00.6000.16574)

Boot mode: Normal

Running processes:






C:\Program Files\Windows Defender\MsMpEng.exe


C:\Program Files\Lavasoft\Ad-Aware 2007\aawservice.exe

C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

C:\Program Files\Alwil Software\Avast4\ashServ.exe





C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe

C:\Program Files\Alwil Software\Avast4\ashWebSv.exe



C:\Program Files\CyberLink\PowerDVD\PDVDServ.exe

C:\Program Files\D-Tools\daemon.exe

C:\Program Files\DU Meter\DUMeter.exe


C:\Program Files\Java\jre1.6.0_03\bin\jusched.exe

C:\Program Files\SyncroSoft\Pos\H2O\cledx.exe

C:\Program Files\Adobe\Acrobat 8.0\Acrobat\Acrotray.exe


C:\Program Files\QuickTime\qttask.exe

C:\Program Files\Windows Defender\MSASCui.exe

C:\Program Files\Steam\Steam.exe


C:\Program Files\Creative\Shared Files\CamTray.exe

C:\Program Files\uTorrent\utorrent.exe


C:\Program Files\Common Files\Teleca Shared\Generic.exe

C:\Program Files\Sony Ericsson\Mobile2\Mobile Phone Monitor\epmworker.exe

C:\Program Files\Outlook Express\msimn.exe

C:\Program Files\Internet Explorer\IEXPLORE.EXE

C:\Program Files\Common Files\Microsoft Shared\Windows Live\WLLoginProxy.exe

C:\Program Files\Winamp\winamp.exe

C:\Program Files\Internet Explorer\iexplore.exe

C:\Program Files\Trend Micro\HijackThis\HijackThis.exe


R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.hivenet.is/

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://www.yahoo.com

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.yahoo.com

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer = laser.hive.is:8080

R3 - URLSearchHook: Freecorder Toolbar - {1392b8d2-5c05-419f-a8f6-b9f15a596612} - C:\Program Files\Freecorder\tbFree.dll

O2 - BHO: (no name) - {02478D38-C3F9-4efb-9B51-7695ECA05670} - (no file)

O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: Freecorder Toolbar - {1392b8d2-5c05-419f-a8f6-b9f15a596612} - C:\Program Files\Freecorder\tbFree.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: Adobe PDF Conversion Toolbar Helper - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll

O2 - BHO: Trixie.Bho - {B0744341-96E0-4341-9ED2-8BC36CE0CCD0} - mscoree.dll (file missing)

O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll

O3 - Toolbar: Freecorder Toolbar - {1392b8d2-5c05-419f-a8f6-b9f15a596612} - C:\Program Files\Freecorder\tbFree.dll

O4 - HKLM\..\Run: [P17Helper] Rundll32 P17.dll,P17Helper

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [nwiz] nwiz.exe /install

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [NeroFilterCheck] C:\WINDOWS\system32\NeroCheck.exe

O4 - HKLM\..\Run: [RemoteControl] "C:\Program Files\CyberLink\PowerDVD\PDVDServ.exe"

O4 - HKLM\..\Run: [DAEMON Tools-1033] "C:\Program Files\D-Tools\daemon.exe" -lang 1033 -lock

O4 - HKLM\..\Run: [DU Meter] C:\Program Files\DU Meter\DUMeter.exe

O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_03\bin\jusched.exe"

O4 - HKLM\..\Run: [H2O] C:\Program Files\SyncroSoft\Pos\H2O\cledx.exe

O4 - HKLM\..\Run: [Acrobat Assistant 8.0] "C:\Program Files\Adobe\Acrobat 8.0\Acrobat\Acrotray.exe"

O4 - HKLM\..\Run: [sony Ericsson PC Suite] "C:\Program Files\Sony Ericsson\Mobile2\Application Launcher\Application Launcher.exe" /startoptions

O4 - HKLM\..\Run: [VF0070 STISvc] RunDLL32.exe V0070Pin.dll,RunDLL32EP 513

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\qttask.exe" -atboottime

O4 - HKLM\..\Run: [Windows Defender] "C:\Program Files\Windows Defender\MSASCui.exe" -hide

O4 - HKLM\..\Run: [userFaultCheck] %systemroot%\system32\dumprep 0 -u

O4 - HKCU\..\Run: [steam] C:\Program Files\Steam\Steam.exe -silent

O4 - HKCU\..\Run: [Fraps] C:\FRAPS\FRAPS.EXE

O4 - HKCU\..\Run: [Creative WebCam Tray] "C:\Program Files\Creative\Shared Files\CamTray.exe"

O4 - HKCU\..\Run: [µTorrent] "C:\Program Files\uTorrent\utorrent.exe"

O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe

O4 - Startup: Adobe Gamma.lnk = C:\Program Files\Common Files\Adobe\Calibration\Adobe Gamma Loader.exe

O4 - Global Startup: Adobe Acrobat Speed Launcher.lnk = ?

O4 - Global Startup: Adobe Acrobat Synchronizer.lnk = C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AdobeCollabSync.exe

O4 - Global Startup: Adobe Reader Speed Launch.lnk = C:\Program Files\Adobe\Acrobat 7.0\Reader\reader_sl.exe

O8 - Extra context menu item: Append to existing PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert link target to Adobe PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert link target to existing PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert selected links to Adobe PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIECaptureSelLinks.html

O8 - Extra context menu item: Convert selected links to existing PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIEAppendSelLinks.html

O8 - Extra context menu item: Convert selection to Adobe PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert selection to existing PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert to Adobe PDF - res://C:\Program Files\Adobe\Acrobat 8.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O9 - Extra button: (no name) - {20CCCFEC-D26F-4ffe-996B-388B39C8CCCA} - C:\WINDOWS\system32\mscoree.DLL

O9 - Extra 'Tools' menuitem: Tri&xie Options... - {20CCCFEC-D26F-4ffe-996B-388B39C8CCCA} - C:\WINDOWS\system32\mscoree.DLL

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\OFFICE11\REFIEBAR.DLL

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O16 - DPF: {02A2D714-433E-46E4-B217-7C3B3FAF8EAE} (ScrabbleCubes Control) - http://www.worldwinner.com/games/v46/scrabblecubes/scrabblecubes.cab

O16 - DPF: {0E5F0222-96B9-11D3-8997-00104BD12D94} (PCPitstop Utility) - http://pcpitstop.com/pcpitstop/PCPitStop.CAB

O16 - DPF: {48DD0448-9209-4F81-9F6D-D83562940134} (MySpace Uploader Control) - http://lads.myspace.com/upload/MySpaceUploader.cab

O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://update.microsoft.com/windowsupdate/v6/V5Controls/en/x86/client/wuweb_site.cab?1140194690890

O16 - DPF: {8A94C905-FF9D-43B6-8708-F0F22D22B1CB} (Wwlaunch Control) - http://www.worldwinner.com/games/shared/wwlaunch.cab

O16 - DPF: {B8BE5E93-A60C-4D26-A2DC-220313175592} (MSN Games - Installer) - http://cdn2.zone.msn.com/binFramework/v10/ZIntro.cab56649.cab

O16 - DPF: {BFF1950D-B1B4-4AE8-B842-B2CCF06D9A1B} (Zylom Games Player) - http://www.arcadetown.com/swf/shangrila/zylomplayer.cab

O16 - DPF: {DF780F87-FF2B-4DF8-92D0-73DB16A1543A} (PopCapLoader Object) - http://www.popcap.com/webgames/popcaploader_v10.cab

O23 - Service: Ad-Aware 2007 Service (aawservice) - Lavasoft AB - C:\Program Files\Lavasoft\Ad-Aware 2007\aawservice.exe

O23 - Service: Adobe LM Service - Adobe Systems - C:\Program Files\Common Files\Adobe Systems Shared\Service\Adobelmsvc.exe

O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashServ.exe

O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe

O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashWebSv.exe

O23 - Service: FLEXnet Licensing Service - Macrovision Europe Ltd. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe

O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe

O23 - Service: iPod Service - Apple Computer, Inc. - C:\Program Files\iPod\bin\iPodService.exe

O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe


End of file - 10587 bytes

I hope this helps.

Link to comment
Share on other sites

Negative on the thumbs.db files. No spyware according to Adaware2007, only "trackers"), or malware that I know of... The hardware seems ok, too.

These are, for example, single AVI files, like, 1.3 gb in size, or RAR files that uT says are 100% downloaded, but after a force re-check they end up as 98% for some reason. When I restart the download, sometimes it takes 5 or 6 times to get 100% after a forced re-check. (BitLord downloads come through fine.)

How does uT recheck the file? Is it something to do with the RAM? It seems smaller torrents (with dozens of files) are fine.

Edit: (I don't use iTunes)

Link to comment
Share on other sites

... could it be Avast virus protection? Checking what is being written? That is the only thing that would monitor files. There is nothing else accessing the files, that I know of.

I'll try shutting that off for a while and see if it improves.

I did notice once, that when I downloaded an infected "keygen" Avast immediately told me it was an infected file. So that MIGHT be it. (testing now)

Here is a more visual idea of what I am experiencing:

Before forced re-check: http://i274.photobucket.com/albums/jj246/countborgia/uT/b4_forced_recheck.jpg

During forced re-check: http://i274.photobucket.com/albums/jj246/countborgia/uT/during_forced_recheck.jpg

After forced re-check: http://i274.photobucket.com/albums/jj246/countborgia/uT/after_forced_recheck2.jpg

Link to comment
Share on other sites

The last picture is of a different torrent... the filenames aren't the same. Also verifying whether or not the same offset for the missing piece exists on your different torrents may help. It appears to be @ ~ 233MiB into the torrent.

If Avast was futzing with stuff you wouldn't be able to download at all... All that's contained in the AVI container around that time would be.. uhm frame picture/audio data. You can't embed URLs or code in that container can you? (compared to WMV's ASF)

As to it continually failing... make sure the missing piece is the at the same location in the same torrent each time. Unless it's not. Double check your Ctrl-P -> Advanced -> Disk Cache settings. Which options do you have enabled?

Link to comment
Share on other sites

It's the same torrent in all pictures, it changed the position of ther files due to sorting in % completed order. All the files are AVI files in that case. I edited out the names of the files, but left a few AVI suffixes so you could see what kind of file was being downloaded. They are all AVI in that case... However...

I just downloaded a 70 mb torrent, with 12 mp3 files with AVAST ANTIVIRUS OFF. When it was 100% done,


I did a force re-check and one of the files was at 98%. So it's not just the BIG torrents, as I first thought.


Link to comment
Share on other sites

That is... odd. My theory was that you weren't dumping directly to disk (the three checkmarks for writing).. What about the error in each torrent being at the same place each "completion"? I think you should run chkdsk /f on that volume you're saving to. If nothing else shows itself as broken, you may also want to run memtest86 on your comp (RAM tester) because the data is being corrupted somewhere between verification dumping to disk completion and reverification.

Link to comment
Share on other sites

I'll do this, but it will take a me a bit more time than I have at present.

My aim is to get this sorted out. I will post back with my findings a.s.a.p.

Many thanks for your help.

(and thanks go to the others also.)


I feel it's only fair to add: I don't know how to check the place of "completion"... Or anything about an "offset". Sorry about that. I just try to run uT and hope all goes as it should, kinda thing.

The volume in this case is an external USB connected drive... BUT I also had the same problems with the hard disks physically in the computer, so it's not that.

Would it be better to dowload onto the hard drive physically in the computer, then upon completion, uT can move the downloaded files to the external drive? I think I saw that option somewhere. So long as it then SEEDS from the external drive. That might be worth a try.

Link to comment
Share on other sites

OH! you don't see it?? Completed pieces in the Files tab are blue. I thought that was the reason you kept showing the Files tab... the incomplete ones (ones which re-check as corrupt) are RED. >< I figured you knew why it was a different color ~ 1/3 of the way into the first file. I'm SO SO sorry about that. Yep there is indeed the option under Ctrl-P -> Downloads to set a separate folder for completed torrents, but... you might not want to do that. Depending on your hard drive speed and usage, you may end up spending... 5 or 6 minutes per file waiting for uT to finish. It should be faster if you just use explorer to copy the files.. then when STOPPED you can right click in uT on that torrent, go to advanced and select change download location. Browse to the new location, say OK, and when you start again it will automatically recheck. If it shows 100% you definitely have problems on the internal drive. Do the chkdsk /f DRIVE: (replace DRIVE with the volume, like "C" for example).

Link to comment
Share on other sites

Ok, I knew that (about the red & blue) hehe... but I meant, I don't know how to check WHERE the corruption took place, you know, like a volume address of the piece on the hard drive, to see if it always has an error at that hard disk address (in hex or binary) etc). hehe... There we go again, communications problems. I guess we really need to be extremely precise in all our discussions.

I had my doubts about the external USB drive - at first, but it seems to work fine, and as you said, saves a lot of transfer time. I am always learning ways to do stuff, and that new location was good to know. I have done it before, with success, but it is so rare that it is good to have it stated somewhere. I'll copy your words to a note, so I have it easily accessible next time.

Menawhile, I will continue to try and figure out what could be causing this, but it is good to discuss it with others, so we know not everyone else is having the same problem.

Good stuff.

Link to comment
Share on other sites

Ok, thank you... Very good to know. I am looking into what I can do to fight this problem.

As soon as I get it fixed I will post a solution...

Meanwhile, if anyone has fixed it, please let us know?

I have just downloaded the NEW uTorrent. Anyone think this will help?

Link to comment
Share on other sites

No solution yet... I have disabled the virus software, but still getting 99% after forced check. Do you get MANY torrents 99% or just some? Recently, here, I feel the number has been increasing. Even the smalled torrents are now 99% after a forced recheck.

I don't want to start some kind of urban legend, but I wonder if this is one of the reasons why some torrents "hang" at 99%? They are showing 100% at the host, but really are incomplete, but they never did a force recheck? Just a thought. I have had MANY 99.9% torrents in BitLord, hence I decided to try another program.

Link to comment
Share on other sites

I don't force recheck very often so I can't be precise on it, but today I had this problem on a 350 MB avi file, yesterday I didn't on a small pdf file or on a bunch of mp3, a few days ago I had it again on some large files.

About the "hang" at 99%, that never happened to me but I don't think it's possible that they are really incomplete, because the uploader's client has to check the files when he loads them in order to start seeding... At least uTorrent does it, as I understand it.

Link to comment
Share on other sites

Hey there...

Well, there's no "thumbs.db" in any of the torrents I have downloaded. I have now run chkdsk and it reports no errors on the drive... So the disk seems fine. I ran the memory check last time I made a post on this forum (a year ago?), and it proved to be 100% working correctly.

However... Since I shut off Avast Antivirus, out of 27 torrents I have now downloaded only about 8 were found to 99% after a forced recheck. That's better than before. I believe it was 9 out of 10 that were 99% before I shut it off, so as someone pointed out here, that another process was accessing the file at some point (I don't know if it was while the recheck was taking place, or during the download)... So it has had some effect. - On the other hand, since I have just downloaded the new uT perhaps that has something to do with it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...