Jump to content

Zyxel Prestige 2502HW-D1A & Utorrent


Recommended Posts

Hi all,

does anyone here recocnise this problem? Whenever I start uTorrent (176 or the latest 18alpha/betas I've tested) it brings down my internet connection.

What I mean is this. MSN remains online but any other connection be it pop3 polling or surfing the web is dead in the water. No action whatsoever, it just all gives a timeout/van't reach page after a long wait.

It doesn't matter how fast or slow uTorrent is doing it's downloads/uploads, this happens.

When I try to surf from another PC I at the time uTorrent is doing its thing also can't access the internet. I can't even access the admin site of the Zyxel modem/router until after I closed uTorrent ans wait for half a minute.

Obviously uTorrent if upsetting my Zyxel somehow and I can't figure out how. The Zyxel is running the latest firmware, it's the second one I have so it's not just one Zyxel that has the problem.

I've tried UPNP enabled on the Zyxel as well as disabled.

I've tried to disable the firewall ont eh Zyxel

I;ve tried portforwarding rules

I've tried limiting the connections in uTorrent

I've tried disabling UPNP on Vista, SSDP as well, no difference, I disabled the firewall on Vista, no difference. I tried vombinations of possibilities but that also didn't help.

It's not a problem with downloads in general because Newsleecher works great and fast too. My ISP does not throttel torrent traffic because I've tried another adsl modem/router (Belkin, Linksys as well) and that works fine with uTorrent.

Whats wrong here?' Zyxel seems not to be able to distinguish it's head from it's ass so I figured that maybe someone over here could say something of use.



Link to comment
Share on other sites

Hi there, thanks for the feedback.

this is what I did:

Try disabling IP resolving in the Peers tab's context menu

Try disabling DHT (Can be found in Preferences > BitTorrent)

Try disabling UPnP and NAT-PMP (Can be found in Preferences > Connection)

Try disabling peer.resolve_country if it isn't already set to false (Can be found in Preferences > Advanced)

Try lowering maximum global number of connections to 200? 100? 50? (Can be found in Preferences > BitTorrent)

Try lowering net.max_halfopen to 4 (Can be found in Preferences > Advanced)

And it works. I lowered the global number of connections to 50.

I also have word from Tiscali/Telfort (my ISP) that Zyxel is aware of the problem and are in fact working on an update of the firmware.

Every Torrent client is said to cause the problems I was having with this router.

Link to comment
Share on other sites

:D Now if only Tiscali would upgrade their infrastructure :/ But I guess not everything will be sunny all the time. Also please be aware depending upon your max upload speed, less is always better. Keeping the least amount of features enabled as you did will try to ensure the least amount of disruption due to router reset due to overload. You can even see WHEN the problem occurs by incrementally (5% at a time is a pretty nice rule-of-thumb) increasing your load. However due to the number of connections it creates it is best to keep DHT disabled in your case.

Thanks for your contribution and help for other Zyxel users out there.

Link to comment
Share on other sites

actually I'm pretty pleased with Tiscali over here. my ADSL performance is great and without hickups and my voip phone service from Tiscali alsow works great.

Anyway, I enabled DHT to test that, I enabled UPNP in the router and UPNP + NAT-PMP in utorrent and the connection still works great after a restart of utorrent.

I'm nog going to test rasing the other settings and see what happens because the download performance is not realy great:(

I'll report back:)

I stand corrected. I need to be more patient. the speed is great:)

I've set the Global Max connections to 100 and all still works great.

Link to comment
Share on other sites

Hey! That's awesome, and I didn't mean to sound harsh on Tiscali, but being in the press consistenly for NOT providing a good CUSTOMER experience ... you start beliving the worst after a while you know? I'm glad to know that it doesn't ALL suck. :D Hey, after doing all that just be aware if you ARE hit by the shaping profiles more than likely sometime during the day/week you WILL have connection problems. The most intensive background task is DHT which should clear up connections-based problems, but not necessarily peer problems, for which you should lower the max back down again. Again thanks for your help and input :) you solved your own problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...