Jump to content

Error: parameter is incorrect


Recommended Posts

Hi all!

I have been trying utorrent from a few days, and it´s been acting a bit stange.

I downloaded a torrent, and it connects fine but after 10 minutes it displys "Error: parameter is incorrect" or "Error: invalid data". I´ve tried download the same torrent using bitcomet 0.60 and it downloads fine no errors. I´ve tried with a number of torrents with the same results. The torrent is 8.6Gb with multiple files, i only download 2.6Gb at a time.

Another issue I´ve encontered is the number of connections. I´ll try and explain the best I can:

The above torrent takes about 2/3 minutes to connect to 14 seeds and 55 peers on bitcomet 0.60, and it starts downloading right away 50/60Kb average. While on utorrent it takes as much as those 10 minutes to connect to 4 seeds and 12 peers, after that it displays the error.

The settings are all default for both programs except:

maximum upload rate= 25Kb

maximum number of connections= 256

maximum number of connected peers per torrent= 102

maximum number of active torrents=3

maximum number of active downloads=2

I´m on a Win98 pentium 133Mhz 80Mb ram, connection: 1024Kb/256Kb

I´m using utorrnt 1.3, but experienced the same problems with 1.2.2

Hope you can help, I really like utorrent but if I can´t download anything i just have to stick with bitcomet for the time being.

Sorry for my bad english, if you need anymore info just let me know

Link to comment
Share on other sites

  • 3 weeks later...

sorry to bother again, but the problem remains. I´m still getting the "parameter is incorrect" error again. I added the registry tweak, MaxConnections=256, as sugested by Firon.

The download of the torrent begins and after 10 minutes, it displays the "parameter is incorrect" and stops downloading.

if you need the torrent or a screenshot just let me know.


Link to comment
Share on other sites

I'm on a p2 450mhz , 128 Ram and I've applied this fix aswell (since I had the same problem) and it solved my problem pretty nicely.

However, I'm on windows 98 second edition, perhaps there's a difference between the win 98 standard version and the second edition that's responsible for this error?

Link to comment
Share on other sites

Well, apparently "Parameter is incorrect" is a very generic error and can be caused by faulty hardware, bad jumper settings, and crappy drivers. 9x/ME also sometimes show "parameter is incorrect" instead of "access denied"...

Try lowering your number of connections/torrent to 60 and global to 200. :/

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...