Jump to content

Internet dies after 20 of uTorrent usage


Recommended Posts

I've been using torrents for about 2 years and I've never had any problems with them apart from average download speeds but about 2 months ago, they stopped working.

They still DO work, kind-of, but not enough for me to download a big file.

What's the problem? Well, when I start downloading, everything is fine but after 10 to 20 minutes, my whole internet connection crashes to the ground. The only way to get it back is to unplug my modem and plug it back.

I had a D-Link DI-524 router and I though that might have been the problem so I bought a new one today and still no change (apart from better speed).

So my router is a D-Link WBR-2310 and my modem is a Motorola SB4200 SURFboard.

Here's what I've tried so far: (with my old router AND my new)

-Tried downloading torrents with uTorrent, BitTorrent, Limewire and Wyzo's FireTorrent.

-Forwarded my port.

-Ran the speed test and set my settings to my speed.

-Disabled IP resolving.

-Disabled DHT.

-Disabled UPnP and NAT-PMP.

-peer.resolve_country was already set to false.

-Lowered maximum global number of connections to 200, then 100.

-Lowered net.max_halfopen to 4.

-Patched TCPIP.sys.(on both vista and XP, I have both installed on my computer)

-Connected the computer directly to the modem. Same problems.

-Tried disabling DHT, UPnP and NAT-PMP, lowered max globa connections to 100 and lowered net.max_halfopen to 4 all at once.

-Set back settings to my speed from the speed guide.

That's what I've tried... Nothing worked obviously.

So I'll provide the information asked:

-The network status light is yellow for a bit then always green.

-Port checker says: OK! Port 55489 is open and accepting connections. You will be able to receive incoming BitTorrent connections.

-The speed guide says:

Connection Type: xx640k

Upload limit: 60kB/s

Upload slots: 4

Connections: 100

Connections: 375

Max active torrents: 4

Max active downloads: 3

-My net.max_halfopen is set to 4

-My operating system is Windows Vista Ultimate

-No security software

-My ISP is Videotron

-I have a cable connection and my speed test results are:

Download:2922 Kb/s

Upload:571 Kb/s

I think I've included everything. Please help me figure this out, it kills me not being able to use uTorrent. ^^

Link to comment
Share on other sites

Limit the connections even lower. 20 Per and 50 total should be a valid test of whether its the modem / ISP throttling your connection due to too many connections. This is notwithstanding the problems with surfboard. Typing in "surfboard" into the search here shows that in spades.

Thanks for the in-depth explanation :/ I'm sorry there's not much else to do after that except figuring out where your "too many" connections limit is.

Link to comment
Share on other sites

I'll try that as soon as I can. Right now I'd rather not, my brother is hooked at his comp playing World of Warcraft and if the solution you provided doesn't work... Well, the game'll crash and he probably won't be very happy.

Concerning the surfboard modem though, I performed the check to see if my surfboard had been tinkered with by my ISP and it seemed okay... I'll check again and see if I'm mistaken.

Thanks for the help, I hope that'll fix it... >_>

EDIT: Redid the check to find out if my surfboard modem was okay, seems it is...

EDIT2: *Sigh* Tried what you said, 50 max and 20 per. Doesn't work. Crashed in about 5 minutes.

Link to comment
Share on other sites

Quite odd. Try setting net.max_halfopen to 1? There isn't any obvious reason why this is happening.

Also, while you're at it, get Process Explorer from sysinternals.com, run it, File > Save, then post the contents of the saved process list in the .txt file here.

Link to comment
Share on other sites

net.max_halfopen to 1 doesn't work either.

Here's what you asked: (I think)

Process PID CPU Description Company Name

System Idle Process 0 48.89

Interrupts n/a 2.96 Hardware Interrupts

DPCs n/a 2.96 Deferred Procedure Calls

System 4 1.48

smss.exe 380 Windows Session Manager Microsoft Corporation

csrss.exe 460 Client Server Runtime Process Microsoft Corporation

wininit.exe 512 Windows Start-Up Application Microsoft Corporation

services.exe 564 Services and Controller app Microsoft Corporation

svchost.exe 784 Host Process for Windows Services Microsoft Corporation

ehmsas.exe 1628 Media Center Media Status Aggregator Service Microsoft Corporation

mobsync.exe 3232 Microsoft Sync Center Microsoft Corporation

WmiPrvSE.exe 3644 WMI Provider Host Microsoft Corporation

iexplore.exe 2264 1.48 Internet Explorer Microsoft Corporation

msn_sl.exe 2744 Windows Live Toolbar Helper Microsoft Corporation

WLLoginProxy.exe 3576 WLLoginProxy.exe Microsoft Corporation

svchost.exe 832 Host Process for Windows Services Microsoft Corporation

svchost.exe 872 16.30 Host Process for Windows Services Microsoft Corporation

svchost.exe 960 Host Process for Windows Services Microsoft Corporation

audiodg.exe 1148 Windows Audio Device Graph Isolation Microsoft Corporation

svchost.exe 1044 Host Process for Windows Services Microsoft Corporation

dwm.exe 1720 7.41 Desktop Window Manager Microsoft Corporation

WUDFHost.exe 3060 Windows Driver Foundation - User-mode Driver Framework Host Process Microsoft Corporation

svchost.exe 1056 Host Process for Windows Services Microsoft Corporation

taskeng.exe 416 Task Scheduler Engine Microsoft Corporation

taskeng.exe 3372 Task Scheduler Engine Microsoft Corporation

SLsvc.exe 1184 Microsoft Software Licensing Service Microsoft Corporation

svchost.exe 1212 Host Process for Windows Services Microsoft Corporation

svchost.exe 1348 Host Process for Windows Services Microsoft Corporation

aawservice.exe 1508 Ad-Aware 2007 Service Lavasoft AB

spoolsv.exe 404 Spooler SubSystem App Microsoft Corporation

svchost.exe 468 Host Process for Windows Services Microsoft Corporation

MSCamS32.exe 2564 MsCamSvc.exe Microsoft Corporation

svchost.exe 2748 Host Process for Windows Services Microsoft Corporation

svchost.exe 2796 Host Process for Windows Services Microsoft Corporation

svchost.exe 2860 Host Process for Windows Services Microsoft Corporation

SearchIndexer.exe 2948 Microsoft Windows Search Indexer Microsoft Corporation

SearchProtocolHost.exe 3036 Microsoft Windows Search Protocol Host Microsoft Corporation

SearchFilterHost.exe 1912 Microsoft Windows Search Filter Host Microsoft Corporation

SearchProtocolHost.exe 1816 Microsoft Windows Search Protocol Host Microsoft Corporation

wmpnetwk.exe 3152 1.48 Windows Media Player Network Sharing Service Microsoft Corporation

WmiApSrv.exe 4032 WMI Performance Reverse Adapter Microsoft Corporation

usnsvc.exe 3956 Messenger Sharing USN Journal Reader Service Microsoft Corporation

lsass.exe 596 Local Security Authority Process Microsoft Corporation

lsm.exe 604 Local Session Manager Service Microsoft Corporation

csrss.exe 520 1.48 Client Server Runtime Process Microsoft Corporation

winlogon.exe 612 Windows Logon Application Microsoft Corporation

explorer.exe 1744 Windows Explorer Microsoft Corporation

OpWareSE4.exe 1852 OCR Aware ScanSoft, Inc.

rundll32.exe 1892 Windows host process (Rundll32) Microsoft Corporation

vVX3000.exe 1980 Microsoft LifeCam Device Application Microsoft Corporation

reader_sl.exe 1992 Adobe Acrobat SpeedLauncher Adobe Systems Incorporated

jusched.exe 2012 Java Platform SE binary Sun Microsystems, Inc.

sidebar.exe 2020 Windows Sidebar Microsoft Corporation

sidebar.exe 664 1.48 Windows Sidebar Microsoft Corporation

msnmsgr.exe 264 2.96 Windows Live Messenger Microsoft Corporation

ehtray.exe 292 Media Center Tray Applet Microsoft Corporation

wmpnscfg.exe 308 Windows Media Player Network Sharing Service Configuration Application Microsoft Corporation

procexp.exe 2360 10.37 Sysinternals Process Explorer Sysinternals

rundll32.exe 1368 Windows host process (Rundll32) Microsoft Corporation

Link to comment
Share on other sites

I ran HiJack This but unfortunately I have no idea what all of this means, so I thought maybe you guys would?

Here's the log:

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 13:11:16, on 2008-01-30

Platform: Windows Vista (WinNT 6.00.1904)

MSIE: Internet Explorer v7.00 (7.00.6000.16546)

Boot mode: Normal

Running processes:



H:\Program Files\Windows Defender\MSASCui.exe

H:\Program Files\ScanSoft\OmniPageSE4.0\OpWareSE4.exe



H:\Program Files\Java\jre1.6.0_03\bin\jusched.exe

H:\Program Files\Windows Sidebar\sidebar.exe

H:\Program Files\Windows Live\Messenger\msnmsgr.exe


H:\Program Files\Windows Media Player\wmpnscfg.exe




H:\Program Files\Windows Sidebar\sidebar.exe


H:\Program Files\Internet Explorer\iexplore.exe

H:\Program Files\Common Files\Microsoft Shared\Windows Live\WLLoginProxy.exe


H:\Program Files\Windows Live Toolbar\msn_sl.exe

H:\Program Files\WinRAR\WinRAR.exe


R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - H:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: Canon Easy Web Print Helper - {68F9551E-0411-48E4-9AAF-4BC42A6A46BE} - H:\Program Files\Canon\Easy-WebPrint\EWPBrowseLoader.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - H:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O2 - BHO: Programme d'aide de l'Assistant de connexion Windows Live - {9030D464-4C02-4ABF-8ECC-5164760863C6} - H:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: Windows Live Toolbar Helper - {BDBD1DAD-C946-4A17-ADC1-64B5B4FF55D0} - H:\Program Files\Windows Live Toolbar\msntb.dll

O3 - Toolbar: Windows Live Toolbar - {BDAD1DAD-C946-4A17-ADC1-64B5B4FF55D0} - H:\Program Files\Windows Live Toolbar\msntb.dll

O3 - Toolbar: Easy-WebPrint - {327C2873-E90D-4c37-AA9D-10AC9BABA46C} - H:\Program Files\Canon\Easy-WebPrint\Toolband.dll

O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide

O4 - HKLM\..\Run: [D-Link RangeBooster G WUA-2340] H:\Program Files\D-Link\RangeBooster G WUA-2340\AirPlusCFG.exe

O4 - HKLM\..\Run: [ANIWZCS2Service] H:\Program Files\ANI\ANIWZCS2 Service\WZCSLDR2.exe

O4 - HKLM\..\Run: [sSBkgdUpdate] "H:\Program Files\Common Files\Scansoft Shared\SSBkgdUpdate\SSBkgdupdate.exe" -Embedding -boot

O4 - HKLM\..\Run: [OpwareSE4] "H:\Program Files\ScanSoft\OmniPageSE4.0\OpwareSE4.exe"

O4 - HKLM\..\Run: [NvSvc] RUNDLL32.EXE H:\Windows\system32\nvsvc.dll,nvsvcStart

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE H:\Windows\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE H:\Windows\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [QuickTime Task] "H:\Program Files\QuickTime\QTTask.exe" -atboottime

O4 - HKLM\..\Run: [LifeCam] "H:\Program Files\Microsoft LifeCam\LifeExp.exe"

O4 - HKLM\..\Run: [VX3000] H:\Windows\vVX3000.exe

O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "H:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"

O4 - HKLM\..\Run: [sunJavaUpdateSched] "H:\Program Files\Java\jre1.6.0_03\bin\jusched.exe"

O4 - HKCU\..\Run: [sidebar] H:\Program Files\Windows Sidebar\sidebar.exe /autoRun

O4 - HKCU\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter

O4 - HKCU\..\Run: [MsnMsgr] "H:\Program Files\Windows Live\Messenger\MsnMsgr.Exe" /background

O4 - HKCU\..\Run: [ehTray.exe] H:\Windows\ehome\ehTray.exe

O4 - HKCU\..\Run: [igndlm.exe] H:\Program Files\Download Manager\DLM.exe /windowsstart /startifwork

O4 - HKCU\..\Run: [WMPNSCFG] H:\Program Files\Windows Media Player\WMPNSCFG.exe

O4 - HKUS\S-1-5-19\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'USLUGA LOKALNA')

O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'USLUGA LOKALNA')

O4 - HKUS\S-1-5-20\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'USLUGA SIECIOWA')

O8 - Extra context menu item: &Windows Live Search - res://H:\Program Files\Windows Live Toolbar\msntb.dll/search.htm

O8 - Extra context menu item: Add to Windows &Live Favorites - http://favorites.live.com/quickadd.aspx

O8 - Extra context menu item: Easy-WebPrint Ajouter à la liste d'impressions - res://H:\Program Files\Canon\Easy-WebPrint\Toolband.dll/RC_AddToList.html

O8 - Extra context menu item: Easy-WebPrint Impression rapide - res://H:\Program Files\Canon\Easy-WebPrint\Toolband.dll/RC_HSPrint.html

O8 - Extra context menu item: Easy-WebPrint Imprimer - res://H:\Program Files\Canon\Easy-WebPrint\Toolband.dll/RC_Print.html

O8 - Extra context menu item: Easy-WebPrint Prévisualiser - res://H:\Program Files\Canon\Easy-WebPrint\Toolband.dll/RC_Preview.html

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - H:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - H:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O9 - Extra button: Ajout Direct - {219C3416-8CB2-491a-A3C7-D9FCDDC9D600} - H:\Program Files\Windows Live\Writer\WriterBrowserExtension.dll

O9 - Extra 'Tools' menuitem: &Ajout Direct dans Windows Live Writer - {219C3416-8CB2-491a-A3C7-D9FCDDC9D600} - H:\Program Files\Windows Live\Writer\WriterBrowserExtension.dll

O13 - Gopher Prefix:

O16 - DPF: {39B0684F-D7BF-4743-B050-FDC3F48F7E3B} (CDownloadCtrl Object) - http://www.fileplanet.com/fpdlmgr/cabs/FPDC_2.3.6.108.cab

O16 - DPF: {4F1E5B1A-2A80-42CA-8532-2D05CB959537} (MSN Photo Upload Tool) - http://gfx1.hotmail.com/mail/w2/resources/VistaMSNPUpldfr-ca.cab

O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab

O17 - HKLM\System\CCS\Services\Tcpip\..\{AE37D07B-D53A-4458-A3A5-7E02DED3C6FA}: NameServer =,

O23 - Service: Ad-Aware 2007 Service (aawservice) - Lavasoft AB - H:\Program Files\Lavasoft\Ad-Aware 2007\aawservice.exe


End of file - 7249 bytes

Is there anything wrong?

Link to comment
Share on other sites

Hm. I've been using the same torrents since the beginning... I'll try to shut them down and get them back. Probably won't make any difference but what the hell. I have tried everything else, so...

EDIT: Okay. Not a single change. Really getting pissed off. About to give up hope... But I've got one last thing to try. If it doesn't work at all even without the router connected, (plus I bought a new one completely so I'm preeeetty sure it's not the router that's the problem) that probably means it's the modem,(Hopefully) even though I've had this one forever and it always worked. But it's a SurfBoard after all >_>. So should I bother to buy a new modem or are there things I haven't tried yet?

Thanks for the help so far, by the way.

Link to comment
Share on other sites

As much as I dislike the SurfBoards, I can't pin the blame on it without feeling like I'm lying, since I've never heard of SurfBoards causing these kinds of problems. If at all possible, you should try bring your computer to a friend's house (or something) to try checking.

Link to comment
Share on other sites

Well... I don't know if that'll change anything.. I have 3 computers in my house:

The old family computer that is connected to the modem and the router, my computer and my brother's computer who're using a Dlink adapter to get the router signal.

I have tried downloading torrents on both my computer and the family computer and both get the same results. That's why I doubt the computer is the problem. It'll probably work at a friend's or somewhere else.

At first I thought it was the router but now I kinda think it's obvious that it's not... Besides, every time the internet crashes, it's the modem that I need to reboot. So I'd pin the blame on the modem... >_>

Anyway, I don't really know much about wireless networks so what do I know? That's why I was asking.

Link to comment
Share on other sites

  • 4 weeks later...

Hey guys. M'not dead yet. I haven't bought that new modem yet either.

I did try something else though! I subscribed to Full Releases (I though they offered regular downloads but I was wrong. They're torrents >_> ) and started a torrent from them.

It's been nearly an hour and no problem at all so far. It made me wonder what was the difference between regular torrents and their's? Well, the only thing that I have noticed is that my upload is at 0kb/s. (since it is a pay site and the downloads are hosted on their servers I guess) Could it be that all this time I had a problem with uploads?

Any thoughts on this?

If you do not figure it out, it's not so bad. I guess that if torrents from Full Releases work with me, I have nothing to complain about!

EDIT: Hm. Had 2 torrents running at the same time and it crashed. I've set it back to 1 to see if the problem still persists.

EDIT2: Still no problem with the first torrent. Seems I can't handle two at the same time but 1 runs fine. Still haven't tested different torrents yet so I'll have to see.

EDIT again: Meh. Seems that upload kicked in and then it crashed after some time. I'm even more confused.

Still EDITing: Confirming the problem. I can't upload without my internet crashing, it seems. I put the upload limit to 5kb/s (thus dropping download rate to about 30kb/s :'( ) And it's been working for more time than usual.

Any ideas as to why I only have a problem with upload? This happen ever before to somebody else?

Probably last EDIT: Working perfectly with uploads limited to 6kb/s. Downloads not limited and been working for 3 hours with decent speed. I think I finally managed to get my torrents to work!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...