Jump to content

Red Light showing, but ports forwarded properly...


Recommended Posts

Hey guys,

Ever since i upgraded to 1.7.6 i've been having problems with my utorrent. So far, i've read numerous threads to solve my problem but nothing is working. I've set up my static ip and forwarded the port in my router config, but it still says its not being forwarded. Right now i can download the open office torrent at a 500kB/s rate, but for any other torrents it seems limited to around 150kB/s.

I have a 5000/800 connection, Linksys WRT54G router, and a D-Link DSL-300l modem.

I've tried enabling/disabling upnp, nat port mapping, protocol encryption but nothing seems to work. Actually, enabling upnp in my router completely stops any downloading...

I've also had some other weird problem where the speed guide page changes my port one number higher than what i set, and its greyed out so i cant change it, but then it gives me a green light and it says its forwarded, but my speeds still arent the best.

Another problem is when i get a green light, but it says im still not forwarded... any help would be GREATLY appreciated as this is really confusing me...

Link to comment
Share on other sites

If other torrents don't hit your maximum sustained speeds, the swarms cannot handle it, or the peers are unable to breach their own shaping profiles. Your enabling of UPnP and letting uT do the mapping is the reason for the port oddness AND the greyed out box. If you check the Logger tab, what does it say relating to UPnP? If nothing, could you enable verbose and error logging, and then restart uT?

If you have done the forwarding yourself, why are you enabling UPnP?

Link to comment
Share on other sites

well it doesnt say anything about upnp there, so how can i go about enabling verbose and error logging? I was using upnp because i read somewhere that it was fixing some problem with my ps3....btw, im not really understanding what you wrote as i dont know much about this stuff, but thanks alot for the help, i do appreciate it.

edit: k well right now, im actually getting decent speeds, i got 2 torrents d/ling at 80kB/s and 200kB/s and my u/ling is actually working now, around 45 and 15kB/s....

my red light has turned to yellow, but it's still saying my port is being blocked so im hoping once this works ill be back to my 500kB/s...

im not sure what i did but for now here is a rundown of my settings:

upnp disabled

nat port mapping disabled

protocol encryption enabled and legacy connections ticked off

dht enabled

u/l capped at 60kB/s

global max connections: 235

max # of connectd peers: 200

max.half open: 50


Link to comment
Share on other sites

You might uhm... want to cut down the number of connected peers per torrent? Upload 60 KiBps roughly equates to the Ctrl-G Speed Guide settings for xx/640k. Even there the connections per torrent are 100 with 3 downloads and 4 total torrents running for the queue. If you're only running 1 torrent concurrently then I guess it's OK though.

In the logger tab, if you right click you get the context menu, which is where you can set those options I mentioned :)

Uhm, are you sure you can have net.max_halfopen that high? Is that the number for your tcpip.sys? Verify under Ctrl-P -> Advanced your number there does not come within 80% of the max. The funny thing is if you're setup for forwarding correctly in any / all of your applicable hardware (modem and router) then you should be at least able to get the green light SOMEtimes. This is signified by clients in the Peers tab showing the "I" flag.

Could you double check the rules on your hardware and make sure they are for your PORT to your LAN IP?

Link to comment
Share on other sites

well i changed my net.max_halfopen back to 8 and i tried 4 as well but still nothing, still getting yellow light, saying my port is blocked, and very limited speeds... please any help is greatly, greatly appreciated...

edit: well i went to go change my port to something else, and before i even got to my router login screen, i got a green light, but i still get terrible speeds and it still says my port is blocked when i go to check it, i dont know why this is so messed up....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...