Jump to content

freezes computer


Recommended Posts

hello, geniuses of utorrent forums. i have had this problem with my computers for years, and ive tried many things to try and fix it but things never worked.

anyway, when im running utorrent (or another bittorrent client), my computer locks up and freezes and will not respond to commands. sometimes i can open the task manager and i see that there is no traffic through my connection.... so thats a waste of time. the only way to get my computer back is killing my wireless connection by turning off the switch, or killing my computer by taking the battery out (or reset button). i have to then restart the torrent client and the same thing happens again.

due to this problem, i cannot get my ratio up high, and i cannot finish downloads most of the time. here is my hardware/software specs:

Windows XP SP2

intel wireless 4965AGN

Linksys WRT54G v8 router

Core 2 Duo


Cable internet connection

Zonealarm Firewall

anything else you want to know about my computer, please ask.

i have disabled DHT, UPnP, and NAT to try and fix it, but to no avail. i have limited my max connections, my max half-open connections, and i have also "fixed" my TCPIP.sys file. anything else i should try? please help because i want to get my ratio high (and finish my downloads ontime too, without having to keep killing my connection forcefully)

Link to comment
Share on other sites

...if zonealarm is not running (read as: kill processes or uninstall entirely) does the problem persist?

In addition to possibly being due to incompatible software, WHEN incompatible software is installed, sometimes setting uTorrent's affinity for a single core can workaround the problem... If zonealarm uninstalled does not resolve the freezing, please provide a HiJackThis logfile and a process explorer logfile for utorrent's running DLLs. (download the zip, run procexp.exe, Ctrl-L, Ctrl-D, click utorrent.exe, Ctrl-A, copy-paste below).

Link to comment
Share on other sites

I think a HiJackThis log would be the next step... and if you're feeling advanturous a Process Explorer DLL list as well.

Like in the How-To, copy-paste the logfiles below please :D

For HJT run a full scan and paste below, it'll include processes and installed/startup programs. Process Explorer requires some finagling, download.zip, open procexp.exe, Ctrl-L, Ctrl-D, click utorrent.exe, Ctrl-A, and then copy-paste ;) It'll get resolved, soon enough.

Link to comment
Share on other sites

  • 3 months later...

hi guys. sorry to have been gone for so long.... i started using torrents again and the same problem persists. i have to force my computer to disable the wireless connection (via the switch on my laptop) in order to de-freeze my computer. here is the process explorer (i got it from microsoft?) log file:


Process: utorrent.exe Pid: 2876

Name Description Company Name Version

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 5.01.2600.2180

CLBCATQ.DLL Microsoft Corporation 2001.12.4414.0310

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.00.2900.2982

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.00.2900.2180

COMRes.dll Microsoft Corporation 2001.12.4414.0258


DNSAPI.dll DNS Client API DLL Microsoft Corporation 5.01.2600.2938

GDI32.dll GDI Client DLL Microsoft Corporation 5.01.2600.3099

hnetcfg.dll Home Networking Configuration Manager Microsoft Corporation 5.01.2600.2180

iphlpapi.dll IP Helper API Microsoft Corporation 5.01.2600.2912

kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 5.01.2600.3119


msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.00.2600.3085

mswsock.dll Microsoft Windows Sockets 2.0 Service Provider Microsoft Corporation 5.01.2600.2180

ntdll.dll NT Layer DLL Microsoft Corporation 5.01.2600.2180

ole32.dll Microsoft OLE for Windows Microsoft Corporation 5.01.2600.2846

oleaut32.dll Microsoft Corporation 5.01.2600.2180

rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 5.01.2600.2938

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 5.01.2600.2794

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.00.2900.3051

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.00.2900.3121




user32.dll Windows XP USER API Client DLL Microsoft Corporation 5.01.2600.3099


uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.00.2900.2523

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 5.01.2600.2180

winrnr.dll LDAP RnR Provider DLL Microsoft Corporation 5.01.2600.2180

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.01.2600.2180

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 5.01.2600.2180

WS2HELP.dll Windows Socket 2.0 Helper for Windows NT Microsoft Corporation 5.01.2600.2180

wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.01.2600.2180



i dont know if im doing it right though.

please help... again.

Link to comment
Share on other sites

Assuming you completely uninstalled Zone Alarm...

There doesn't seem to be anything hooked, so it's a problem with your wireless adapter. Find updated drivers for it, and if that doesn't help, you might need a different adapter altogether.

Link to comment
Share on other sites

actually i didnt uninstall zonealarm...... im actually reluctant to do so because thats the only firewall i trust....

i think its my adapter too, sorta.... but i dont know why. its an intel Wireless WiFi Link 4965AGN (on hp dv9500t laptop)

when i cut off my wireless conncetion by turning the switch off for my wireless, my computer becomes usable again....

i updated my drivers a while ago (still latest)

Link to comment
Share on other sites

If you have a router, good ant-virus, and stay away from obvious porn sites (videos pretending to be exe's), you don't need a firewall since the router has one. If you insist though, use Comodo Firewall. Dump ZA first and see how things work.

Link to comment
Share on other sites

ok this may be off topic but i use VMWare alot, and in VMWare i use Freespire (some linux distro) and i used the KTorrent app from there and it worked no prob :confused:

it must be my Windows installation, and like you said its prob my Zonealarm and i need to uninstall it.

is uninstalling Zonealarm easy? meaning do i just click uninstall or is it like AOL/Norton Antivirus where i have to get third party uninstall apps....

Link to comment
Share on other sites

thank you very much! it solved my problem! i uninstalled ZA and installed Comodo and now i finally have a high ratio for one of my torrents, lol. finally i can keep seeding/downloading without constantly killing my connection and getting frustrated.

and thanks for the set up instructions as well! those were very helpful, and at first i was lost after installing codomo.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...