Jump to content

Vista problem? Network stops working after +/- 24h on 2 computers


Recommended Posts

Hello there guys, I upgraded from XP to Vista (Business ed. on my desktop PC) about 4 months ago and after that I always had problem if I left uTorrent open for a reasonable amount of time - my network connectivity simply stopped, all I had to do is restart my PC and it worked again, so after over one month of testing, I gave up and just lived with it.

Problem is, now I bought a laptop and this problem also occurs on it, so I'm pretty sure it's a problem with Windows Vista (basic edition on my Laptop - Dell Latitude 630) and not my hardwares or uTorrent..

Can anyone help me to solve this damn problem? Here is what happens:

I start downloading stuff on uTorrent, which is configured for only 2 net.max_halfopen, 130 max connections, 70 peers per torrent, 3 uploads slots and 1 download slot. It all goes fine (speed, green tick, etc, all fine), but after around 24h of downloading my computer just can't connect to ANYTHING (uTorrent, Firefox, telnet, Thunderbird, nothing). I try to ping some IPs and I get replies, but if I try to connect, nothing connects. Ah, and I don't use any firewall software (on both computers).

What is really pissing me off is because it's happening on my 2 computers (I'm even on a different country now, jesus!!)..

Desktop PC (In Brazil, 1 month ago) - Motorola SB5100 cable modem, using a WRT54G (w/ DDWRT latest firmware) router, 3com network card, uTorrent 1.6.x, Vista Business all updated.

Laptop PC (In Argentina - right now) - Motorola SB5105 cable modem, no router, plugged in straight on ethernet, uTorrent 1.7.7, Vista Basic all updated.

Does anyone else suffer from the same problem or knows how to solve this? It's really pissing me off having to restart my computer every 24h because my network just dies with no error messages or crashes! :/

Thanks in advance :)

Link to comment
Share on other sites

My net.max_halfopen is set to 2 right now.

I will post a HighJackThis right now. I also limited speed setting to xx/128kb now and disabled all uPnP and DHT to see if it's gonna happen again.

Hijackthis log:

Logfile of Trend Micro HijackThis v2.0.0 (BETA)

Scan saved at 16:07:01, on 14/02/2008

Platform: Windows Vista (WinNT 6.00.1904)

Boot mode: Normal

Running processes:






















C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe

C:\Program Files\Broadcom\ASFIPMon\AsfIpMon.exe

C:\Program Files\CSR\Vista Profile Pack\BthFilterHelper.exe


C:\Program Files\Intel\Intel Matrix Storage Manager\Iaantmon.exe







C:\Program Files\Dell\QuickSet\NicConfigSvc.exe







C:\Program Files\DellTPad\Apoint.exe

C:\Program Files\Java\jre1.6.0\bin\jusched.exe


C:\Program Files\Intel\Intel Matrix Storage Manager\IAAnotif.exe


C:\Program Files\Common Files\InstallShield\UpdateService\issch.exe

C:\Program Files\DellTPad\ApMsgFwd.exe

C:\Program Files\CyberLink\PowerDVD DX\PDVDDXSrv.exe





C:\Program Files\iTunes\iTunesHelper.exe

C:\Program Files\Windows Media Player\wmpnscfg.exe

C:\Program Files\Digital Line Detect\DLG.exe

C:\Program Files\Dell\QuickSet\quickset.exe

C:\Program Files\DellTPad\HidFind.exe


C:\Program Files\DellTPad\Apntex.exe

C:\Program Files\Windows Media Player\wmpnetwk.exe

C:\Program Files\iPod\bin\iPodService.exe

C:\Program Files\Mozilla Firefox\firefox.exe

C:\Program Files\Mozilla Thunderbird\thunderbird.exe



R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = about:blank

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Window Title = Internet Explorer fornecido por Dell

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: Facilitador de Leitor de Link Adobe PDF - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: Skype add-on (mastermind) - {22BF413B-C6D2-4d91-82A9-A0F997BA588C} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - c:\Program Files\Java\jre1.6.0\bin\ssv.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O2 - BHO: Auxiliar de Conexão do Windows Live - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: G-Buster Browser Defense - {C41A1C0E-EA6C-11D4-B1B8-444553540000} - C:\Program Files\GbPlugin\gbieh.dll

O2 - BHO: Browser Address Error Redirector - {CA6319C0-31B7-401E-A518-A07C3DB8F777} - C:\Program Files\Dell\BAE\BAE.dll

O4 - HKLM\..\Run: [Apoint] C:\Program Files\DellTPad\Apoint.exe

O4 - HKLM\..\Run: [sunJavaUpdateSched] "c:\Program Files\Java\jre1.6.0\bin\jusched.exe"

O4 - HKLM\..\Run: [sigmatelSysTrayApp] sttray.exe

O4 - HKLM\..\Run: [iAAnotif] "C:\Program Files\Intel\Intel Matrix Storage Manager\Iaanotif.exe"

O4 - HKLM\..\Run: [broadcom Wireless Manager UI] C:\Windows\system32\WLTRAY.exe

O4 - HKLM\..\Run: [iSUSScheduler] "C:\Program Files\Common Files\InstallShield\UpdateService\issch.exe" -start

O4 - HKLM\..\Run: [PDVDDXSrv] "C:\Program Files\CyberLink\PowerDVD DX\PDVDDXSrv.exe"

O4 - HKLM\..\Run: [igfxTray] C:\Windows\system32\igfxtray.exe

O4 - HKLM\..\Run: [HotKeysCmds] C:\Windows\system32\hkcmd.exe

O4 - HKLM\..\Run: [Persistence] C:\Windows\system32\igfxpers.exe

O4 - HKLM\..\Run: [snpstd] C:\Windows\vsnpstd.exe

O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\QTTask.exe" -atboottime

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"

O4 - HKCU\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter

O4 - HKCU\..\Run: [iSUSPM Startup] C:\PROGRA~1\COMMON~1\INSTAL~1\UPDATE~1\ISUSPM.exe -startup

O4 - HKCU\..\Run: [WMPNSCFG] C:\Program Files\Windows Media Player\WMPNSCFG.exe

O4 - HKUS\S-1-5-19\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-20\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'SERVIÇO DE REDE')

O4 - Global Startup: Digital Line Detect.lnk = C:\Program Files\Digital Line Detect\DLG.exe

O4 - Global Startup: QuickSet.lnk = ?

O8 - Extra context menu item: E&xportar para o Microsoft Excel - res://C:\PROGRA~1\MICROS~2\OFFICE11\EXCEL.EXE/3000

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - c:\Program Files\Java\jre1.6.0\bin\npjpi160.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - c:\Program Files\Java\jre1.6.0\bin\npjpi160.dll

O9 - Extra button: Skype - {77BF5300-1474-4EC7-9980-D32B190E9B07} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll

O13 - Gopher Prefix:

O16 - DPF: {20A60F0D-9AFA-4515-A0FD-83BD84642501} (Checkers Class) - http://messenger.zone.msn.com/binary/msgrchkr.cab56986.cab

O16 - DPF: {C3F79A2B-B9B4-4A66-B012-3EE46475B072} (MessengerStatsClient Class) - http://messenger.zone.msn.com/binary/MessengerStatsPAClient.cab56907.cab

O16 - DPF: {DB6BF2CD-4F59-4F1C-AA9C-D08C0B61A931} (GbpDistObj Class) - https://www14.bancobrasil.com.br/plugin/GbpDist.cab

O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL

O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - C:\Windows\system32\browseui.dll

O23 - Service: Apple Mobile Device - Apple, Inc. - C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe

O23 - Service: Broadcom ASF IP and SMBIOS Mailbox Monitor (ASFIPmon) - Broadcom Corporation - C:\Program Files\Broadcom\ASFIPMon\AsfIpMon.exe

O23 - Service: Bluetooth Feature Support (BthFilterHelper) - CSR, plc - C:\Program Files\CSR\Vista Profile Pack\BthFilterHelper.exe

O23 - Service: Gbp Service (GbpSv) - Unknown owner - C:\PROGRA~1\GbPlugin\GbpSv.exe

O23 - Service: Intel® Matrix Storage Event Monitor (IAANTMON) - Intel Corporation - C:\Program Files\Intel\Intel Matrix Storage Manager\Iaantmon.exe

O23 - Service: Serviço iPod (iPod Service) - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe

O23 - Service: Gerenciamento de energia da placa interna de rede Dell (nicconfigsvc) - Dell Inc. - C:\Program Files\Dell\QuickSet\NicConfigSvc.exe

O23 - Service: SigmaTel Audio Service (STacSV) - SigmaTel, Inc. - C:\Windows\system32\STacSV.exe

O23 - Service: stllssvr - Unknown owner - C:\Program Files\Common Files\SureThing Shared\stllssvr.exe (file missing)

O23 - Service: Dell Wireless WLAN Tray Service (wltrysvc) - Unknown owner - C:\Windows\System32\WLTRYSVC.EXE

O23 - Service: XAudioService - Conexant Systems, Inc. - C:\Windows\system32\DRIVERS\xaudio.exe


End of file - 8974 bytes

Link to comment
Share on other sites

  • 2 weeks later...


I am also having the exact same problem as danielponte and dstylez.

I have used uTorrent for the last two years. In fact, until recently, I was still using version 1.6.1 with XP. The only thing I had to do was make sure uTorrent was listed as an exception in XP's firewall when I first installed it two years ago. I have had excellent results with XP and uTorrent 1.6.1 since then.

Now, I bought a new computer (upgraded from Pentium 4 to Dual-Core Quad) with Windows Vista. I loaded uTorrent 1.6.1 into Vista, no problems. I left all the settings the same. I even left the port number the same in uTorrent's settings (34xx). Started DLing some torrents. After about 6 or 8 hours, I went to check on its status to check the speeds and how far along it was. All torrents had stopped. My modem was still showing a connection but it was like the connection was stalled. All torrents were inactive. I shut off my modem, waited a few seconds, and restarted it. When I went to close and reopen uTorrent, a widow said " uTorrent processes still running"; something like that. I tried again and uTorrent finally closed and reopened. uTorrent checked each torrent and resumed downloading. Everything was back up to speed and looked fine. A few hours later, the same thing: I had an Internet connection but the torrents downloading had stalled and become inactive. I had to reboot my modem and restart uTorrent again.

I updated to the latest version of uTorrent (1.7.7 I believe), started out with my original port number (34xx) then changed different ports (clicked Random Port once and went with that port number. One was 29xxx and another was 50xxx) and after a fews hours each time, the downloading stalled. I am still using the same modem provided by my ISP as I never had any problems before with it until now. I have a Router but I don't have it installed yet as I want to figure out what is going on first with uTorrent and Vista. After changing port numbers, I always check to see if uTorrent finds the port openned and can accept incoming connections. I always get the green light. Each time, I always get a green check mark at the bottom of uTorrent for Network Connection. I can't remember exactly but when the torrents stall, I believe that there is nothing showing at the bottom of uTorrent for Network Connection. It's blank.

Is there any way to see if this is something happening with Windows Vista only? Maybe there is a new setting in Vista that needs addressed. I'm just guessing. This stinks because my torrents stop while I'm at work or asleep and I have to reset the modem and restart uTorrent in order to resume downloading.

I read a few of the latest thread headings and it looks like a few people are having the same problem, they're just starting different threads to state their problem. I see similarities between what I'm experiencing and what they are experiencing. Thanks for any help you can provide.

Sorry. Wanted to add alittle more info. After reading danielponte's post closer, I noticed that when my torrents stall, it seems I also lose Internet connection. My Windows Vista Home Premium is set to show animation in the task bar when connected to the Internet. When my torrents stop downloading, I'm showing no connection; hence, why I must have to reset my modem. This must be something in Windows Vista, I'm guessing.

My modem is showing green for Power, Ethernet, DSL, and Internet, but nothing at all for Activity. On Windows Vista, I'm showing no Network Connection animation in the taskbar.

Link to comment
Share on other sites

Something similar is happening to me. I've been running utorrent for over a year without any problems until about a week ago: on one of my Vista machines (my desktop - AMD X2 4200 Dual Core), every time I launch utorrent my network connection now drops. It then automatically reconnects, and after a few seconds I lose my internet connection again. I think this only happened after recently upgrading to 1.7.7 from 1.7.6, though my laptop is running 1.7.7 with Vista and it works fine.

I don't think it's a problem with the router, since the problem only occurs on my desktop. The strange thing is that if I run utorrent on my desktop pc now, I lose my internet connection for both my laptop and the desktop (and then I can connect for a few seconds, then it disconnects... over and over again.) The utorrent settings seem to be the same on both my laptop and desktop so I'm stumped.


Link to comment
Share on other sites

uTorrent doesn't find a port. It uses what you tell it to. The only time port cycling works is if you are setup on your POP for UPnP or NAT-PMP (POP stands for point of presence and in most cases for consumers that is your router).

Connection drop-outs are regularly due to ISP limitations. You are either overloading concurrent connections or bandwidth usage for a certain time. Lower your concurrent connections, follow How-To post #2, or lower upload bandwidth cap... 10% at a time is a nice number to use.

Link to comment
Share on other sites


You're mistaken, your problem is not the same as mine, I have to REBOOT my computer in order to get it working again, not my modem.

And by the way, I have 2 computers connected and only mine stops working, so my problem is not cable-modem related. It's my S.O. :(

By the way, I still have the f*ing problem, even tried patching my tcpip.sys to set a new limit on my max half-open connection... Ah, I found a new thing, if I let my uTorrent seeding only, it won't crash my connection, I havent downloaded anything last week until now and it hasnt crashed, the problem is only when I download :(

If someone knows something about it, let me know :)

Link to comment
Share on other sites


I am trying to help you and me also, trying to find out what is going on. I am still using the same modem, same setup, and same uTorrent settings. The only thing that has changed for me is my computer and OS also.

I am trying jewelisheaven's advice- DLing one torerent and lowered upload by 10%. See how long this lasts.

You said your computer doesn't crash or lock-up but you lose connection? I think we both are resetting our connections but just different ways.

danielponte, I am new to Vista, trying to get used to it. I was "snooping around" and found out if you are signed in as Administrator, you can look at error and warning logs.

Go to Control Panel -> System and Maintenance -> Administrative Tools at the bottom. In Administrative tools should be 'View Event Logs'. Inside you should see listings for everytime your computer listed errors and warnings.

Once inside Event Viewer, I expand Information and scrolled through the list. I noticed I had a large number of Errors for Dhcp-Client. I highlighted it and right clicked and chose 'View All Instances Of This Event'.

Now in the left hand column, I chose Administrative Events. This now lists ALL Errors and Warnings. I noticed a series of Warnings about a minute apart. They said:

'Your computer was not able to renew its address from the Network (DHCP server) for the network card. The semaphore (?) timeout has expired. Your computer will try to obtain its own address from the DHCP server.'

Then i get a final Error saying:

'Your computer has lost its lease to its IP address on the network card.'

So I am not sure if this is ISP releated or not. I'm not sure how the DHCP server works. I am with AT&T right now.


I was wondering if the same thing was happening to you. (Hope I didn't lose you with my lousy instructions).

Link to comment
Share on other sites

I concur. That's what I was recommending.. either lowering the connection count manually (Ctrl-P -> BitTorrent) or through the speed guide (Ctrl-G). If the EV tells you half-open is being hit, you need to make sure your Ctrl-P -> Advanced -> net.max_halfopen is default (* means non-default). Additionally you should notice a difference if you apply EITHER change (less connections, OR less upload over time)... But usually connections makes faster progress back towards "normal" operation.

Situations differ in this thread due to the manifestation and fixes. At minimum, a reboot is a sign of a larger incompatibility... usually relating to drivers, or RAM. At minimum, DHCP stopping means your POP (modem currently, but will be router when you plug it in) ... resets your connection for whatever reason.

I don't know specifics of ISPs, but making sure you are running encrypted traffic (Forced encryption, disallow legacy connections)... running low connection amounts, and running low bandwidth amounts especially during peak times (Using the Scheduler is easiest)... eliminates all of the hardware reset problems I have seen to date.

It's trial-and-error to see the tipping point for your ISP and hardware.

Link to comment
Share on other sites


Took your advice. I downloaded/seeded only one torrent and stopped all other downloads for now. Then for good measure, I decreased the upload rate on this one torrent downloading. (I usually max at 48KB total, this torrent maxed at 35KB so I reduced upload to 30KB, which was the next lowest rate in the Bandwidth Allocation -> Upload Limit). It has seeded now for a good 14 hours straight with no stalls or Internet disconnections. This is a first since I installed uTorrent on my new computer.

I also checked Event Log in Administrative Tools after downloading for those 14 hours and not once since lowering the upload rate and stopping the other torrents downloading did I have any Errors or Warnings about "reaching the limit imposed on the number of concurrent TCP connection attempts".

Thank you for your advice!

I guess for now with Vista, I will stick with downloading and seeding one torrent at a time. But this is at least a start in the right direction.

Thanks again for your help!

Link to comment
Share on other sites

If you did this without changing any settings... it only proves the settings allow you to overload the connection. I'm glad on minimal usage it works as expected :D Now you get to figure out where the tipping point is I talked about so you can be sure what it is and not exceed that. I still have an inkling the halfopen setting is allowing this to happen.

Link to comment
Share on other sites

I didn't mean to take over danielponte's thread. I thought we were having some of the same problems. I hope he still figures out what the problem is.


I'm not too "tech" savvy. The only "halfopen" setting I know of is uTorrent's (Ctrl - P -> Advanced). By default, 'net.max_halfopen' was already set at 8 by default for me. I never changed this number. Is this the 'halfopen' you are talking about? Should it be something else?

BTW I'm now downloading one torrent and seeding another with reduced capped upload speeds on both, no loss of connection. As stated, this is a first on this computer so far.

Link to comment
Share on other sites

ok, i'm kind of having the same problem with vista and have literally tried everything i can think of and utorrent will just not work. i start downloading something then at like 5%, or the first few minutes, it quits. i would still be connected to the internet but could not access anything on mozilla, or even ie. the strange thing was that i could actively use aim, but not msn messenger. i would have to restart my computer to be able to use the internet again. i do know that windows xp service pack 2 started limiting the number of TCP connect so i'm assuming that vista is doing the same, and i know of no way to change that number. i did go into my event log and found a slew of the same event id 4226. i tried just downloading soulseek and that would not work, and then steam would quit as well when i would try and download new games. i thought it was a firewall problem, and turned off every thing on my computer, but still nothing. i did the whole port forwarding thing and that still didn't help. i was on a steam support site and they listed some windows hotfixes which i installed and it helped with steam but still nothing for utorrent. actually i can now open utorrent and use mozilla at the same time, but i still cannot download. i actually uninstalled it like 2 months ago because i was so frusterated that i could not get it to work after i purchased my new computer and re installed it today but nothing has changed. i'm not that computer smart so i'm probably just sounding like an idiot, but these were all the things i could think of and know how to change. so if anyone knows anything else i can do, i would appreciate some help.

Link to comment
Share on other sites

  • 4 weeks later...

I have the same problem too!! happens with every torrent download manager, no just utorrent! but now it happens even when im not using it. i rarely turn off my laptop and so every so often this happens and im forced to restart. i think its a Vista problem, something to do with the DHCP, but im not sure how to sort it out

Link to comment
Share on other sites

jep i got a router, and the ports is open. i know this because i have 2 computers one with vista and one with windows xp. the one that have xp have no proplems. so i think it is a vista proplem. ???? when i say i treid averything i mean literally averything os i am out of iders

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...