Jump to content

1.3 doesn't properly connect to peers?


Recommended Posts

I've noticed that 1.3 doesn't properly connect to peers, after i've upgraded all my torrent were very slow, the client only connect to like 1 or 2 peers sometimes, very anoiying, even on a 1000+ seeder torrent, i've downgraded back to 1.2.2 and this one doesn't seem to have this problem?

what's up with this?, 1.3 is very very very slow

Link to comment
Share on other sites

Similiar Here!!!

Yes slow connects overall but seeds in my case as much as 30 mins...sometimes torrent is finished by time connect to 1 and sometimes never! Timestamped 27mins to connect to seed of 9 with 2 other peers leeching.

For notation: DHT is disabled and have been using BW alloc heavily... tops 3-5 torrents runnning! Nominal bw being used!

Edit: Will try lowering conn speed to see if helps but don't think that since not prob prior rel.

Link to comment
Share on other sites

If it is, I'm not noticing or feeling it so nothing to speak of! Have a 10/1mb conn so maybe wouldn't notice?!?!?

Tried the connect speed but no change.

First thing I noticed is peers come before seeds (fairly normal)...but in one case had to wait (15 mins) for peer to connect to dl when I was the only/first lch. These were low s/l counts so easy to watch..1-9 sds , 0-3 prs. First thought it was a tracker issue but jumped to another and similiar. Then thought the BW Alloc options but set them all to normal.

Ludde said the upload was more aggressive so maybe in changes the polling loop/thread falls out or never gets in based on initial start...something like that??? Given looking for net slow down assuming looking for indefinite loop symptom.

Anything else I could look at??

Link to comment
Share on other sites

"U", jaj!! Its a VPN Router!! Virtual Private Network!

Just to let you all know, went back 122 for now ... needed to finish seeds and should be able to revisit tonight!!

@Firon> Anything else you want me to try/look at??? Have already planned some testing torrents...was wondering if you or ludde had a test tracker to check from your side!

Link to comment
Share on other sites

Hey All,

Went back to 1.3 and disabled UPnP ... that seemed to work as far as connecting speed but still have problem connecting to avail seeds/peers ... e.g 50/8 avail > 3/3 connected ...


DHT disabled private trackers

Glb Max conn 1000

Max conn per trt 30 \

Max ul slot per 15 / even if I upped these same

halfopen 64 (upped per Firon)

connect speed 30

lazybit true

low cpu false


Think may have hit on something else.... seem to have problems with torrents that have private tracker bit off. In fact the example above is from trt with bit off.

Edit: connections come on and off...does clock ul/dl ks


Edit2: After 2hrs above example as climbed to 54/13 avail > 6/3 conn

Edit3: New torrent with PT bit on 2/14 avail > 1/9 in a couple of mins. cranking speed for this one also 400+dl / my max up stat bits UD or d through all conns

Link to comment
Share on other sites

Hi together.

I've noticed the same problems as ironboyzz and some others. I opend a Bug in the Bug Forum (see here -> http://forum.utorrent.com/viewtopic.php?id=3483 ). I will try the settings of ironboyzz to see if its better working. I am releasing new torrents so using µtorrent for this is currently unacceptable. I will edit this Post when I got the first results.

Edit1 ~ My current settings:





I have a DSL 6000 which means about 80kb/s upload and up to 650kb/s download.

My router has NAT enabled and forwards Ports 65509. Previous versions worked much better. With previous versions I mean 1.0-1.2 beta builds.

Actual example:

Torrent with 13/17 (seeders/leechers). Connections 5/4 (seeders/leechers).

Same torrent in Azureus:

Connections 11/14 (seeders/leechers).

Edit2 ~ Disabled UPnP:

- Didn't change the result. :(

If you need more informations please leave me a PN. I will add as much info as need to solve this bug.

Best regards,


Link to comment
Share on other sites

@ ShAQ> Disabling UPnP help my torrents speed up in connecting to s/ps not so much as the number of connections overall.

Edit: Since I made my changes, have not had any problems on my side...granted there are many factors as to how/who you are connected to, but for the most part, everything is working as I would expect it to.

TBH, I think my problem is an issue with µTorrent, Windows and Firewall collectively using UPnP. Other than disabling UPnP on µTorrent, no other changes were made. But note that all was fine with prior versions!

Link to comment
Share on other sites

@ ShAQ>[...]But note that all was fine with prior versions!

And thats the point. I didn't changed my settings.

With 1.2.2:

- Fantastic Speed

- Fast connection to others

- upload is stable

With 1.3:

- Slow Speed

- less connections to others (extremly!)

- upload is a little bit unstable

Please keep in Mind - I didn't changed my settings or replace anything on my hardware or somethings. Just a simple version change, nothing more. But with extremly effects ...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...