Jump to content

uTorrent Says 100%, Force Re-Check says incomplete


SuperJ

Recommended Posts

I have been experiencing this issue with most of my torrents so far, mostly with .7z, .zip, and .rar files.

It will say that it is finished 100%. So I go to extract the information, and it tells me CRC Check Failed or Data Corrupt etc. etc...

So I go to force re-check in uTorrent that the creators so thoughtfully provided (this is after it told me it was 100%) and it rechecks and finds that the data was not fully downloaded (usually puts me at around 95%-99%) and begins to download again. When it says its finished, I try again, but it fails again. I recheck again and it sees it is missing data. I watch the pieces download and they seem to fill in, and all the bars in the Files and Pieces sections go to 100% and are all blue. I check the data again, and it is again corrupt. I even delete the rar or 7z files that are corrupt and download them again, and again this error surfaces. This goes on and on, very rarely I get lucky and it finishes.

I am not quite sure what is happening here. I am running on a Linksys WRT54G, but I don't think this has anything to do with it. I get fine speeds and my router doesn't hang. This seems to have been happening more recently, I have never encountered this problem before and I hope there is some way to make it go away.

Sometimes when I run uTorrent, my network cable disconnects then reconnects very quickly. Mabye my client is sending a packet that it finished the download before it actually finished it?

I can't really think of any reason this is happening except for my Windows install dying or my Hard Disk failing (which I find very hard to believe, its only 1 year old and only used half that time). If anyone has had this problem or knows of it, please tell me how u fixed it or what you are doing to fix it.

I have even tried to reinstall uTorrent, no luck :/

Thanks :) :/

Link to comment
Share on other sites

Hmm, mabye i should try to replug my hard drive and reset my memory.

Will try this and report back :/

EDIT:

Well, I took out my SATAs, blew on the connectors to get out any dust, blew in the power supply to get rid of any dust, re set my memory and blew on that, and it worked!

I Force Re-Checked and it saw that I had finished downloading all but 99.9%, so it downloaded the last bit and none of the files failed a CRC or had any Data corruption :)

I don't know if I got lucky or that was the issue, I'm sure it could happen again if it wanted to...

I guess if it continues Ill need a new computer...

Thanks for the suggestions :)

I'll be sure to report back with any other errors ;)

Link to comment
Share on other sites

Ran Memtestx86 and found that one of my RAM sticks was bad, took it out and everything is running smooth, no random crashes or unfinished files. New problem tho, my connection keeps on saying Disconnected then Reconnects very fast. I suspect its my WRT54G, but I don't know what to do about it. I'll make a fresh post.

Link to comment
Share on other sites

  • 2 months later...

Hi to all I just wanted to update this thread maybe someone might be experiencing this problem, I have been having the same errors whenever I download a large file (4GB or more), when the downloads complete I uncompress the file & got CRC errors, I make a force re-check, again Utorrent goes to 99.9% & re-downloads another part of the file, I have to repeat this process two or three times in order for me to be able to extract the file without any problems.

After reading this thread I ran a windows memory diagnostic test & to my surprise one of the memory modules resulted to be faulty, it is quite strange since i never had any random crashes or bsod's with my PC, however the tests showed that one of my modules was faulty.

Thanks to this thread I hopefully managed to find out what was causing these CRC errors, & I also found out that i had a faulty module before it could have gotten any worse!!

Link to comment
Share on other sites

  • 2 weeks later...

Have got the same problem. Downloaded a ~ 4gb torrent and I've force re-checked it like 6 times now and it's constantly finding new pieces to download.

I've run memtest86+ and after 2 passes still no errors. So that means my memory isn't the problem right? Could it be my SATA-controller and if so, how can I test that? Any other momory test program that I can run without a cd-drive in my PC?

Thanks

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...