Jump to content

Connection Closed by Peer...?


Recommended Posts


I've read a few other posts from people with similar problems, but haven't really understood many of the suggested solutions to this issue. Any help would be greatly appreciated.

Basically, in the last 48 hours I have had trouble downloading a couple of torrents. My tracker status reads 'connection closed by peer' and my DHT status reads 'not allowed'. Now, as I've never had a problem downloading before, I've no idea what these should say but I'm guessing that's not right, huh.

Anyway, my downloads have all but frozen (d/l at 0.1% and 2.9% u/l at 0% and 18% respectively), the arrows to the left of the file name are in a red box, and it's really frustrating. I've tried many different torrents, all having the same problem. The really weird thing is that it decided to work for a few hours last night and managed to get 40% through a couple of large files (albeit at a slightly slower rate than usual), and now it's gone down again.

I haven't changed any settings on my computer, and have been running utorrent for a couple of months now so I'm at a loss as to why this has happened. The only thing I did out of the ordinary recently was to perform a Disk Cleanup (I'm running Windows Vista).

I've made no changes to my firewall or security settings, as far as I'm aware, I've enabled protocol encryption, and the port I'm using is permanent, not a random change every time utorrent opens. It's also open I presume, as I check it when I reinstalled (I tried reinstalling, too, and this resulted in the few hours of successful runtime I mentioned above).

So there we have it. Apologies for the length of this post, but the more information available the better, I guess, so it'll hopefully be easier to solve this problem!

Many thanks to anyone out there who can help.


PS. These are the trackers for one of the files I'm trying to download, it that helps:



Link to comment
Share on other sites

Hi, thanks for the response. There's no note about 'leeching' or anything in the status.... Plus, why would it start all of a sudden when it's been working fine for weeks? And it's not just these files, it's happened with half a dozen now that i've had to cancel...

I've got a thing saying:

"No connection could be made because the target machine actively refused it" for one tracker as well, and the occasional one saying they 'timed out'. Um? For so many trackers to refuse to work, there must be some problem...

Link to comment
Share on other sites

jewel... I can't think of any changes that were made other than those negligible things I mentioned in the first post. Plus, it's strange that it worked okay again for a while last night, something I guess wouldn't have happened if any system changes had screwed it up?

Ultima - tried downloading the thingy from that page, but it too gets mired in the dead zone of my torrents (says connection closed by peer). So maybe it is an ISP thing. But if that were the case, surely more people would be complaining? Anything I can do if it's an ISP issue? Damn them.

Thanks for the ideas so far.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...