Jump to content

System lag and uTorrent


Recommended Posts

I once had a problem with utorrent causing the computer to use 100% CPU power. This trickered a bug on the mainboard, this bug contantly told me that a jack-plug was unplugged and then re-plugged. Happened over and over again, with intervals, less than a second. I read it might be a firewall problem. I contacted my firewall supplier and they helped me solve it.

But I don't think its gone. Winamp lags, when it plays a file from the harddrive and my utorrent is running. I have a 250GB Seagate harddrive. Its a SATA-II or the one nicknamed SATA300. It has a data transfer of 300Gbits/sec I think. Something like that. I have 2GB of Kingston memory. Its 800mhz dual-channel DDR-II blocks. And I have an Intel E4400 Core2 Duo duo processor, all on a Windows XP Pro platform.

I hope I didn't leave out any important details...

I'm afraid I can't offer more technical insight on the problem. Though it seems that the more torrents I have loaded in uTorrent, the more problems I have. But 1 torrent is enough to make Winamp lag. My internet browser is also seriously affected by this. It nearly stalls.


Link to comment
Share on other sites

Logfile of HijackThis v1.97.7

Scan saved at 23:58:32, on 12-05-2008

Platform: Windows XP SP2 (WinNT 5.01.2600)

MSIE: Internet Explorer v7.00 (7.00.6000.16640)

Running processes:







C:\Programmer\Lavasoft\Ad-Aware 2007\aawservice.exe





C:\Programmer\MSI\Live Update 3\LMonitor.exe


C:\Programmer\DAEMON Tools\daemon.exe


C:\Programmer\BullGuard Ltd\BullGuard\bullguard.exe


C:\Programmer\Fælles filer\InstallShield\UpdateService\isuspm.exe


C:\Programmer\Fælles filer\Logishrd\KHAL2\KHALMNPR.EXE


C:\Programmer\BullGuard Ltd\BullGuard\BullGuardUpdate.exe



C:\Programmer\Fælles filer\Microsoft Shared\VS7DEBUG\MDM.EXE

C:\Programmer\NVIDIA Corporation\nTune\nTuneService.exe



C:\Programmer\Adobe\Adobe Version Cue CS2\data\database\bin\mysqld-nt.exe

C:\Programmer\MSN Messenger\usnsvc.exe

C:\Programmer\MSN Messenger\msnmsgr.exe


C:\Programmer\Mozilla Firefox\firefox.exe


R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName = Hyperlinks

O2 - BHO: (no name) - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Programmer\Adobe\Adobe Acrobat 7.0\ActiveX\AcroIEHelper.dll

O2 - BHO: (no name) - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\PROGRA~1\MICROS~2\Office12\GRA8E1~1.DLL

O2 - BHO: (no name) - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Programmer\Java\jre1.6.0_05\bin\ssv.dll

O2 - BHO: (no name) - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll

O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll

O4 - HKLM\..\Run: [Kernel and Hardware Abstraction Layer] KHALMNPR.EXE

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Programmer\Java\jre1.6.0_05\bin\jusched.exe"

O4 - HKLM\..\Run: [QuickFinder Scheduler] "C:\Programmer\WordPerfect Office X3\Programs\QFSCHD130.EXE"

O4 - HKLM\..\Run: [PWRISOVM.EXE] C:\Programmer\PowerISO\PWRISOVM.EXE

O4 - HKLM\..\Run: [nwiz] nwiz.exe /install

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [NeroFilterCheck] C:\WINDOWS\system32\NeroCheck.exe

O4 - HKLM\..\Run: [KernelFaultCheck] %systemroot%\system32\dumprep 0 -k

O4 - HKLM\..\Run: [iSUSScheduler] "C:\Programmer\Fælles filer\InstallShield\UpdateService\issch.exe" -start

O4 - HKLM\..\Run: [iSUSPM Startup] "C:\Programmer\Fælles filer\InstallShield\UpdateService\isuspm.exe" -startup

O4 - HKLM\..\Run: [GrooveMonitor] "C:\Programmer\Microsoft Office\Office12\GrooveMonitor.exe"

O4 - HKLM\..\Run: [C-Media Mixer] Mixer.exe /startup

O4 - HKLM\..\Run: [Adobe Version Cue CS2] "C:\Programmer\Adobe\Adobe Version Cue CS2\ControlPanel\VersionCueCS2Tray.exe"

O4 - HKLM\..\Run: [Acrobat Assistant 7.0] "C:\Programmer\Adobe\Adobe Acrobat 7.0\Distillr\Acrotray.exe"

O4 - HKLM\..\Run: [bullGuard] "C:\Programmer\BullGuard Ltd\BullGuard\bullguard.exe" -boot

O4 - HKLM\..\Run: [LiveMonitor] C:\Programmer\MSI\Live Update 3\LMonitor.exe


O4 - HKLM\..\Run: [Alcmtr] ALCMTR.EXE

O4 - HKLM\..\Run: [sony Ericsson PC Suite] "C:\Programmer\Sony Ericsson\Mobile2\Application Launcher\Application Launcher.exe" /startoptions

O4 - HKCU\..\Run: [NVIDIA nTune] "C:\Programmer\NVIDIA Corporation\nTune\nTuneCmd.exe" clear

O4 - HKCU\..\Run: [MsnMsgr] "C:\Programmer\MSN Messenger\MsnMsgr.Exe" /background

O4 - HKCU\..\Run: [DAEMON Tools] "C:\Programmer\DAEMON Tools\daemon.exe" -lang 1033

O4 - HKCU\..\Run: [CTFMON.EXE] C:\WINDOWS\system32\ctfmon.exe

O4 - HKCU\..\Run: [bullGuard] "C:\Programmer\BullGuard Ltd\BullGuard\bullguard.exe"

O4 - HKCU\..\Run: [iSUSPM] "C:\Programmer\Fælles filer\InstallShield\UpdateService\isuspm.exe" -scheduler

O4 - HKCU\..\Run: [DAEMON Tools Pro Agent] "C:\Programmer\DAEMON Tools Pro\DTProAgent.exe"

O4 - Startup: MagicDisc.lnk = C:\Programmer\MagicDisc\MagicDisc.exe

O4 - Startup: Webshots.lnk = C:\Programmer\Webshots\Launcher.exe

O4 - Global Startup: Adobe Acrobat Speed Launcher.lnk = ?

O4 - Global Startup: Adobe Gamma.lnk = ?

O4 - Global Startup: Logitech SetPoint.lnk = C:\Programmer\Logitech\SetPoint\SetPoint.exe

O8 - Extra context menu item: Convert link target to Adobe PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert link target to existing PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert selected links to Adobe PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECaptureSelLinks.html

O8 - Extra context menu item: Convert selected links to existing PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppendSelLinks.html

O8 - Extra context menu item: Convert selection to Adobe PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert selection to existing PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: Convert to Adobe PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIECapture.html

O8 - Extra context menu item: Convert to existing PDF - res://C:\Programmer\Adobe\Adobe Acrobat 7.0\Acrobat\AcroIEFavClient.dll/AcroIEAppend.html

O8 - Extra context menu item: E&ksporter til Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000

O8 - Extra context menu item: Open with WordPerfect - C:\Programmer\WordPerfect Office X3\Programs\WPLauncher.hta

O9 - Extra 'Tools' menuitem: Sun Java Console (HKLM)

O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 (HKLM)

O9 - Extra button: Messenger (HKLM)

O9 - Extra 'Tools' menuitem: Windows Messenger (HKLM)

O11 - Options group: [iNTERNATIONAL] International*

O16 - DPF: {31435657-9980-0010-8000-00AA00389B71} - http://download.microsoft.com/download/e/2/f/e2fcec4b-6c8b-48b7-adab-ab9c403a978f/wvc1dmo.cab

O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab


I took this scan while the jack-plug bug was trickered by utorrent. I checked my device manager, but I can't see those settings you talk about. I don't really get the option of choosing any settings...shouldn't I right-click, and then choose 'properties' on ALL the SATA and IDE devices that is listed?


Link to comment
Share on other sites

Check the properties of each device listed, one at a time and check the 'Advanced Settings' tab.

Please do this as well.

B) get Process Explorer from sysinternals.com, run it, Ctrl+D (to show the lower DLL pane), select the µTorrent process from the list, Ctrl+S (and save the list somewhere you'll find easily -- like the Desktop), then post the contents of the saved process list in the .txt file here

Furthermore, check which "process" is using all the CPU in Process Explorer.

Link to comment
Share on other sites

Process PID CPU Description Company Name

System Idle Process 0 83.85

Interrupts n/a Hardware Interrupts

DPCs n/a 6.92 Deferred Procedure Calls

System 4 1.54

smss.exe 968 Windows NT-sessionsstyring Microsoft Corporation

csrss.exe 1044 Client Server Runtime Process Microsoft Corporation

winlogon.exe 1068 Windows NT-logonprogram Microsoft Corporation

services.exe 1112 Tjenester og controllerprogrammer Microsoft Corporation

svchost.exe 1312 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1400 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1524 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1628 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1836 Generic Host Process for Win32 Services Microsoft Corporation

aawservice.exe 1952 Ad-Aware 2007 Service Lavasoft

spoolsv.exe 852 Spooler SubSystem App Microsoft Corporation

lmgrd.exe 612


BullGuardUpdate.exe 656 BullGuard LiveUpdate Service BullGuard Ltd.

svchost.exe 764 3.85 Generic Host Process for Win32 Services Microsoft Corporation

MDM.EXE 1624 Machine Debug Manager Microsoft Corporation

nTuneService.exe 2060 NVIDIA Access Manager NVIDIA

nvsvc32.exe 2368 NVIDIA Driver Helper Service, Version 169.21 NVIDIA Corporation

PnkBstrA.exe 2388

wdfmgr.exe 2536 Windows User Mode Driver Manager Microsoft Corporation

alg.exe 3688 Application Layer Gateway Service Microsoft Corporation

usnsvc.exe 3528 Messenger Sharing USN Journal Reader Service Microsoft Corporation

lsass.exe 1124 LSA Shell (Export Version) Microsoft Corporation

explorer.exe 288 0.77 Windows Stifinder Microsoft Corporation

jusched.exe 552 Java Platform SE binary Sun Microsystems, Inc.

rundll32.exe 600 Kør en DLL som et program Microsoft Corporation

mixer.exe 680 Mixer C-Media Electronic Inc. (www.cmedia.com.tw)

LMonitor.exe 724 UpdateMonitor MFC Application

RTHDCPL.exe 732 Realtek HD Audio Control Panel Realtek Semiconductor Corp.

daemon.exe 784 Virtual DAEMON Manager DT Soft Ltd.

ctfmon.exe 808 CTF Loader Microsoft Corporation

BullGuard.exe 816 BullGuard BullGuard Ltd.

ISUSPM.exe 868 Macrovision Software Manager Macrovision Corporation

SetPoint.exe 1444 Logitech SetPoint Event Manager (UNICODE) Logitech, Inc.

KHALMNPR.exe 1768 Logitech KHAL Main Process Logitech, Inc.

msnmsgr.exe 3300 Messenger Microsoft Corporation

firefox.exe 2836 Firefox Mozilla Corporation

rundll32.exe 3708 Kør en DLL som et program Microsoft Corporation

mmc.exe 1652 Microsoft Management Console Microsoft Corporation

procexp.exe 3832 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

utorrent.exe 3344 3.08

mysqld-nt.exe 2572

Process: utorrent.exe Pid: 3344

Name Description Company Name Version

ACTIVEDS.dll ADs Router Layer-dll Microsoft Corporation 5.01.2600.2180

adsldpc.dll C-DLL til ADs LDAP-provider Microsoft Corporation 5.01.2600.2180

ADVAPI32.dll Avanceret Windows 32 Base-API Microsoft Corporation 5.01.2600.2180

ATL.DLL ATL Module for Windows XP (Unicode) Microsoft Corporation 3.05.2284.0000

CLBCATQ.DLL Microsoft Corporation 2001.12.4414.0308

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.00.2900.2982

comdlg32.dll DLL-fil med fælles dialogbokse Microsoft Corporation 6.00.2900.2180

COMRes.dll Microsoft Corporation 2001.12.4414.0258


DNSAPI.dll DNS Client API DLL Microsoft Corporation 5.01.2600.3316

GameHook.dll Logitech Gaming Hook (UNICODE) Logitech, Inc. 4.40.0088.0000

GDI32.dll GDI Client DLL Microsoft Corporation 5.01.2600.3316

hnetcfg.dll Konfigurationsstyring til Hjemmenetværk Microsoft Corporation 5.01.2600.2180

IMM32.DLL Windows XP IMM32 API Client DLL Microsoft Corporation 5.01.2600.2180

Iphlpapi.dll IP Helper API Microsoft Corporation 5.01.2600.2912

kernel32.dll Klient-DLL til Windows NT BASE API Microsoft Corporation 5.01.2600.3119

lgscroll.dll Logitech Scroll Enabler (UNICODE) Logitech, Inc. 4.40.0088.0000


MFC80U.DLL MFCDLL Shared Library - Retail Version Microsoft Corporation 8.00.50727.0762

MPRAPI.dll Windows NT MP Router Administration DLL Microsoft Corporation 5.01.2600.2180

MSCTF.dll DLL-fil til MSCTF-server Microsoft Corporation 5.01.2600.2180

msctfime.ime Microsoft Text Frame Work Service IME Microsoft Corporation 5.01.2600.2180

MSVCP80.dll Microsoft® C++ Runtime Library Microsoft Corporation 8.00.50727.1433

MSVCR80.dll Microsoft® C Runtime Library Microsoft Corporation 8.00.50727.1433

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.00.2600.2180

mswsock.dll Microsoft Windows Sockets 2.0-tjenesteudbyder Microsoft Corporation 5.01.2600.2180

NETAPI32.dll Net Win32 API DLL Microsoft Corporation 5.01.2600.2976

ntdll.dll DLL til NT-lag Microsoft Corporation 5.01.2600.2180

NTMARTA.DLL Windows NT MARTA provider Microsoft Corporation 5.01.2600.2180

ole32.dll Microsoft OLE til Windows Microsoft Corporation 5.01.2600.2726

OLEAUT32.dll Microsoft Corporation 5.01.2600.3266

PluginHook.dll SpamFilter Outlook Express Plugin BullGuard Software 8.00.0000.0002

PluginHookRes.dll PluginHookRes Bullguard Software 7.00.0000.0000

rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 5.01.2600.2938

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 5.01.2600.3173

rtutils.dll Routing Utilities Microsoft Corporation 5.01.2600.2180

SAMLIB.dll SAM Library DLL Microsoft Corporation 5.01.2600.2180

Secur32.dll Security Support Provider Interface Microsoft Corporation 5.01.2600.2180

SETUPAPI.dll API til Windows Installation Microsoft Corporation 5.01.2600.2180

SHELL32.dll Dll-fil med fælles dialogbokse til brugergrænsefladen i Windows Microsoft Corporation 6.00.2900.3241

SHLWAPI.dll Shells letvægts-programmappe Microsoft Corporation 6.00.2900.3314




USER32.dll Windows XP BRUGER API Klient Microsoft Corporation 5.01.2600.3099


uxtheme.dll Microsoft UxTheme-bibliotek Microsoft Corporation 6.00.2900.2180

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 5.01.2600.2180

winrnr.dll LDAP RnR Provider DLL Microsoft Corporation 5.01.2600.2180

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.01.2600.2180

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 5.01.2600.2180

WS2HELP.dll Windows Socket 2.0-hjælper til Windows NT Microsoft Corporation 5.01.2600.2180

wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.01.2600.2180


Thats the saved txt-file from Process-explorer. I kinda assume from the previous reply that the hijack-this log is clean?

I think I found that setting you were reffering to. I can choose between 'Only PIO' or 'DMA, if available'. Its set to use 'DMA, if available'.


Link to comment
Share on other sites

The current transfer mode is 'Ultra DMA-5' on the 'Standard IDE/ESDI harddrive controller' and the same on the first primary and secondary IDE-channels. For some reason the primary and secondary IDE-channels appear 3 times each in the list. And only the first one of each has this setting, I can't see the settings on the others. I can't see what the SATA drivers/controllers are set to.


Link to comment
Share on other sites

You have multiple generic channels? Your probably missing drivers, you can use CPU-Z to find out what chipset your south bridge is, and try to find appropriate drivers for it. Also, I'm not sure as I'm not the HJT/PE kinda person here, but that SpamFilter crap has been loaded into µTorrent and might be causing problems.

Link to comment
Share on other sites


I expanded the entire tree in the device manager, there is no yellow question marks. So I guess all the mainboard drivers are loaded. But I'm not 100% sure on that.


when I got home today the computer seemed seriously overloaded. So I stopped uTorrent before I got to check what program was hogging up all the system ressources. I tried to open CPU-Z to find the answer to GTHK's questions. CPU-Z failed to open and trickered that jack-plug-bug again. I took a look at the processes and CPU-Z took about 40% uTorrent and Bullguard was both very low. uTorrent used less than 10%, definately. And Bullguard sometimes popped up to 1% CPU usage. Total CPU load was about 75%.

However...I also removed a lot from the torrentlist. So I haven't been able to recreate the problem, yet. I'll post again when I've recreated the problem, and tell what process exactly that takes up the CPU. Of what I can remember the last time this happened, it was both uTorrent AND Bullguard. But there was a lot of malware on my computer at that time, so I don't know if its the same problem.


Link to comment
Share on other sites

The drivers loaded are probably generic Windows one, this happened on mine as well. Once I loaded the proper drivers, seven controllers became two. CPU-Z isn't working? Since your system is bugging, did you try with µTorrent closed? If you can't get it to work, SpeedFan will identify your chipset on startup... the System Information program included in Win XP may list it, but it lists other stuff mixed in. For System Information All Programs > Accessories > System Tools > System Information > Expand Hardware Resources > Conflicts/Sharing. Look for something ending with SATA Controller, post the whole controller name.

Link to comment
Share on other sites

I just downloaded a driver for the mainboard. The chipset driver, I'm pretty sure it is.

Here is a link to the view in the device manager: (Note: I have a danish version of Windows XP Pro)


Here is a link to what CPU-Z shows:


That leads me to believe that the southbridge drivers are already installed properly. I did download a new set of drivers from the mobo-manufacturers webpage and install them anyway.

I'm kinda thinking...could it be because I'm behind a router or something like that? I talked to some guys here where I live. They said that if fx. the correct ports are not open, that could induce lag on fx. game servers. Could it be the same problem here?

Like the processor has to re-route all traffic through the available ports and the result being that running uTorrent uses 100% CPU power?

After installing the drivers I rebooted and tried to load some torrents in uTorrent. Nothing happened. For a while the workload seemed to be 50% en the PE. Then fell to near zero. And the download speed was around 1MBit at that time. I started winamp, and there was no lag to detect in the playback. Even though winamp's files and the torrents where from the same partition on the same physical drive. So I have no clue wether the problem is solved or not.

Maybe those drivers did do something, though it doesn't look like it in the Device Manager.


Link to comment
Share on other sites

If you're sure it's the right controller drivers, uninstall all the controllers and restart so you can be sure Windows installs only the new ones. Windows is kinda retarded when it comes to updating IDE drivers.

Link to comment
Share on other sites

Ok I managed to induce system lag today, including the soundcard bug! I took some screenshots from inside PE, one with the graphs and one with the process list.



Process list:



I've succesfully failed at trying to remove the controller drivers. Frankly I'm not sure how to. Am I just supposed to right-click in the device manager and choose 'remove'? I might be a retarded question. But sometimes when ppl ask me to do things like that I do it in a wrong way. Its the only way I can find, so I reckon thats the way. But sometimes, I guess, if you do such things wrong, then the driver doesn't get removed totally and then you get a driver conflict when you try and load the new driver, or some gruesome thing like that.


Link to comment
Share on other sites

Just right-click and press uninstall, don't reboot on the ones that ask you, just go through each one. Some wont disappear from the list, It's ok if you accidentally press uninstall twice, just make sure you do it to all of them at least once, and then reboot. Windows will reinstall using the most up to date available to it, so if you installed the right drivers correctly those will be used.

Link to comment
Share on other sites

Properly installed drivers get copied to somewhere in the Windows folder. If it doesn't work, use the update driver option on one of the controllers, then uninstall the rest, this will copy it to the Windows folder, and the others will install with it. If there's a problem, hold F8 while starting Windows, last known good configuration.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...