Jump to content

speed, port forward, spybot and vista SP1


Recommended Posts


My problem is my seeding speed and port forwarding, and the following is what I already tried, to get things to work, still with no success.

I've been using ut 1.7.7, encapsulated, in Windows Vista home basic x86 (32) for several months WITHOUT problems. :) Recently I installed sp1 using the build-in Windows Update. The same day, I also installed Spybot Search & Destroy. Since then, my seeding speed is erratic, and the number of peers I connect to is lower than before.

Searching the forum I couldn't find anything about spybot incompatibilities with ut. I also searched spybot's website. Nothing. But I wanted to be on the safe side, at least for troubleshooting, so I remove (uninstalled) spybot (including the resident module), erase all the rules for the Windows Firewall (I'm not using any other firewall and I don't have any router), restart Windows, and let ut build the rules again using administrative rights. No improvements there.

I also tried uninstalling (completely) avast! home edition 4.8, but I didn't see any improvement (I should wait longer?), so I installed it again with the same preferences than before (ut is not checked in p2p shield, so it shouldn't be a problem).

Searching for a solution, I changed net.max_halfopen from 4 (default) to 1, since vista home basic x86 sp1 max half open connections is 2. Even though I know net.max_halfopen should be lower than the max of tcpip.sys, I tried setting it to 2 instead of 1, and I didn't see any new 4226 id events (using event viewer); even using IE AND ut at the same time.

As I said, before installing sp1 i was using net.max_halfopen of 4. After spybot (remember, uninstalled) and sp1, I had to wait for about an hour or more just to get some peers to download from me (currently, and for troubleshooting porpose I'm just seeding, not downloading anything). Of course, this was not the situation before sp1 (I used to start seeding after several minutes of starting ut). I have tried several torrents, with the same situation almost all of them (still, it could be just coincidence). There ARE torrents, though, I get to seed after several minutes. In any case, the seeding speed is not "constant", as it was before sp1. For that "constant" upload I may have to wait for 2 hours, or even worse, it won't happen. Since vista before sp1 and the current vista WITH sp1, I didn't change any ut parameter other than the net.max_halfopen. If I understand correctly (do I?), now with net.max_halfopen set to 2 (the max of vista home basic sp1) I will most certainly have to wait for hours to actually start seeding to peers each time I start ut.

All this happened with the green icon in the status bar, "network ok". I tried checking with the speed guide test, and sometimes it says ok, but if I check again it gives me an error, as if I were not forwarding correctly. Several seconds, and "F5", and I get "ok", and so on if I check several seconds later. The icon in the status bar? Yes, green always except for the first minute (or two, tops) every time I start ut, as it should be.

So I turn off windows firewall, and even erased the rules for utorrent, unchecked "Add ut to windows firewall exception", saved the preferences. This didn't get the "error portforwarding" go away (F5 refresh at the test port forwarding page), so I tried several combinations of all this firewall settings, without success (I didn't exit ut for each combination, though, just waited several minutes to see if there were any changes). I also searched portforward.com for anything about vista and sp1, tcpip.sys half-open connection limit or something like that. I didn't find anything there (that doesn't mean it's not there, of course).

Even though all this is not happening because ut itself (I hope), I would be very grateful if anyone could help me find a solution, and hopefully we can help others with vista sp1 and ut too.

So now my questions (finally!).

1) Should I care about the portforwarding test result if the status bar icon is always green?

2) In the cases where the speed guide test doesn't match the status bar icon, In which cases the status bar icon is "saying the truth" about portforwarding, and in which ones the speed guide test result is the "true" status?

3) Has the test's failure anything to do with the max half-open connection limit of vista home x86 sp1? (Maybe, the web page in IE with the test doesn't get response by the time it expects because that same instant the max half-open connections limit has already been reached, so the test fails?)

4) I read about changing the tcpip.sys half-open connection limit, and I didn't feel I really needed it using vista previous to sp1. According to my situation, should I use the cracktcpip.sys v.744 driver or any other kind of patch? Or still it's not recommended for using with ut? What should I expect from using it? Does anyone knows about instabilities with it or any other issue worth knowing before using it? Does anyone using vista sp1 actually uses it and has any comment about it? Is there any solution or path or update to the tcpip.sys limit that comes from Microsoft kb itself?

5) What about spybot? Does anyone knows about any incompatibility with ut, torrents and vista sp1?

6) Is it possible all this is just a coincidence and the problems are related to my ISP? I would like to rule out all software related issues before I get into ISP's problems.

From my point of view, and for this specific situation, all these questions are pointing me to solve the problem, so please don't take these questions as ones that should be asked in several different threads.

As an example, right now I got peers to download from me (and at a mostly "constant" speed) after waiting for 4 and a half hours. The torrent properties: DHT on (got 82 peers), PEX on, seeds 0 of 71 (232 in swarm), peers 2 of 257 (68 in swarm), tracker status "working" (not private). In this specific torrent, it could be possible the peers didn't really "need me" to upload to them before, and right now there are 2 peers wich prefer to download from me than from other seeders. This COULD be the case. I just want to be sure I at least get to connect to enough peers in an acceptable time. After that, if "the swarm" really decides not to connect to me... :) I'm also thinking that this 4 and a half hours could happen not only as a seeder, but as a regular peer also in any future torrent I decide to get!

This example does not mean I am indeed forwarding the port correctly, since it is not impossible to connect to others if I'm not forwarding the ports correctly, just not very common or usual. Am I right?

I really would like to use ut as I used to, before sp1. I even didn't talk about downloading speed - that should be fine after solving the port thing, the seeding irregular speed and the "get peers to connect to me" problems (if there is any :)

If anyone needs more info, just ask me. I really don't know if you would need hardware info, speed tests, ut parameters other than the ones I changed after installing sp1, Proccess Explorer or HJT logs, ISP info... I just know that the other ut parameters were working fine for me in vista home basic x86 before sp1.

Sorry for the long post. Any help is very welcome and very needed!

Link to comment
Share on other sites

Probably not spybot... Did you change the half_open prior to installing SP1? If you're getting the same connectivity as before (peer #s) then try disabling "<90% add slots" in Ctrl-P -> BitTorrent

If you want other evaluation of your setup please copy-paste the hijackthis log... it may point out something else you missed

Link to comment
Share on other sites

Thank you for taking time to help.

Right now, I'm seeding 2 torrents for several hours as it should be. The reason I'm seeding 2 torrents instead of just 1 is to minimize the possibility of not seeding anything for hours again. With 2 torrents, if I get disconnected from 1 of them, or even the upload speed of 1 of them decreases, it may be possible the other swarm would take advantage of the "free" bandwith. In a standard "seeding" situation, I would be seeding just 1 torrent at a time to maximize the swarm speed. Still, I'm not downloading right now, just for troubleshooting purpose.

If I wouldn't know I was waiting for 4 and a half hours just to start seeding, I would say the current situation is fine (every speed graph shows a strait uploading speed line for 8 hours now and I will continue as long as I can). But I suspect the next time I will start ut I will get the same "waiting" situation.

In the meantime, from the very beginning of this troubleshooting proccess, I lowered the upload slots from 3 (default in speed guide) to 2, so to keep alive and healthy the connections in both swarms, but still using additional upload slots if upload speed < 90%. My upload speed tests got 128 kb/s (16 kB/s), and I used that for the speed guide initially (hence up slots were 3 by default). Starting with the default 9 kB/s in speed guide, I'm currently at 11 kB/s upload speed limit (as I said, working fine). I used 60 global connections in ut, and currently I changed that to 50 (there are not so many peers I get connected to anyway, and I tried to minimize the influence of too many connections). My connections limit per torrent are 18. With these numbers, I wasn't having problems before installing sp1.

I also had UPnP and NAT disabled (I'm wired connected to the cablemodem and there is no router). After I finally got connected to peers, and just to try and see what happens, I enabled both of them in ut, and later on I also enabled Windows firewall (added the rules). I also stopped several Avast! "providers" (Instant messaging, Internet mail and Outlook/Exchange providers), that are not related to my current problems. Right now, everything seems to be working as it should, but again I'm afraid it will take hours each time to get connected, or that I will not get the port forward.

I hope all this steps could guide also others in troubleshooting. Could anyone tell me if these steps are worth the trouble? Are my ut parameters ok for this troubleshooting purpose?

Still, my questions are in the first post of this thread.

My Hijackthis and Proccess Explorer logs with the current "connected" situation are:

Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 09:52:11, on 2008-05-15

Platform: Windows Vista SP1 (WinNT 6.00.1905)

MSIE: Internet Explorer v7.00 (7.00.6001.18000)

Boot mode: Normal

Running processes:





C:\Program Files\Windows Defender\MSASCui.exe

C:\Program Files\Intel\Intel Matrix Storage Manager\IAAnotif.exe


C:\Program Files\Microsoft IntelliPoint\ipoint.exe


C:\Program Files\Java\jre1.6.0_05\bin\jusched.exe



C:\Program Files\Alwil Software\Avast4\ashDisp.exe


C:\Program Files\Microsoft IntelliPoint\dpupdchk.exe


F:\P2P\portable utorrent freeware closesource\utorrent.exe

C:\Program Files\Internet Explorer\IEUser.exe


C:\Users\adyadmin\Downloads\HARD\System Info\tren micro secure\HiJackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =

R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =

O1 - Hosts: ::1 localhost

O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_05\bin\ssv.dll

O2 - BHO: (no name) - {7E853D72-626A-48EC-A868-BA8D5E23E045} - (no file)

O2 - BHO: Windows Live Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll

O2 - BHO: FDMIECookiesBHO Class - {CC59E0F9-7E43-44FA-9FAA-8377850BF205} - C:\Program Files\Free Download Manager\iefdm2.dll

O4 - HKLM\..\Run: [Windows Defender] %ProgramFiles%\Windows Defender\MSASCui.exe -hide

O4 - HKLM\..\Run: [iAAnotif] "C:\Program Files\Intel\Intel Matrix Storage Manager\Iaanotif.exe"

O4 - HKLM\..\Run: [RtHDVCpl] RtHDVCpl.exe

O4 - HKLM\..\Run: [skytel] Skytel.exe

O4 - HKLM\..\Run: [intelliPoint] "C:\Program Files\Microsoft IntelliPoint\ipoint.exe"

O4 - HKLM\..\Run: [PAC7302_Monitor] C:\Windows\PixArt\PAC7302\Monitor.exe

O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_05\bin\jusched.exe"

O4 - HKLM\..\Run: [igfxTray] C:\Windows\system32\igfxtray.exe

O4 - HKLM\..\Run: [HotKeysCmds] C:\Windows\system32\hkcmd.exe

O4 - HKLM\..\Run: [Persistence] C:\Windows\system32\igfxpers.exe

O4 - HKLM\..\Run: [avast!] C:\PROGRA~1\ALWILS~1\Avast4\ashDisp.exe

O4 - HKUS\S-1-5-19\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'LOCAL SERVICE')

O4 - HKUS\S-1-5-20\..\Run: [sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'NETWORK SERVICE')

O8 - Extra context menu item: Download all with Free Download Manager - file://C:\Program Files\Free Download Manager\dlall.htm

O8 - Extra context menu item: Download selected with Free Download Manager - file://C:\Program Files\Free Download Manager\dlselected.htm

O8 - Extra context menu item: Download video with Free Download Manager - file://C:\Program Files\Free Download Manager\dlfvideo.htm

O8 - Extra context menu item: Download with Free Download Manager - file://C:\Program Files\Free Download Manager\dllink.htm

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_05\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_05\bin\ssv.dll

O13 - Gopher Prefix:

O16 - DPF: {21F49842-BFA9-11D2-A89C-00104B62BDDA} -

O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab

O17 - HKLM\System\CCS\Services\Tcpip\..\{30607873-CDE3-4EBD-B134-A9E6AC8F2C00}: NameServer =

O17 - HKLM\System\CS1\Services\Tcpip\..\{30607873-CDE3-4EBD-B134-A9E6AC8F2C00}: NameServer =

O23 - Service: avast! iAVS4 Control Service (aswUpdSv) - ALWIL Software - C:\Program Files\Alwil Software\Avast4\aswUpdSv.exe

O23 - Service: avast! Antivirus - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashServ.exe

O23 - Service: avast! Mail Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashMaiSv.exe

O23 - Service: avast! Web Scanner - ALWIL Software - C:\Program Files\Alwil Software\Avast4\ashWebSv.exe

O23 - Service: Intel® Matrix Storage Event Monitor (IAANTMON) - Intel Corporation - C:\Program Files\Intel\Intel Matrix Storage Manager\Iaantmon.exe


End of file - 5654 bytes


Process PID CPU Description Company Name

System Idle Process 0 100.00

Interrupts n/a Hardware Interrupts

DPCs n/a Deferred Procedure Calls

System 4

smss.exe 448 Windows Session Manager Microsoft Corporation

csrss.exe 516 Client Server Runtime Process Microsoft Corporation

wininit.exe 560 Windows Start-Up Application Microsoft Corporation

services.exe 604 Services and Controller app Microsoft Corporation

svchost.exe 824 Host Process for Windows Services Microsoft Corporation

mobsync.exe 2040 Microsoft Sync Center Microsoft Corporation

igfxsrvc.exe 2952 igfxsrvc Module Intel Corporation

unsecapp.exe 3464 Sink to receive asynchronous callbacks for WMI client application Microsoft Corporation

WmiPrvSE.exe 3532 WMI Provider Host Microsoft Corporation

svchost.exe 888 Host Process for Windows Services Microsoft Corporation

svchost.exe 924 Host Process for Windows Services Microsoft Corporation

svchost.exe 1024 Host Process for Windows Services Microsoft Corporation

audiodg.exe 1196 Windows Audio Device Graph Isolation Microsoft Corporation

svchost.exe 1056 Host Process for Windows Services Microsoft Corporation

dwm.exe 576 Desktop Window Manager Microsoft Corporation

svchost.exe 1088 Host Process for Windows Services Microsoft Corporation

taskeng.exe 480 Task Scheduler Engine Microsoft Corporation

taskeng.exe 2348 Task Scheduler Engine Microsoft Corporation

SLsvc.exe 1228 Microsoft Software Licensing Service Microsoft Corporation

svchost.exe 1276 Host Process for Windows Services Microsoft Corporation

svchost.exe 1448 Host Process for Windows Services Microsoft Corporation

aswUpdSv.exe 1556 avast! Antivirus updating service ALWIL Software

ashServ.exe 1576 avast! antivirus service ALWIL Software

spoolsv.exe 1800 Spooler SubSystem App Microsoft Corporation

svchost.exe 1828 Host Process for Windows Services Microsoft Corporation

IAANTmon.exe 496 RAID Monitor Intel Corporation

svchost.exe 2228 Host Process for Windows Services Microsoft Corporation

svchost.exe 2276 Host Process for Windows Services Microsoft Corporation

svchost.exe 2316 Host Process for Windows Services Microsoft Corporation

SearchIndexer.exe 2368 Microsoft Windows Search Indexer Microsoft Corporation

ashWebSv.exe 2768 avast! Web Scanner ALWIL Software

lsass.exe 616 Local Security Authority Process Microsoft Corporation

lsm.exe 628 Local Session Manager Service Microsoft Corporation

csrss.exe 572 Client Server Runtime Process Microsoft Corporation

winlogon.exe 672 Windows Logon Application Microsoft Corporation

explorer.exe 1184 Windows Explorer Microsoft Corporation

MSASCui.exe 2236 Windows Defender User Interface Microsoft Corporation

IAAnotif.exe 2264 Event Monitor User Notification Tool Intel Corporation

RtHDVCpl.exe 2400 HD Audio Control Panel Realtek Semiconductor

ipoint.exe 2552 IPoint.exe Microsoft Corporation

dpupdchk.exe 3156 dpupdchk.exe Microsoft Corporation

Monitor.exe 2592 Registry Monitor PixArt Imaging Incorporation

jusched.exe 2640 Java Platform SE binary Sun Microsystems, Inc.

hkcmd.exe 2744 hkcmd Module Intel Corporation

igfxpers.exe 2780 persistence Module Intel Corporation

ashDisp.exe 2796 avast! service GUI component ALWIL Software

explorer.exe 3680 Windows Explorer Microsoft Corporation

procexp.exe 3312 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

utorrent.exe 3736

ieuser.exe 3372 Internet Explorer Microsoft Corporation

Process: utorrent.exe Pid: 3736

Name Description Company Name Version

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 6.00.6001.18000

apphelp.dll Application Compatibility Client Library Microsoft Corporation 6.00.6001.18000

CLBCatQ.DLL COM+ Configuration Catalog Microsoft Corporation 2001.12.6931.18000

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.10.6001.18000

comctl32.dll.mui User Experience Controls Library Microsoft Corporation 6.10.6001.18000

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.00.6001.18000

dhcpcsvc.DLL DHCP Client Service Microsoft Corporation 6.00.6001.18000

dhcpcsvc6.DLL DHCPv6 Client Microsoft Corporation 6.00.6001.18000

DNSAPI.dll DNS Client API DLL Microsoft Corporation 6.00.6001.18000

DUser.dll Windows DirectUser Engine Microsoft Corporation 6.00.6001.18000

duser.dll.mui Windows DirectUser Engine Microsoft Corporation 6.00.6000.16386

GDI32.dll GDI Client DLL Microsoft Corporation 6.00.6001.18023

iertutil.dll Run time utility for Internet Explorer Microsoft Corporation 7.00.6001.18000

imageres.dll Windows Image Resource Microsoft Corporation 6.00.6000.16386

imageres.dll.mui Windows Image Resource Microsoft Corporation 6.00.6000.16386

IMM32.DLL Multi-User Windows IMM32 API Client DLL Microsoft Corporation 6.00.6001.18000

IPHLPAPI.DLL IP Helper API Microsoft Corporation 6.00.6001.18000

kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 6.00.6001.18000



LPK.DLL Language Pack Microsoft Corporation 6.00.6001.18000

MSCTF.dll MSCTF Server DLL Microsoft Corporation 6.00.6001.18000

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.00.6001.18000

mswsock.dll Microsoft Windows Sockets 2.0 Service Provider Microsoft Corporation 6.00.6001.18000

napinsp.dll E-mail Naming Shim Provider Microsoft Corporation 6.00.6001.18000

NLAapi.dll Network Location Awareness 2 Microsoft Corporation 6.00.6001.18000

NSI.dll NSI User-mode interface DLL Microsoft Corporation 6.00.6001.18000

ntdll.dll NT Layer DLL Microsoft Corporation 6.00.6001.18000

ole32.dll Microsoft OLE for Windows Microsoft Corporation 6.00.6001.18000

OLEAUT32.DLL Microsoft Corporation 6.00.6001.18000

pnrpnsp.dll PNRP Name Space Provider Microsoft Corporation 6.00.6001.18000

PROPSYS.dll Microsoft Property System Microsoft Corporation 6.00.6001.18000

PSAPI.DLL Process Status Helper Microsoft Corporation 6.00.6000.16386

rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 6.00.6000.16386

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 6.00.6001.18000

Secur32.dll Security Support Provider Interface Microsoft Corporation 6.00.6001.18000

SETUPAPI.dll Windows Setup API Microsoft Corporation 6.00.6001.18000

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.00.6001.18000

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.00.6001.18000

urlmon.dll OLE32 Extensions for Win32 Microsoft Corporation 7.00.6001.18023

USER32.dll Multi-User Windows USER API Client DLL Microsoft Corporation 6.00.6001.18000

USP10.dll Uniscribe Unicode script processor Microsoft Corporation 1.626.6001.18000


uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.00.6001.18000

WINNSI.DLL Network Store Information RPC interface Microsoft Corporation 6.00.6001.18000

winrnr.dll LDAP RnR Provider DLL Microsoft Corporation 6.00.6000.16386

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 6.00.6001.18000

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 6.00.6001.18000

wshtcpip.dll Winsock2 Helper DLL (TL/IPv4) Microsoft Corporation 6.00.6001.18000

Again, thank you very much for your help, and I hope this can be of help for others too.

Link to comment
Share on other sites

Indeed.. here's the thing, for cases like this, you can think of the following formula you'll see around here if you look at enough of the forums... UPLOAD / (TORRENTS * SLOTS) >= 3 ... that is to say, as you say for the Speed Guide settings for xx/128 you have 1 torrent 3 upload slots. You can change that to 3 torrents 1 upload slot, and even the <90% as you said before, and generally keep the same throughput. The only difference would be the speed you appear to others as. Remember you get reciprocal speeds, but since you're talking about seeding it's mostly moot. At 15 KiBps a 4MiB piece takes just shy of 5 minutes to pump out, so be advised especially for larger piecesize torrents you may NEED to pump up the upload slots. As peers keep track of your limited throughput... if you don't give up alot for them they are less likely to retrieve from you later. It's in this case where LESS upload slots would be preferred, but it's not always possible.

As far as the logs, thanks. ;) I see nothing in P.E., which is good. And HJT shows Avast, which should be fine :/ Could you try without FDM installed? Silly question, is your modem (from the ISP) listed @ http://www.portforward.com/english/routers/port_forwarding/routerindex.htm as including mini-router functionality? It doesn't seem like it, or it's minimal and/or turned off as your icon is usually green, but the temperamental port tester makes me think otherwise ><

Link to comment
Share on other sites


So I suppose my posts were too long to read :( Do I need to open a new thread, now that I have ruled out possible troublemakers? I'm still having intermittent "error" messages using the speed guide test, but the status bar icon is always green. Any ideas?


I took some time to evaluate several possible solutions. You asked if I changed net.max_halfopen from 4 to 2 before installing sp1. No, I was using the default 4, installed sp1, then changed it to 2. Before sp1 I saw some 4226 events, but it was no such a big deal. After installing sp1 I couldn't get connected the same way as before, so I start searching the forum. That's why I lowered it.

BTW, I don't know how many are having trouble forwarding ports in ut in general, but I read here several cases of having trouble connecting or low speeds just after installing sp1 (both x86 and x64) while this was not happening before the sp1 update, according to those same posts. So it may be a good idea to take a look at this, try to find a solution and add it to the faq or the troubleshooting guides.

You suggested uninstalling FDM. I did it and rebooted, but I couldn't notice a specific improvement in connectivity.

As of my cablemodem, Terayon TJ715, I didn't see it listed in portforward.com . I didn't notice any problem with it before, though. Do you know if it has any firewall capabilities or any other settings that could be making trouble?

One thing I remember was that just after sp1, Windows Update also gave me the possibility to update the Network adapter's driver, and I did it. So I searched for an even more updated driver (Installing a new driver can make things better, but it also could make something else worst). I installed the most stable updated driver. It didn't help in my specific case, but in general I would recommend to anyone having problems to search for updated drivers and to take a look at its "last changes log" as part of a troubleshooting guide. I just hope in my case that these new after-sp1 drivers are not messing up with my connectivity. As a last option, I will check this possibility by rolling back to the pre-sp1 network adapter's driver.

I couldn't find in the forum any real suggestions about changing tcpip.sys in vista sp1. I just found "comments" about it, or people asking for help but not returning to say how they solved their problem. So I take a risk and installed something that changes the halp-open max limit. I don't know if it's ok to post the site where I got it. I'm not sure if it is even legal, from the point of view of microsoft, to change something about tcpip.sys. I would say though that I didn't change the tcpip.sys file itself, but added some driver which changes the half-open limit in memory. Searching the web everyone could find it. I don't really know if installing this could be "dangerous". After all, I AM using Windows Firewall, Windows Defender, Avast!, and from time to time I use SpywareBlaster. So installing something I know nothing of, and with no serious comments or references about its implications, was for me in some degree a "risk". (Please, don't laugh at me. Not everyone can spend hours reformating and installing everything again after some trojan took over the system :)

So I checked, with Event Viewer, if I got any new 4226 events. I changed net.max_halfopen back to 4 (default). Still no 4226 events. I took it to 6 and 8. No 4226 events. So I don't really know if nothing else was changed in my system by this driver, or if setting more than 250 as the half-open connections limit (not in ut, but as a whole) is really a safety concern (at least, microsoft thinks so). What I CAN say is that before, when net.max_halfopen was 2, it tooks more than 4 hours to start seeding to peers (after installing sp1). Now it took 2 hours :) Ok, not so good as I wanted, but better than before. All this with the network adapter's driver I received from Windows Update.

But still, I get intermittent "error" when I use the speed guide test. The status bar icon is always green. That's why I asked before, in which cases the icon is giving me the real status, and in which cases the speed guide test results are the "true" ones.

I'm not getting steady seeding speeds either. After setting the net.max_halfopen to 8, and after waiting for 2 hours, I finally got steady upload speed (remember I am not downloading anything, just for troubleshooting purpose) for 14 hours. Then it slowed down (and up, not getting to the max and no steady speed) and after 2 more hours I decided to stop all, update to the new network adapter's driver I told you before, reboot and start over.

I can't reproduce exactly the same conditions each time. The swarm changes, people connecting and disconnecting with different connection speeds, ISP bandwith, time of the day, weekday or weekend, the specific torrents I try to seed...

I'm not sure what next step to try and what to set as it was before. Do I keep the new network adapter's driver? And what about that driver which changes the half-open connection limit? Do I keep it? Maybe these specific torrents are just not good enought to make a choice and a final decision, but a "test" torrent (openoffice, etc.) is not a good choice either. In the best case, a "test" torrent would download, but even before installing sp1 I couldn't get to seed them (my best upload speed would be useless for the swarm so I could not get steady upload speed, which is my goal here).

If I can't find a solution, I will have to look at my ISP for "new" throttle issues. Since this is not really under my control (other than changing it), I really want to look for any possible improvements in compatibility with vista sp1 x86.

Can anyone help me answer the questions of my first post in this thread? Any ideas? Does anyone know which is the real troublemaker after installing sp1? Any known solutions? I really want to finish this thread posting a solution!

Thank you in advance for your help and patience, and don't hesitate to ask me for more information if it can help us.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...