Jump to content

Weird things going on with my computer


Recommended Posts

Hi guys, I am having weird problems with utorrent. Here are my system specs:

amd 64 3000+ skt 754

chaintech vnf3-250 motherboard

1 GB OCZ pc3200 and 512 MB Mushkin memory

3x200 gig hdd, 1 hitachi, 1 SG, 1 WD

Rocketraid IDE ATA100 controller

Windows XP SP2

SpeedStream 802.11B USB 2.0 wifi card

Dlink DI-614+ router

Zonealarm firewall

The problem started after the following changes were made to the system:

Loaded windows xp with SP 2 (need it for VS 2005, Damn you Microsoft)

Loaded the SP2 patch to fix the number of new connections from 10 and put it to the highest value possible, which is around 600,000 or so (patch found somewhere on this site)

In utorrent, checked the "Pre-allocate Disk Space" which is located in Preferences->Torrent Options.

I have 20 Torrents loaded up and having the following settings in utorrent:

Global maximum upload rate: 10 KB

Global maximum number of connections: 2000

Maximum number of connected peers per torrent: 500

Number of upload slots per torrent: 4

The problem is that after a few minutes, my mouse starts to lag and the CPU spikes to 100% or so and stays there. I tried closing utorrent and this action in itself took a long time, a few minutes for the utorrent icon to disappear from the start menu. However, the mouse continues to lag and looking at Task Manager, it shows that the utorrent process is still running and using about 5.5 MB of memory. However, under CPU column it shows for the utorrent task that the CPU usage is 0% even though the CPU usage on the bottom shows 99-100%. Very weird. I try to end the process and it takes a long time for it to disappear, about 3 minutes or so. After the process disappears everything goes back to normal.

I tried removing utorrent but I cant find the folder for it. It does not appear under Program Files and a search reveals nothing. I removed the icon that I use to launch utorrent and then I downloaded utorrent again. Samething occurs. I've even shutdown zonealarm and that didn't help. I've stopped the downloading and seeding of torrents and that DID WORK!!! So I don't know what to figure, whether it is some corrupted torrent or utorrent itself is corrupted. I will try and stop each torrent at a time. Is there a certain limit on the number of torrents that I can download?

My question is three fold:

What can possibly be causing this problem?

What can I do to fix this problem? Is it possible to remove utorrent completely somehow? Perhaps certain registry items need to be removed?

If this problem is not fixable, where does utorrent store torrent information so that I can try and use another program and see if the problem still occurs. I would like to keep my downloaded information.

edit: sorry, I forgot, I also added a few more torrents. That might be the cause, I will check.

Link to comment
Share on other sites

Why the hell did you set the patch to such a high number? Set it to 100. If you got it from this site, you'd also see that it says to never use higher than 100! It only affects half-open connections (connection ATTEMPTS), not established connections.

And why 500 connections? Unless you have a 20mbit symmetric connection, using that many will SLOW you down. Serves you right for putting such stupid numbers in both of them. And with such a pitiful upload (10 KB/s, so I guess it's 128kbit), you should be using 50 or lower per torrent, and 200 global. Nor should you run more than 2 torrents.

Uninstall Zone Alarm and see if it goes away. If it doesn't, run Sysinternals Process Explorer and see if there's DPCs using a ton of CPU (I bet they are). If this is the case, either you have a) bad drivers B) bad hardware or c) some kernel level software that's totally screwing up (AV, firewall, etc)

Link to comment
Share on other sites

SpeedStream 802.11B USB 2.0 wifi card

Dlink DI-614+ router

Zonealarm firewall

How do you connect to your internet connection?

Through your router?

If so, what's the wifi card for?

If there's a possibility to get internet access through more than 1 path, Windows invaribly picks the wrong one.

Link to comment
Share on other sites

The Dlink is a wireless router. I use the USB wireless card to connect wirelessly to the router and then the internet.


thats my wifi card.

I think I narrowed it down. but I am not sure. The system seems to lag when it is verify the integrity of the file. After that it seems fine. I will have to test it a bit longer, but I think when utorrent goes through the verifying process it takes up too many resources.

Does that seem right?

Edit: I've also reduced the number of open connections to 100, and maximum connections to 200 and number of connected peers to 50.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...