Jump to content

IP resolving doesn't work


Recommended Posts



Yesterday uT resolved IP of peers but now this feature is broken even if the option is selected (right click on peer column) !!

So I get no flags and no DNS for IP !!!

Maybe the process ti resolve IP is corrupt or something like that...

Can I try to delete a file from uT folder about IP resolving process and restart uT ?

Thx in advance. ciao

Link to comment
Share on other sites

Yep yesterday IP resolving worked fine, but after an upgrade of modem firmware, it's not more the case.

My normal internet is good, portforwarding on my ADSL box didn't change, I didn't change any settings in uT manager...

uT works fine but only IP are not resolved, that's why I asked you if this internal process in uT needs to be connected on Internet.

I'm in Wifi so I will see if with ethernet wire it's the same thing...


EDIT: same pbm with ethernet wire.

Link to comment
Share on other sites


I searched on the web and I found that (in FAQ too):

Settings to activate Flags: 'peer.resolve_country' under 'settings' 'enhanced', must be 'false' selected (otherwise the service from DNSBL is used).

A text files including data on which hosts map to which country, since by default .com and .net hosts are mapped to the US. This will not work if you have peer.resolve_country set to true in the advanced settings, as that will set µT to use a DNSBL service to determine countries instead.

So uTorrent has an internal process to resolve IP so-called DNSBL service but I dunno if it needs to connect to internet ?!?

I tried to set "true" for peer.resolve_country and several flags have appeared but not for all seeding torrents and its was only for a short moment.

And with "false" value (default value in uT), always nothing when I activate IP resolving with right click on peer column...

So uT has a weird behavior to resolve IP !!!

Link to comment
Share on other sites

The usual DNS lookup request is an outgoing request on port 53 over UDP.

Wow thanks for the info. Maybe the upgrade of modem firmware has changed the policy of filtering.

Do you know if I need to create a additional rule of portforwarding (for #53) or just modify the policy of the modem firewall ?

IMPORTANT: When I set "true" the variable "peer.resolve_country" in Advanced Preferences and select "Resolve IPs" in IP column, flags appear after 5 or 10 min but ONLY flags, not resolved IP !!!!

Screens: http://i26.tinypic.com/5yvo2h.jpg

But before I didn't need to change the value of "peer.resolve_country" to view flags (false value by default), I just needed to switch in IP resolving mode.... :(


Link to comment
Share on other sites


I dont think so.

I visited this page and the IP printed after REMOTE_ADDR is the same as the IP of my modem.

Then Orange (rebranding name of Wanadoo ;) ) doesn't use an ISP transp. proxy.

I think it's the upgrade of the firmware that has added a "new" rule in portfiltering or modem FW or something like that...

And uTorrent behaviors strangely with this new firmware, default IP resolving (DNSBL service, peer.resolve_country = false) or advanced IP resolving (flags.conf/.bmp of eng, peer.resolve_country = false) don't work !

So if you said IP resolving needs port 53 to work, maybe the problem is here with the new firmaware.

Link to comment
Share on other sites

Wanadoo ISP don't require a proxy to work. And they don't act as transparent proxy. The sagem livebox is an adsl/router/firewall. The Livebox has an internet IP and computers have locals IPs (192.168.1.x). Wanadoo has automatically updated the firmware and it seems that the internal firewall block utorrent 1.7.7 reverse DNS, probably because of malformed packets/connection (or strange rules in the new default firewall rules)...


It seems that the internal DNS of the Livebox (with new firmware) fail for reversing IP.

So, don't use as DNS server but directly an Orange server: : dns-adsl-gpe1-a.wanadoo.fr : dns-adsl-gpe2-a.wanadoo.fr : dns-adsl-gpe1-b.wanadoo.fr : dns-adsl-gpe2-b.wanadoo.fr : dns-adsl-gpe3-l.orange.fr : dns-adsl-gpe4-l.orange.fr : dns-adsl-gpe3-m.orange.fr : dns-adsl-gpe4-m.orange.fr : dns-abo-static-a.wanadoo.fr : dns-abo-static-b.wanadoo.fr : dns-rtc-gpe3-l.orange.fr : dns-rtc-gpe4-l.orange.fr : dns-rtc-gpe3-m.orange.fr : dns-rtc-gpe4-m.orange.fr

And that work again :D

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...