Jump to content

Could my speed problems be because of my modem, and not my WRT54G?


Recommended Posts

For years I've had problems with my speed, and I've tried just about every trick in the book to alleviate them, all to no avail. Instead of going into details, I'll just run through the list:

Forwarding about a million ports

Enabling and disabling DMZ

Flashing more than one custom firmware to my WRT54G

Running all sorts of different custom configurations for those firmwares

Testing to see if my ISP is throttling BT ports

Changing max allowed connections and all that jazz in utorrent, which changed nothing

The list could go on, but at this point I don't even want to think about how much trouble I've had with this. Over the years, here's what I've noticed:

If I even open utorrent, my internet goes out. I can occasionally get pages to load, but it takes quite a few refreshes and goes slow as hell. Oddly enough, anything I have open before opening utorrent, like xfire or msn, still functions, however, if I disconnect them and try to reconnect, I can't. This means that if I have any torrents going, I effectively cannot browse the web.

I usually only get between 10 and 20 kBps, when downloading from a well seeded torrent, and that's if the torrent even starts downloading to begin with. My upload however, seems fine, and I routinely complete torrents having uploaded double what I downloaded. Great for everyone else, but terrible for me, as 3GB torrent takes weeks for me to finish.

I cannot forward ports. No matter what I do, no matter what guide I follow, not one port will open up. I've disabled ever firewall, tried forwarding a million different ports through my router which did nothing, and I've even eliminated the router and tried forwarding ports through my modem which also did nothing.

On private trackers, I can actually get decent speeds sometimes. What I've noticed is that when I open the torrent it will top out at about 28kBps, but occasionally I'll see it jump to my max download speed of about 450, but then as quickly as it jumped it will slam back down to about 28. However, if I leave it going for a long enough time, it will eventually get up to my max speed and stay there until the download finishes.

If I refresh a large server browser, say in UT2004 or TF2 or something, my internet goes out for 5 minutes, just like it does when I open utorrent.

Now, I know all of this could be attributed to my router, I've heard that all of these problems are pretty common with the WRT54G, however, all of this still happens even if I take the router out of the picture. All of the custom firmwares designed to fix this exact problem with the WRT54G, did nothing for me, so is it possible that the modem is the problem? The modem is the one my ISP gave me, it's made by VisionNet.

I'm at the end of my rope here, and I don't know what to do. Would getting a new modem fix these problems? Am I even allowed to use a different modem other than the one my ISP provided me?

Forgive my ignorance or anything I didn't explain properly, I know very little about this stuff and everything I've learned has been taught to me by reading guides while trying to fix this problem.

Thanks to anyone who reads this lengthy post, and many thanks to anyone who can offer any insight.

Link to comment
Share on other sites

Holy crap, it's working! Thanks a lot man!

And for some reason I was able to open the ports fine with just the modem, even though the times I'd tried it before it didn't work. I was still stuck at 28 kB/s on a well seeded private tracker torrent for a bit, but it shot up to over 400 much faster than it usually does and it didn't throttle back down.

Now all I can do is hope it works when I throw the router back into the equation.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...