Jump to content

Firewall and port problem


Recommended Posts

My PC is in private network ,so i am behind a linux server (firewall/dhcp/samba/squid/routing etc.)

I asked our administrator for a little favour (it was about forwarding a port) ,because I needed it to reach my PC through SSH and BT stuff.

So he forwarded a port 222 to my local ip address. The SSH is working pretty well. But when I set the port in utorrent ( Options > Preferences > Connection > ... ) to 222 ,the

utorrent port checker -> Error! Port 222 does not appear to be open

https://www.grc.com/x/portprobe=222 -> says that port 222 status is "STEALTH" and protocol application is : rsh-spx, Berkeley rshd with SPX auth

for example http://www.t1shopper.com/tools/scan.php4 -> xxx.yyy.62.42 isn't responding on port 222 (rsh-spx)

I don't know where is the problem then , the port 222 is forwarded and it's working with putty/ssh but with utorrent is not.

I am a bit lazy to search around ,because this is pretty specific problem ( I think :) ). With common Vigor router is portforwarding pretty easy and it works well , I've done few pf myself ,but I can't find out what's the problem here. The admin said ,the port is forwarded and that's all.

How should I proceed ?

I using WinXP and Ubuntu HH. I have no firewall just PG2/Mobloquer.

Thanks for reply and sorry for my bad english.

Link to comment
Share on other sites

Of course , as far as I know only one appplication can handle one port at the same time. My putty is running now , but it uses port 22 , because im logged on our server (irssi). Port 222 is for external purpouse ,there is no connection from WAN now, so port 222 is not in use.

EDIT : LOL ! I have an idea ! That remote port 222 is forwaded to local port 22 , im going to write an email to admin.

EDIT 2 : So our admin changed the rules in iptables . remote port 222 si forwarded to local port 222 ,the utorrent port checker says that the port is CLOSED ( so the port is not in use ) when i type "sudo /usr/sbin/sshd -p 222" the port checker says the port is OPEN :-) ( because of packet response I think ),or if I run deluge on ubuntu on port 222 the port checker says OPEN , when i close it then CLOSED , and finally when I run uTorrent under 222 listening port the client says "Listen error , you should change ur l port" , weird

- under WinXP it works with Azureus (Vuze) but with uTorrent is not

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...