Jump to content

Ports Appear Closed Even After Opening


Matress_of_evil

Recommended Posts

Hi, I signed up to these forums because i've got a problem that is really annoying me. I've got the latest version of µTorrent, and there's a red exclamation mark at the bottom of my screen. If I scroll my mouse over it, it says "Not connectable. A Firewall/router is limiting your network traffic. You need to open up a port so others can contact you."

If I test whether my port is open (34134, that's the one it randomly selected so I kept it) then I am told that my port appears closed. But i've followed the instructions on the port forwarding website as best as I can, (Even though that site is full of mistakes) so there is no reason that I can see as to why it should show the icon.

I have a Netgear DG834G v3 and I have AVG Internet Security 8.0. The µTorrent program has been added to my list of exceptions in both Windows Firewall (Which AVG turns off anyway) and in AVG. Port 34134 is also open in AVG.

I tried changing the port to another random one (And I set the rules again) but that didn't work either.

Now the really strange thing is that I AM downloading files, even though it says I am not connectable. The file I am currently downloading has 13 (88) Seeds and 205 (2724) Peers. My average download speed is about 30kb/s, which is a lot slower than i'd like since i've got an 8mb connection, but it randomly jumps as high as 200kb/s, albeit rarely.

Does anyone know if there is something wrong with µTorrent? Is this a bug? Or is there something else I can do that will get my download speed up to a decent rate? Thanks for your help. :)

Link to comment
Share on other sites

I can't set up a static IP; if I change any of the settings in my connection my internet stops working completely. It MUST be set to obtain address automatically before my internet works. I've lost count of the number of times that i've followed the guides on that port forwarding site, but the simple fact of the matter is that the information on there is wrong.

My ISP (Plusnet) gives static IP's as standard anyway - and the static IP that they have given me (84.92.62.196) is completely different to the one that the portforwarding site tries to force me to enter. (192.168.0.x) When I put ipconfig/all in the box though, it says that my IP address is 192.168.0.2 and the DNS server is 192.168.0.1. (The portforwarding site says there should be two but only one is listed)

The DHCP range is 192.168.0.2-192.168.0.254.

The static IP that I *tried* to set was 192.168.0.3.

Link to comment
Share on other sites

Can you try turning on verbose messages for UPnP in the Logger tab, close uT... Tell Windows to get an IP automatically again (DHCP)... restart uT. See what messages show up. If you're going to do it all automatically you don't need to change the range. If however you WILL manually forward, change the range to something stopping BEFORE your static IP (if you choose .200, make DHCP stop @ 199).

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...