Jump to content

Peers not updating dynamically (Vista)


Recommended Posts

I'm having the weirdest problem with uTorrent now. I recently updated my computer to use Vista (I wanted to give it an honest shot now that most of the kinks are worked out). And yesterday I noticed a bug while uploading to a tracker.

When I upload the torrent, I don't immediately connect to peers, no matter how many there are jumping on the torrent. The only time my peer list is updating is when the tracker updates.

So I can upload a torrent, do nothing for 40 minutes, then I'll start seeding. Unless I do a manual update, which is fine if it was only a problem when uploading a torrent. But I have the same problem on every torrent. Peers are only updated with the tracker. At least I think I have the same problem with other torrents, it's a bit harder to check on torrents that don't originate from me.

I know it didn't use to work like this, that's for sure. I'm not even sure it correlates with the Vista upgrade, maybe it's more recent. I've only witnessed this behavior the past three days so it could be something else. But I think it's been there since I upgraded.

I am using the exact same settings that I did on XP, so I know they have worked in the past.

I'm using uTorrent 1.7.7. I would try an upgrade, but the tracker I'm uploading to doesn't allow beta versions, so that wouldn't really help.

Link to comment
Share on other sites

I thought I had answered that follow up question, appears I hadn't.

Anyway, what I was going to say was that the culprit could be AVG Free which I installed alongside Vista and didn't have before. Also that I couldn't verify until sunday.

Now I have checked, and it was AVG that caused the problem. With it disabled everything worked as normal.

So anyone know a setting in AVG to change to fix this?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...