Jump to content

Page Fault in NonPage Area - Only with uTorrent/Azureus


Recommended Posts


Recently, I began downloading the Warhammer Online Closed Beta client (~10 gigs). I run Vista Ultimate x64, with 4 1-gig sticks of RAM, 8800 GTX, and a WD Raptor 150GB. However, 30 minutes after I started downloading, I got a BSOD with the above error code. It continues to happen whenever I'm running uTorrent. I'm using the built in Realtek ethernet, with the newest drivers. This error also happens with Azureus, and I have never seen it before. I've tried running all kinds of diagnostics (chkdsk, memtest86+, Western Digital diagnostic, and Safe Mode still crashes) and they all turn up clean. Also, running Ubuntu is perfectly stable and I can download the torrent through there. I've also recently run other torrents that haven't crashed, but this one has caused all kinds of problems.

Any help would be greatly appreciated!

Link to comment
Share on other sites

All the crash reports talk about ntfs.sys (I've tried replacing the ntfs.sys with one from a friend's computer running 64-bit Vista ultimate, and it still crashes with the same error). I'll include the text from one of the crash reports.


Invalid system memory was referenced. This cannot be protected by try-except,

it must be protected by a Probe. Typically the address is just plain bad or it

is pointing at freed memory.


Arg1: fffffa610b3a9ff8, memory referenced.

Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.

Arg3: fffffa6001219130, If non-zero, the instruction address which referenced the bad memory


Arg4: 0000000000000005, (reserved)

Debugging Details:


Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80002c70080




fffffa60`01219130 4c8b4c0af8 mov r9,qword ptr [rdx+rcx-8]







TRAP_FRAME: fffffa60055b0ce0 -- (.trap 0xfffffa60055b0ce0)

NOTE: The trap frame does not contain all registers.

Some register values may be zeroed or incorrect.

rax=0000000000000040 rbx=0000000000000000 rcx=fffffa8104fea000

rdx=ffffffe0063c0000 rsi=fffff880090b3140 rdi=fffffa6001220374

rip=fffffa6001219130 rsp=fffffa60055b0e78 rbp=00000000ffffffff

r8=00000000ffffffff r9=0000000007ffffff r10=fffffa60055b14f0

r11=fffffa8004fea001 r12=0000000000000000 r13=0000000000000000

r14=0000000000000000 r15=0000000000000000

iopl=0 nv up ei ng nz na po nc


fffffa60`01219130 4c8b4c0af8 mov r9,qword ptr [rdx+rcx-8] ds:1970:fffffa61`0b3a9ff8=????????????????

Resetting default scope

LAST_CONTROL_TRANSFER: from fffff80002aaa4e2 to fffff80002a9c390


fffffa60`055b0be8 fffff800`02aaa4e2 : 00000000`00000050 fffffa61`0b3a9ff8 00000000`00000000 fffffa60`055b0ce0 : nt!KeBugCheckEx

fffffa60`055b0bf0 fffff800`02a9af19 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`ffffffff : nt!MmAccessFault+0x4f2

fffffa60`055b0ce0 fffffa60`01219130 : fffffa60`0123988e fffffa00`06000000 fffffa60`012d1f9a 00000000`00000000 : nt!KiPageFault+0x119

fffffa60`055b0e78 fffffa60`0123988e : fffffa00`06000000 fffffa60`012d1f9a 00000000`00000000 fffffa60`055b14f0 : Ntfs!memcpy+0x2c0

fffffa60`055b0e80 fffffa60`0123a735 : 00000000`00000000 fffffa60`055b1194 fffff880`090b3140 00000000`00000030 : Ntfs!NtfsCopyFromMdl+0x17b

fffffa60`055b0f60 fffffa60`0120d684 : fffff880`090b3140 fffffa60`055b1140 00000000`00000000 00000000`00010000 : Ntfs!NtfsPrepareSparseWriteBuffer+0x85

fffffa60`055b0fb0 fffffa60`01221bc7 : fffffa60`055b14f0 fffffa80`04642010 fffff880`090b3101 00000000`00000010 : Ntfs! ?? ::FNODOBFM::`string'+0x46f7

fffffa60`055b1070 fffffa60`0121f963 : 00000000`00000000 fffffa60`055b14f0 fffffa60`055b1190 00000000`0002d000 : Ntfs!NtfsPrepareBuffers+0x177

fffffa60`055b10f0 fffffa60`0121bf2e : fffffa60`055b14f0 fffffa80`04642010 00000000`00004000 00000000`00000000 : Ntfs!NtfsNonCachedIo+0x1c3

fffffa60`055b12c0 fffffa60`0121f118 : fffffa60`055b14f0 fffffa80`04642010 fffffa60`055b1601 fffffa60`055b1600 : Ntfs!NtfsCommonWrite+0x4ce

fffffa60`055b14c0 fffffa60`00764e17 : fffffa80`046423b0 fffffa80`04642010 fffffa80`03e9c040 fffffa80`09c23cb0 : Ntfs!NtfsFsdWrite+0x208

fffffa60`055b1730 fffffa60`007640dd : fffffa80`04d82ac0 fffffa80`0958e050 fffffa80`03e9c000 fffff800`02bc0b00 : fltmgr!FltpLegacyProcessingAfterPreCallbacksCompleted+0x227

fffffa60`055b17a0 fffff800`02abbbcd : fffffa80`03e9c040 fffffa80`03e9c040 00000000`0000000b fffffa80`0958e050 : fltmgr!FltpDispatch+0xcd

fffffa60`055b1800 fffff800`02aba90d : 00000000`00000008 fffff880`0a4c7180 fffffa60`055b1920 00000000`00000000 : nt!IoSynchronousPageWrite+0x14d

fffffa60`055b1830 fffff800`02aae069 : fffff880`0a4c7160 fffff880`0a4c7180 fffffa80`0994aea0 fffffa80`0994aea0 : nt!MiFlushSectionInternal+0x7ce

fffffa60`055b1a30 fffff800`02ab1989 : fffffa80`00000000 00000000`00000000 00000000`00000000 fffffa80`0896d720 : nt!MmFlushSection+0x2a9

fffffa60`055b1af0 fffff800`02ab5450 : fffffa80`09dbc360 00000000`00000000 fffffa60`00000001 fffffa60`055b1ca0 : nt!CcFlushCache+0x65a

fffffa60`055b1be0 fffff800`02ab5f9b : 00000000`00000100 00000000`00000000 00000000`00000000 fffff800`02c45800 : nt!CcWriteBehind+0x1c0

fffffa60`055b1c70 fffff800`02aa905a : fffffa80`039b74a0 fffff800`02c458a0 fffffa80`09ced520 fffffa80`00000001 : nt!CcWorkerThread+0x17b

fffffa60`055b1cf0 fffff800`02cbff73 : fffffa80`039b74a0 fffffffe`9a5f4400 fffffa80`0896d720 00000000`00000080 : nt!ExpWorkerThread+0x11a

fffffa60`055b1d50 fffff800`02ad6526 : fffff800`02bbb680 fffffa80`0896d720 fffffa80`0896d040 00000000`00000001 : nt!PspSystemThreadStartup+0x57

fffffa60`055b1d80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16




fffffa60`01219130 4c8b4c0af8 mov r9,qword ptr [rdx+rcx-8]


SYMBOL_NAME: Ntfs!memcpy+2c0



IMAGE_NAME: Ntfs.sys


FAILURE_BUCKET_ID: X64_0x50_Ntfs!memcpy+2c0

BUCKET_ID: X64_0x50_Ntfs!memcpy+2c0

Followup: MachineOwner

Link to comment
Share on other sites

ntfs.sys should never crash... if you're saving to the same NTFS drive using ubuntu (yes, you can), then there is something really, really wrong with your Windows install. Try removing some sticks of RAM or something, then try reinstalling, and if all else fails, contact your motherboard mfr's support.

Link to comment
Share on other sites

  • 2 months later...
  • 6 months later...

Blue screening with NTFS.sys should never happen. Create a new troubleshooting thread please, as this one is unrelated.

Or give more information. If it's happening with multiple filesharing software it's apparently something related to your NIC. Update drivers. Search on your chipset, in this forum.

Link to comment
Share on other sites

Thank you for your answer. I also get the bluescreen without the NTFS.sys reference. My board is an XFX 8200 with an AMD, AVG av and bitdefender running. I've been looking for a fix everywhere and a lot of people have the same problem but no solution and several misleading answers regarding RAM, HDD or mobo problems. Anyone knows how to test my NIC?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...