Jump to content

Utorrent 1.8 Doesn't recognize open ports (Help!)


Recommended Posts

I just updated to version 1.8. And I spent my whole day trying to make utorrent work. The previous version worked fine.

I have a DI-604 router and 2 computers. The other computer is still running utorrent 1.7.

The problem is that my torrents either have really small speeds (as low as 0.1KB/s and maximum of 25 KB/s) or don't work at all.

I don't have an upload or download limit and nex.max_halfopen is 8 (I tried with lower values and didn't work)

When I test the port with utorrent's speed test I get Error! Port XXXXX does not appear to be open. The port is forwarded. I tried it with DC++ for example and it works. I tried different numbers and the port didn't work in utorrent but worked in DC++. I turned off the firewall (Kerio),as well, in order to take down variables.

The only conclusion I can come up with is that Utorrent 1.8 doesn't recognize my open ports since 1.7 worked fine and as I said before utorrent 1.7 still works fine on my other computer.

Can anyone please help? I can't think of any other ways to solve the problem.:(

Edit: Also, everytime I turn on utorrent now. All the torrents that I was previously seeding say: Failure: Connection limit exceeded! You can only seed from two location at the same time. This gets fixed after an hour or so (I read in a forum post about the tracker's sanity something...) but it does so every time I turn it on. It didn't with 1.7. I don't want to wait one hour so that I can seed.

Link to comment
Share on other sites

Well, it's free, fairly powerful, and doesn't seem to have any compatibility issues.

Generally, you can't disable firewalls, as they stay hooked in anyway, requiring you to uninstall them to actually have it removed.

If you don't mind, can you try connecting your PC directly to the modem to see if it makes any difference?

Link to comment
Share on other sites

It works by connecting the PC directly to the modem (with Kerio on I tried a slackware torrent).

So what does this mean? Some problem with my router and new utorrent 1.8?

I checked the router's firewall and it's automatically on allow since the application ports forwarded.(As I said in my original post)

P.S. The seedong torrents still had the problem Failure: Connection limit exceeded! You can only seed from two location at the same time).

Link to comment
Share on other sites

Ok, I just tried a different port number and it worked. I don't know. I think it's my router, since I had some problems way back when I was using Azureus. Sometimes it works sometimes it doesn't. I'm sure now that the router was the problem. Thank you for your time and help!!!!

The port forwarding is done properly since there aren't many options at all for this model. It's so easy, therefore no advanced options. :(

I will probably buy a new router anyway (one that has wireless as well).

Is it possible for you to recommend me a good router that is worth the money, but also financially accesible ? One that hasnt had any problems with p2p and can support p2p very good, since with this one the internet is going so slow even when i have only one torrent!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...