Archived

This topic is now archived and is closed to further replies.

Firon

1.8.1 Release Candidate 1 (build 12549)

Recommended Posts

@alus,

I did more "Vista bug" investigation (using 1.8.1 Beta build 12323):

UPnP PortForward utility confirms that µTorrent correctly forwards the TCP and UDP port µTorrent is listening on whenever it is started (including when it crashes after a router reboot) and releases them when it exits normally.

If I use PortForward to set up the forwards after rebooting my router, then start µTorrent it will not crash.

-> If I delete "resume.dat" and "resume.dat.old" then reboot my router and start µTorrent it will not crash! <-

Similarly, it I stop all torrent activity and set "bt.scrape_stopped" false before exiting µTorrent, then reboot my router and start µTorrent it will not crash.

So for me the crash only happens on the first start of µTorrent after rebooting my router when there is torrent activity (even just tracker scraping) ready to be started immediately!

There seems to be something µTorrent should wait for that Vista has to do (or finish doing) after the initial UPnP port forwards before starting torrent activity.

Regards, Joe

Share this post


Link to post
Share on other sites

Hello,

I getting what problem from V1.7 version...

My computer crashes wan i trying to "open containing folder" of file who is downloading, but isn't downloaded jet.

I have MS Windows XP SP2

Intel Core 2 CPU T7200 @ 2.00GHz, 993MB RAM, Mobile Intel 945 Express Chipset Family.

My windows operating system is installed on MacBook, using BootCamp (creating another partition).

All on my windows works fine: Games, Programs, things who only work on WINXP SP2. All is fine. Except wt crash.

By crash i mean what all screen turns blue witch some white text, and windows restarts in like sec, whiteout any things like "Windows is shutting down".

Any ideas what is it and is there way to fix it?

EDIT:

My computer doesn't crash wan i "open containing folder" of already downloaded torrent (by clicking on torrent name, not on files inside torrent).

Share this post


Link to post
Share on other sites

Firon,

I have latest version of utorrent (12323), and i getting what problem in 12323 to. I mean what i was getting what problem from time i started using utorrent (v1.7).

And yes, i got what crash after i tryed to open folder using Utorrent!

I got what problem witch UTorrent not one time...

Here is mini dump

http://www.filefactory.com/file/52a3d6/n/Mini092608-01_dmp

Share this post


Link to post
Share on other sites

Make a new thread, although that minidump tells me that your system is really, really screwed and you should reinstall windows.

Share this post


Link to post
Share on other sites
Firon,

I have latest version of utorrent (12323), and i getting what problem in 12323 to. I mean what i was getting what problem from time i started using utorrent (v1.7).

And yes, i got what crash after i tryed to open folder using Utorrent!

I got what problem witch UTorrent not one time...

Here is mini dump

http://www.filefactory.com/file/52a3d6/n/Mini092608-01_dmp

f7981a40 8054a583 nt!KeBugCheckEx+0x1b

f7981a90 f722dac9 nt!ExFreePoolWithTag+0x2a3

f7981aa0 f7235b46 Fastfat!FatFreeFcb+0x10

f7981aac f723201a Fastfat!FatDeleteCcb_Real+0x15

f7981b3c f723185c Fastfat!FatCommonClose+0x1b2

f7981ba0 804eeeb1 Fastfat!FatFsdClose+0xbd

f7981bb0 f7250459 nt!IopfCallDriver+0x31

WARNING: Stack unwind information not available. Following frames may be wrong.

f7981bb8 804eeeb1 sr+0x459

f7981c0c 804eeeb1 nt!IopfCallDriver+0x31

f7981c1c 805827bc nt!IopfCallDriver+0x31

f7981c54 805b9e2d nt!IopDeleteFile+0x132

f7981c70 805257b8 nt!ObpRemoveObjectRoutine+0xdf

f7981c88 804e1b6e nt!ObfDereferenceObject+0x4c

f7981c8c 804e1ab6 nt!CcPerformReadAhead+0x330

f7981d34 804e7062 nt!CcPerformReadAhead+0x278

f7981d7c 80537757 nt!CcWorkerThread+0x150

f7981dac 805ce794 nt!ExpWorkerThread+0xef

f7981ddc 805450ce nt!PspSystemThreadStartup+0x34

00000000 00000000 nt!KiThreadStartup+0x16

What is "sr"? sr.dll? Do you have that on your system?

Anyway, not a uT issue.

Share this post


Link to post
Share on other sites

Hello,

sr.dll is part of Google Chrome:

C:\Documents and Settings\*******\Local Settings\Application Data\Google\Chrome\Application\0.2.149.30\Locales

And do you want to tell me what UTorrent crashed because of Google Chrome?

Share this post


Link to post
Share on other sites
Hello,

sr.dll is part of Google Chrome:

C:\Documents and Settings\*******\Local Settings\Application Data\Google\Chrome\Application\0.2.149.30\Locales

And do you want to tell me what UTorrent crashed because of Google Chrome?

That minidump was not a uTorrent crash, it was a Windows crash. Yes, I believe the "sr" module, whatever that is, was involved in the Windows crash.

Share this post


Link to post
Share on other sites
I have version of utorrent (12183), and i getting what problem

Application may is crash after connect vpn connection. uTorrent must launch is some time with out internet connection and when i start VPN, uTorrent is shutdown and restarting.

generated dump is here http://www.mediafire.com/?sharekey=3e4f0cccaef79061d2db6fb9a8902bda

Try disabling "UPnP port mapping" and see if that helps. Let us know.

Share this post


Link to post
Share on other sites

Send me an PM or mail through the forums, jsillup - I followed your last testing procedure of rebooting the router but I'd be glad if there was an even easier method to reproduce the bug. ^^

Share this post


Link to post
Share on other sites

@Lim-Dul,

You're too late, Uncle Alus found a work around already. But if you still want to force the crash with Build 12323, try disabling your NIC while µTorrent is running with UPnP port mapping enabled.

Share this post


Link to post
Share on other sites

Thanks - I had a lot of fun crashing uTorrent. ;-)

I'm glad that Alus found a solution to this problem - one question, Alus - is it a workaround or a true fix? Do you know PRECISELY what causes/caused the crashes?

Share this post


Link to post
Share on other sites

Workaround. The built-in Windows UPnP causes the crash, so it'll be disabled on Vista. You'll only have utorrent's implementation of it. In a future version, a real fix will be attempted.

Share this post


Link to post
Share on other sites

bt.allow_same_ip = false

Same client can connect twice if IP6 is installed. One connection will be via IP4 and second connection will be via IP6.

Share this post


Link to post
Share on other sites
bt.allow_same_ip = false

Same client can connect twice if IP6 is installed. One connection will be via IP4 and second connection will be via IP6.

Well, those are different IPs, which is why this occurs. I'll add protection against it in the future.

Share this post


Link to post
Share on other sites

Not sure whether this is actually a regression, but the current 1.8.1 beta (b12323) displays "<ERROR>" as IP address for IPv6 peers when running in Wine, even with DNS resolution enabled. Rest works fine. Wine 1.0.0 on Ubuntu Intrepid. Bug is not there on Vista.

Share this post


Link to post
Share on other sites

It sounds like WINE is correctly parsing IPv6 addresses with WSAStringToAddressA (which is how I detect that the IPv6 stack is enabled), but WINE is failing to format with WSAAddressToStringA. File a bug with them?

Share this post


Link to post
Share on other sites
Release 1.8 (11813) mass crash....

Dumps(37) http://upload.com.ua/direct/900463417/dmp.rar

These are mostly the "Vista bug". Try disabling UPnP, let us know if that helps.

Also, you have "Lingvo Keyboard Hook" - could you try disabling or uninstalling that?

Btw, this thread is for 1.8.1, so you should at least run that if you are going to report bugs here.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.