Jump to content

1.8.1 Release Candidate 1 (build 12549)


Firon

Recommended Posts

  • Replies 547
  • Created
  • Last Reply

Top Posters In This Topic

Well, now I'm beginning to suspect these errors might be related to a problem µTorrent was having with duplicate keys and broken connection settings in the settings.dat dictionary... They all seem related in that they're all bencoded data that is fumbling. Ryan seems to have fixed the settings.dat issues, so if my hunch is correct, then hopefully, most of the problems will go away on the next beta.

Link to comment
Share on other sites

add RSS feed button, edit feed (from context menu) and create new torrent button - all pop up multiple dialogs when clicked more then once. Add torrent from URL - pops only one when clicked more then once. Is it a bug ? In sake of consistency - shouldn't all behave "one at a time" ?

Link to comment
Share on other sites

Well, the only reason the add torrent from URL dialog pops up once is because it's a modal dialog, so you couldn't click the button again even if you wanted to. Whether thr Add RSS Feed dialog should be a "singleton" kind of thing, I dont know. I mean, I can always pose the question: why are multiple Add New Torrent dialogs allowed, if consistency supposedly dictates that there be only one of each dialog, right?

Link to comment
Share on other sites

After hearing about the possible problems of build 11903, I went back to 11882.

Exactly 30 minutes later, I got this in the Logger:

Settings integrity check failed (duplicate keys: 6 count: 6), repaired: C:\Documents and Settings\420\Application Data\uTorrent\settings.dat

Hopefully, nothing else was damaged...

P.S. If you have a secret test build somewhere, I would love to test it for you!

Link to comment
Share on other sites

I mean, I can always pose the question: why are multiple Add New Torrent dialogs allowed, if consistency supposedly dictates that there be only one of each dialog, right?

right, they shouldn't be allowed either... 'one at a time' for all is correct...

Link to comment
Share on other sites

I noticed that I got banned on a tracker. Unfortunately, the DHT settings were not allowed on that tracker and I got really poor results. So when I loaded the trackers, It said that the connection was refused by that active peer. And on top of that, the tracker was loading every 35 seconds.

Now you're (as a collective community) saying it was the cause of duplicated keys. If you revert back to 1.8 Stable or any previous build, would the bugs caused by duplicated keys be fixed?

Link to comment
Share on other sites

The collective community isn't saying that, actually -- I drew that correlation on my own by picking out the (seemingly) one common factor in all the problems.

I'm really not sure if the duplicate keys thing didn't exist in previous versions. All I know is that these problems did not manifest themselves until build 11903. Take it for what it's worth (not too terribly much, I suppose :P).

Link to comment
Share on other sites

ah, Ultima , not 'add torrent', 'add new torrent'... I almost never use it.. so, that was my opinion , but whatever... have fun! add 3 new torrents at a time... about the RSS dialogs - I guess it will not need to be fixed anyway after the devs will read and change things per my RSS post here http://forum.utorrent.com/viewtopic.php?pid=352646#p352646 (I hope...) :)

Link to comment
Share on other sites

The collective community isn't saying that, actually -- I drew that correlation on my own by picking out the (seemingly) one common factor in all the problems.

I'm really not sure if the duplicate keys thing didn't exist in previous versions. All I know is that these problems did not manifest themselves until build 11903. Take it for what it's worth (not too terribly much, I suppose tongue).

ah, Ultima , not 'add torrent', 'add new torrent'... I almost never use it.. so, that was my opinion , but whatever... have fun! add 3 new torrents at a time... about the RSS dialogs - I guess it will not need to be fixed anyway after the devs will read and change things per my RSS post here http://forum.utorrent.com/viewtopic.php … 46#p352646 (I hope...) smile

Thanks for the information... Now to see if there was any problem with the previous builds....

Link to comment
Share on other sites

The problem is not with Win98. Indeed, It works perfect on Win98.

The problem is with Win95... And yes, it doesn't work there (at least for me),

and I have not any firewall installed. However, as I said before, the version 1.7.7 works like a charm, in the same PC, with the same setup.

My setup is Win95 4.00.950B, with winsock 2 installed and IE5.5 installed.

I have been using uTorrent without any problems and with good performance with this setup for around 2 years. Indeed, it's my favorite torrent client, and I don't use another program, it's because this bug is worrying for me.

Any help for solving this problem is very appreciated.

Best regards,

EDIT: Also, the new beta (11962) has the problem.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.

×
×
  • Create New...