Jump to content

uTorrent speeds maxing at 5kb/s


Recommended Posts

I have:

Windows Vista

Comodo Firewall Pro v3


Bigpond Broadband ADSL Wireless

D-Link model DI-624

Originally, the network status was continuously the yellow triangle with the exclamation mark.

I have followed instructions on how to get past my firewall and redone them just incase. I've been to portforward.com and followed those instructions twice as well.

After doing this, the network status has degenerated to the red circle with an exclamation mark. I'm not sure whether i have followed an instruction incorrectly even though i've tried twice at different times for both, or if there is something else going on that i don't know about.

I would GREATLY appreciate any help given, and am prepared to give a HijackThis log etc if required.

I don't particularly mind having the slower download speed (though it would be great faster), but i am getting the impression that having it like this inhibits seeding??

Link to comment
Share on other sites

First of all if your router has a NAT and SPI security built into it, which is known as a hardware firewall, you don't need a software firewall. One firewall, period.

Disable your firewall completely and test again. If it doesn't work try below.

Choose a port from the 49152–65534 range. Don't use 6881.

Link to comment
Share on other sites

NAT and SPI???

Well here's the list of specs: http://reviews.cnet.com/routers/d-link-di-624/4507-3319_7-20817312.html?tag=coco

Does this mean i don't need Comodo Firewall?? Is there not a way to have both? or is the router enough? I do a lot of downloading and have come to like prevention rather than trying to fix/remove a problem afterwards and so prefer to have a few things running instead of relying on one, but if it doesn't matter...

Link to comment
Share on other sites

So just the router then, not even windows firewall?

OK so i've disabled it but now the network status is just back to being orange instead of red.

I also still egt this when i test if the port is forwarded properly:

Welcome to the µTorrent Port Checker.

A test will be performed on your computer to check if the specified port is opened.

Checking port 38135 on

Error! Port 38135 does not appear to be open.

Please see www.portforward.com for more information about how to map a port.

Please make absolutely sure that PeerGuardian2 or Protowall is allowing utorrent.com ( in either of those programs. Those of you using ipfilter.dat should make sure the list does not include the website's IP. After making sure of this, re-run this test by refreshing the page (F5).

Link to comment
Share on other sites

OK, well the only firewalls i know that i have are Windows and Comodo Firewall Pro v3 and i have turned off Windows and Comodo (after configuring Comodo didn't work) all while i have followed instructions at portforward.com and it still is limited...I have no idea what else to do??

Link to comment
Share on other sites

No, i'll give that a try.

EDIT: OK, so i've uninstalled Comodo and turned off Windows Firewall and have checked that i still have the port forwarded, and it's all good, but uTorrent is still maxing at 5 or 6kb/s and it still has the "no incoming connections" yellow triangle sign thingy.

Link to comment
Share on other sites

Might as well reinstall Comodo then. :(

My only guess now is either your modem or router (or both) isn't forwarded correctly.

Possibly you did not put in your computer's current LAN address to forward the router to?

Or the modem isn't forwarded to the router's LAN address (as the modem sees it, not the LAN the computer is on.)

Or your computer is in your router's DHCP (dynamic ip) range.

If your modem has a DMZ feature, try it...but you'll still need to figure out what ip the modem sees your router as. :(

Link to comment
Share on other sites

  • 2 months later...

Hi lotrhpfan,

I run the same setup as you pretty much, without the comodo...

The IP from the modem to the d-link router is

From the router to your computer - what ever your static IP has been set to - something like - 192.168.0.xxx

Depending on where you live in Australia, your DNSs can be found;


copy and paste the address above (i don't do html)

Hope this helps if you haven't already sorted it out.


Link to comment
Share on other sites

In applications and gaming section of your router enter the port number (typically 24006) in both protocols TCP and UDP for internal and external ports. (Therefore you should be entering this number 4 times.) Run cmd, and type ipconfig /all to find your computers i.p. address. (there is a space between the word ipconfig and the /). Enter this address in the ip address section and tick the enabled box. Everything should now work ok Also double check how fast the modem is running. If your browsing is slow run a speed check. Telecom had issues with their network cards at the exchange and it took me 8 months for them to change my connection. I now have constant 4 meg speeds download and 850 k uploads without having to reboot daily :)

Link to comment
Share on other sites

It's all been sorted out thank you! From what i remember, i hadn't forwarded the port properly, only through the router, and not then forwarding the router to the modem (or the other way around?? lol), but it's all fixed! Thank you everyone for helping XD It's much appreciated.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...