Archived

This topic is now archived and is closed to further replies.

Directrix

WebUI v0.361 ready for testing

Recommended Posts

IE8: Made of as much fail as any other IE

It's odd though... Directrix (AFAIK) has IE8 installed, so he should be able to test it. Last I heard, it was working :\

Share this post


Link to post
Share on other sites

I'm using uTorrent 1.8 build 11813 on Vector Linux 5.9 Std. Gold with Wine 0.9.54. I never downloaded a webui.zip, because the WebUI was working right from the start. When i go to http://myip:myport/gui/ i get into the WebUI 0.361, authenticating with the user|pass combo i specified in the options. Everything seems to work, i can modify the preferences, delete torrents, etc, but i cannot add torrents. When i enter a local torrent file and click OK (the one right under the path field), the path field is cleared, but the add torrent form stays. When i enter a url and click OK (the one at the bottom) the add torrent form disappears. but either way no torrent is added. any ideas what the problem could be?

pontomedon

P.S.: i hope you can tell me how get the webUI to work, because with it uTorrent would be the perfect tool for my very old linux server, because the only useable webui of another torrent client is imho the one of Azureus and yours is WAY better. (And Azureus also is a big resource-eater, so it's not really useable on such an old machine.

Share this post


Link to post
Share on other sites

the newest one in the repository was 1.1.2, but adding torrents works now! i noticed a few other things:

Percent values are displayed in a strange way sometimes.

For example in the "General" tab of the torrent detail pane i see something like that:

"Seeds: 12 of 25 connected (¿? in swarm)"

or

"Peers: 28 of 55 connected (¿? in swarm)"

or when adding a torrent with existing data i get "Checked ??%" in the Status column. (Yes this time with 2 upright question marks)

Is this still a matter of Wine? or do i have to enable a special charset to display the numbers correctly? (Problem occurs in Firefox 3.0.3 as well as in Internet Explorer 7.0.5713.13

mfg pontomedon

EDIT:

one more thing: sorting torrents by the ETA collumn treats the infinite sign in a wrong way:

it gives me: <infinite> - 15m - 7h - 14h when sorting ascending

and the other way round when sorting descending.

Share this post


Link to post
Share on other sites

I would like to ask how can i remove the settings button from the webui whiich line do i edit in the main.js can someone guide me

Share this post


Link to post
Share on other sites
Friends of TorrentSpy,

We have decided on our own, not due to any court order or agreement,

to bring the Torrentspy.com search engine to an end and thus

we permanently closed down worldwide on March 24, 2008.

Please remove TorrentSpy from search engines of WebUI.

You can add another else instead it. (2torrents, btjunkie)

If can I, I ask you to keep original torrent status icon in torrent list of WebUI.

And in the end - thank you for your work on WebUI.

Share this post


Link to post
Share on other sites

WebUI's working great for me.

Also, I didn't like the face status icons either. I like it to be consistent between the webUI and regular GUI. Anyways, I fixed the problem myself and replaced the new icons with the new ones. For anyone else that wants it, all you have to do is just replace the old tstatus.png file in the webui.zip, with this one (you can download it at either link):

http://rapidshare.com/files/151970375/tstatus.png.html

http://www.megaupload.com/?d=942Y1VK0

I tested it and I didn't notice any problems at all. When it first loaded it had the old icons for a couple seconds and then the new ones loaded, but I think that's just a cache thing. Only did it the first time I loaded it.

Share this post


Link to post
Share on other sites

So i'm having a problem with the webUI when i change the tstatus.png image. Whenever i go to access the site after changing the image i get a screen saying: The webUI is not installed, click here to install it. If i refresh the page SOMETIMES it works, other times it doesn't.

So here is what i'm doing, someone tell me if i'm doing it wrong please :)

1. Extract WebUI.zip

2. Replace tstatus.png With a more awesome version (i.e. the ones offered above)

3. Re-Zip the files using WinRAR or the built in Windows zip archiver (tried both)

4. Place into the correct folder.

The folder is there, and when i click the button to auto install the webUI it overwrite my old version... So what am i doing wrong?

Share this post


Link to post
Share on other sites

Could anyone give status update on adding torrent feature not working? It's pretty essential for me.

If you need any additional info about my setup, logs or anything I'd be glad to help.

Share this post


Link to post
Share on other sites

It's like using Office 2007 on Win98 or 2000... :D

I dunno what is ALT but it's stupid to dont allow 1.7 then 1.8 uT series...

In addition, I'm not sure if this old version supports completely the WebUI feature.

Share this post


Link to post
Share on other sites

@DarkBug: Tell the administrators to explain to you why they won't allow newer versions. If anything, I would be suspicious of them, as versions older than 1.8 have many known security exploits -- several of which can be taken advantage of by anyone serving .torrent files, and several of which are WebUI related. No, I'm not accusing them of actually exploiting these, but there quite simply isn't any *real* reason for trackers to ban the current versions.

Share this post


Link to post
Share on other sites

I'm sure they think uT is a spyware or stg like that for Bittorrent Inc, so they have blocked uT version to 1.6.1. That was offen a discussion subject on tracker boards when uT has been purchased... :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.