Jump to content

Unable to Forward Port


Recommended Posts

Hi there,

I'm getting limited download speeds, less then 10kb at all times. At the bottom of my utorrent app it shows yellow exclamation mark with the message :"No incoming connections, unless this icon turns green it should indicate a problem with our network connection.

When I use the utorrent port checker I get: "Port 50866 does not appear to be open."

I'm using a DI-624 DLink router. I've set my computer to use a static IP. I've also added the Utor1 service to my virtual server list. I've double checked with the steps from portforward.com.

I'm not using any firewall besides the default winXP SP2 firewall. I've added checked to make sure utorrent is on the list of proccesses granted access. I've also added the same port as I added with my firewall. Disabling the winXP firewall altogether creates NO changes.

Issue might be my router?

I'm using utorrent v1.8 stable

Thanks in advance for any help.

Link to comment
Share on other sites

I've tried enabling/disabling numerous settings in utorrent.

- uPnp



- Encryption

No change from any of them.

This leads me to believe it might be my modem. When you say configure your modem, what are you referring to?


Nevermind, tested out another open wireless connection. Added the port to that routers list of ports to forward. Worked good. So I figured it must be my router, did a rom update, issue is now resolved. Now to set up ideal download config... argh haha

Thanks for the help anyways.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...