Jump to content

Desperate to solve speed issues!


Recommended Posts

I am desperately in need of help with my utorrent as its download speed has been severely handicapped. I do not believe it is due to the v1.8 patch since I have never touched any settings at all. Hence it should be some other factors (internal or external) which is causing this problem. One very important clue I noticed was my connected seed or peer are always below 10 which has never happened before even after connected for hours. For example: 8 of 3184 connected (9684 in swarm). After looking up at various faqs and similar forum threads, I still could not resolve the issue pr increase my connected seeds and peers. Below are my system specs, network connection and utorrent settings. Hope it helps and many thanks.

OS: Window Vista SP 1 (64 bit)

Chipset: Intel G33/ G31 / P35 Express Chipset Processor

Processor: Intel Core 2 Quad Q6600 2.4 GHz


TCPIP connection patched? : No (The patch seems risky - any advice? http://www.mydigitallife.info/2008/02/17/download-vista-tcpipsys-and-uac-auto-patcher-to-increase-tcp-connection-limit/)

Firewall: Default Microsoft Firewall only and it is enabled (No difference in download speed even if I turn off the Firewall)

Modem: Motorola SurfBoard SB5101 (Login: Automatic Configuration - DHCP and IP Address is - not neutered as it is not 192.168.100.xxx)

Router: WRT54GSV4 (Patched? - No, links appears to be dead from http://www.thibor.co.uk/ and http://www.dd-wrt.org/)

ISP: Starhub Cable (Bad ISP - http://www.azureuswiki.com/index.php/Bad_ISPs#Singapore )

Antivirus: Kaspersky (Any settings that may interfere with speed?)

Application: utorrent v1.8

Download speed: 23000KB

Upload speed: 360KB

Static IP:

utorrent settings:

Selected Speed Guide connection: xx/2Mbit (upload limit 186)

Pre-allocate all files - Yes

Append .!ut to incomplete files - No

Network status: Green (Port is forwarded properly)

Port: 48514

UPnP and NAT-PMP port mapping - No

Randomized port each start - No

Add Windows Firewall exception - Yes

Enable DHT Network - Yes

Enable DHT for new torrent - Yes

Enable Local Peer Discovery - Yes

Ask tracker for scrape information - Yes

Enable Peer Exchange - Yes

Outgoing Protocol Encryption; Enabled (Forced seems to have a worse effect)

Allow incoming legacy connections - Yes

Resolve IP - No (Was advised to turn it off but it still did not change anything)

utorrent advanced options (Any other important advanced options I need to provide?)

net.max_halfopen = 50 (changed from default 8 to 50)

net.bind_ip = "blank"

net.outgoing_ip = "blank"

peer.lazy_bitfield = true

Testing on OpenOffice torrent - Average download speed in 30mins- 15KB

Thanks for your assistance and time once again.

Link to comment
Share on other sites

"TCPIP connection patched? : No


net.max_halfopen = 50 (changed from default 8 to 50)"

In order for uTorrent to use more than 8 half open connections at once you MUST patch windows using 3rd party hacks. Otherwise, you're just generating a massive amount of failed half open connection attempts and corresponding 4226 errors. These 3rd party hacks get reset often and without notice by Microsoft Windows updates.

"ISP: Starhub Cable (Bad ISP - http://www.azureuswiki.com/index.php/Bad_ISPs#Singapore )

Download speed: 23000KB

Upload speed: 360KB


Selected Speed Guide connection: xx/2Mbit (upload limit 186)"

23000 KiloBYTES/second download speed and 360 KiloBYTES/second upload speed...you do not have. I don't know of any "regular" Cable ISP that offers download speeds greater than ~7000 KiloBYTES/second. So those numbers are almost certainly kilobits/second. Even 23000 kilobits/second down is very impressive...10 times faster than many Cable/ADSL connections!

That means your upload max isn't 2 megabits/second like you chose in Speed Guide (CTRL+G)...it's 384 kilobits/second at most.

You've been overloading your connection trying to upload too fast and may have gotten unwanted attention from your ISP as a result!

2nd link in my signature can come up with more conservative settings than Speed Guide and also includes more choices...you may even need to use 320 kilobits/second upload settings or lower.

Your ISP may be limiting how many connections you can have at once...and they may count your incomplete outgoing half open connections and DHT UDP packets as well against that limit.

Of the few connections you DO get, you'll probably see many if not most of them are in the Asian-Pacific region...Australia, Taiwan, Japan, South Korea, Malaysia, Thailand, China, and definitely others in Singapore. (this is an abbreviated list...but are probably the big ones)

As far as encryption is concerned, this link is among the best there is on the subject:


...You may need the equivalent of Level 5, which is very hard to do with uTorrent!

Link to comment
Share on other sites

Thanks Switeck. At least this explains greatly on what the real underlying issues are.

Apart from these that was mentioned, is the Linksys Router firmware patch or other settings an issue too?

I will patch the TCPIP file soon after the other user of this PC agrees to use the 3rd party hacks. This is quite embarrassing but now I realized that kb can also refer to kilobits which is indeed vastly different from kilobyte. As for the speed guide settings, I will definitely change it 384 kilobits/second (upload < 35KB). Finally, if the level 5 encryption is such a pain, I would be very glad to change to another ISP.

Link to comment
Share on other sites

"Apart from these that was mentioned, is the Linksys Router firmware patch or other settings an issue too?"

Probably not. Whether you do that or not will likely not change your problems at all.

Your ISP is so hostile that I've been tempted to block both it and SingTel nearby from EVER connecting to my computer. And I don't even feel that way about Rogers Cable in Canada, which I used to love making fun of. (3rd link in my signature even :P )

At least give as much of level 5 encryption settings as you can a try. It might work for all I know...I've just learned to be disappointed in advance to save myself disappointment later. :(

Link to comment
Share on other sites

I have seen many complaints of speed issues as well as bandwidth hogging and resource-hogging as well pertaining to many Bittorrent clients, including uTorrent.

I have tried many clients in the past, but settled on Bitcomet mainly because it didn't use Java, which I won't allow in the house. What I always found, no matter how I configured it, was that it hogged all the available bandwidth so that I might as well forget about web browsing while torrents are running. This is not a local issue, as any machine sharing the network would have the same trouble.

This was the main thing that made me start using eMule, as it doesn't have any of these issues; although downloads are slow and erratic, it is reliable, you just have to be patient. Before that, though, I tried several other Bittorrent clients, but not uTorrent at the time, and always got the same result. This was quite independent of any configuration or preference settings. Even one torrent running at 1k/sec would make the browser unusable.

Upon learning that Opera now has a built in bittorrent client, I gave it a try and got the same thing. There are issues with my ISP as well, who insist that they do not throttle torrents, rather they use traffic shaping where p2p traffic speeds up during off peak hours. That was not my experience; I couldn't get any better than 0.3 or 0.4 k/sec under any circumstances.

I had a large (4 Gig) torrent that had been trickling in for months and still hadn't reached 50% yet. I would let it run all night and in the morning it would have grown by only 10 or 20 MB. Then I installed uTorrrent 1.61 yesterday (I found it in my download folder) and gave it the half-completed file. Only a day later, it is at 97% and has been going at 22k/sec or more the whole time. I didn't touch the settings except to change the port being forwarded from the router.

I don't know how to explain this. I believe the client has protocol obfuscation built in, which is probably fooling the ISP, but I have eMule running as well and have also been browsing the whole time with no trouble other than a small lag. Also, task manager reports uTorrent is using 12 megs of memory and 3% CPU. This is nothing compared with my experience with other clients. Torrents also used to kill eMule stone dead. There is absolutely no way I previously could have run both at once. Fiddling with number of connections and down/up speeds never had any effect, either.

I have been avoiding bittorrrent for years because I couldn't find any client that didn't kill the system - and now this! Can someone please explain?

Link to comment
Share on other sites

Thanks for the clarifications. I have patched the TCPIP and it seems to have improve slightly.

However, this matter is somewhat resolved since there is nothing much I can do about ISP being such a pain. ILikewise, I would have blocked connections from all ISP in Singapore too.

Link to comment
Share on other sites


Make a new post in Speed Problems...after trying uTorrent v1.8.1 beta.

2nd link in my signature for the highest settings I recommend for your connection.

...And you may want to disable uTorrent's extra features: DHT, LPD, UPnP, and Resolve IPs (right click in PEERS window of an active torrent).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...