Jump to content

Utorrent Causing Connection To Drop In and Out


Recommended Posts

While downloading, my wireless connection will either drop to an extremely low speed or or just die all together. I've tried lowering my global connections and lowering the amount of connectible peers under settings but it still happens. Even power cycling, and restarting doesn't really even bring the connection back right away. It just seems to drop at random intervals. I cant really tell what is causing it.

The problem started happening in v1.6 and still is happening now in 1.8. I'm using a Linksys WRT52G2, but the problem was also happening with the basic WRT54G.

My current settings:

UnNp Mapping: Unchecked

DHT Network: Unchecked

Maximum Upload Rate: 25

Maximum Download Rate: 0

Global Maximum Number of Connections: 250

Maximum Number of Connected Peers Per Torrent: 200

Number of Upload Slots: 10

Any help would be appreciated.

Link to comment
Share on other sites

I've tried pretty much everything suggested in that guide.

I also played around with some of my settings - Increasing/decreasing # of Global Connections, Connected Peers, Upload Slots and the drop in connection still happens after a few minutes of downloading.

I'm not sure whether the settings in Utorrent are incorrect or if the settings for my router are wrong. But something is causing my router to completely drop my connection to the point where even power cycling right away wont bring the connection back.

Any suggestions?

Link to comment
Share on other sites

Yes, I disabled everthing listed above. I've also tried different combinations of those settings disabled and enabled. The only time that I saw a difference was in UnNP. I enabled it on my router and also in utorrent and also raised the # of connections back higher. At first the speeds were very very high and was working great but the problem started happening all over again. So I'm not sure if that actually had an impact, or if it was just that individual torrent I was downloading. I think it was pretty much because of the increased amount of connections, because I had lowered them a lot to try and solve the overall problem.

Right now I have UnNp disabled in both Utorrent and my Router.

Right now I my settings are:

Maximum Upload Rate: 25

Maximum Download Rate: 0

Global Maximum Number of Connections: 500

Maximum Number of Connected Peers Per Torrent: 100

Number of Upload Slots: 8

The problem is still happening, but just not as frequent as before. I'm not sure why though.

Link to comment
Share on other sites

If there doesn't seem to be a rhyme or reason to the time/interval between dropouts, have you tried limiting the connections drastically like 20 connections per torrent 50 total... with 4 upload slots?

Since it's still happening it sounds like the modem/router needs to be reset... so I'd double check that your modem isn't configurable as far as timeout values similarly to the WRT

Link to comment
Share on other sites

"If there doesn't seem to be a rhyme or reason to the time/interval between dropouts, have you tried limiting the connections drastically like 20 connections per torrent 50 total... with 4 upload slots?"

I haven't really been able to determine what the exact interval between dropouts are because I've been adjusting the settings to try and stop the problem. Any suggestions of a good way of trying to narrow down what exactly is causing the problem? Like a starting point I can set my settings to and to work off of?

"=Get TCP view (www.sysinternals.com reroutes to microsoft where it's hosted now)...

Maybe there's something other than uTorrent running?

...or a firewall is really mucking with uTorrent?"

My Windows XP firewall is set to off. I also have port forwarded utorrent on my router.

I've never used TCP Review before, is there something I should specifically look for while its running?

Link to comment
Share on other sites

Yes, anything other than uTorrent.exe running...uTorrent's connections going through (man-in-the-middle loggers or firewalls!)...and strange connections on outgoing ports beyond 1000-5000.

Helps if you disable Resolve IPs in TCP view...and possibly in uTorrent as well...so you can spot ip addresses easier.

Link to comment
Share on other sites

The drops are happening after I close out Utorrent now, after downloading. The connection will drop completely. I was watching the status of my connection with my router at the time of the drop and there were lots of Packets being sent but not a single one being received.

Link to comment
Share on other sites

Already had those disabled. Thankfully the connection isnt dropping after I close utorrent anymore, just during downloading.

EDIT: Ok I think I might have narrowed down what the problem might be. I had TcpView open while I was downloading in Utorrent. Everything was fine, until the connection started to slow down a lot and then finally stopped all together. I switched over to TcpView and there were at least 10-15 processes running that werent there before. They were all Csrss.exe. So just to see what would happen I clicked End Process on one of them and they all closed at once. As soon as I did that my connection completely came back.

Now I have no idea what the process is used for, or what caused it to open up. Anyone know how this file/process relates to utorrent and how it could be causing the drop in connection?

Link to comment
Share on other sites

Well apparently that wasn't the cause, because it happened again today while downloading, and I had already removed the csrss.exe file.

Here's my log from HiJackThis:

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157

R1 - HKCU\Software\Microsoft\Internet Connection Wizard,ShellNext = http://windowsupdate.microsoft.com/

R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local

O2 - BHO: AcroIEHlprObj Class - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Adobe\Acrobat 6.0\Reader\ActiveX\AcroIEHelper.dll

O2 - BHO: DriveLetterAccess - {5CA3D70E-1895-11CF-8E15-001234567890} - C:\WINDOWS\system32\dla\tfswshx.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll

O4 - HKLM\..\Run: [TrackPointSrv] tp4serv.exe

O4 - HKLM\..\Run: [igfxTray] C:\WINDOWS\system32\igfxtray.exe

O4 - HKLM\..\Run: [HotKeysCmds] C:\WINDOWS\system32\hkcmd.exe

O4 - HKLM\..\Run: [TPKMAPHELPER] C:\Program Files\ThinkPad\Utilities\TpKmapAp.exe -helper

O4 - HKLM\..\Run: [TpShocks] TpShocks.exe


O4 - HKLM\..\Run: [ControlCenter] "C:\Program Files\IBM fingerprint software\ctlcntr.exe" /startup

O4 - HKLM\..\Run: [TP4EX] tp4ex.exe

O4 - HKLM\..\Run: [EZEJMNAP] C:\PROGRA~1\ThinkPad\UTILIT~1\EzEjMnAp.Exe

O4 - HKLM\..\Run: [uC_Start] C:\Program Files\IBM\Updater\\ucstartup.exe

O4 - HKLM\..\Run: [updateManager] "C:\Program Files\Common Files\Sonic\Update Manager\sgtray.exe" /r

O4 - HKLM\..\Run: [dla] C:\WINDOWS\system32\dla\tfswctrl.exe

O4 - HKLM\..\Run: [iBMPRC] C:\IBMTOOLS\UTILS\ibmprc.exe

O4 - HKLM\..\Run: [QCWLICON] C:\Program Files\ThinkPad\ConnectUtilities\QCWLICON.EXE

O4 - HKLM\..\Run: [PWRMGRTR] rundll32 C:\PROGRA~1\ThinkPad\UTILIT~1\PWRMGRTR.DLL,PwrMgrBkGndMonitor

O4 - HKLM\..\Run: [sunJavaUpdateSched] "C:\Program Files\Java\jre1.6.0_07\bin\jusched.exe"

O4 - HKLM\..\Run: [QuickTime Task] "C:\Program Files\QuickTime\QTTask.exe" -atboottime

O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"

O4 - HKCU\..\Run: [MSMSGS] "C:\Program Files\Messenger\msmsgs.exe" /background

O4 - HKCU\..\Run: [ctfmon.exe] C:\WINDOWS\system32\ctfmon.exe

O4 - Global Startup: Digital Line Detect.lnk = ?

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_07\bin\ssv.dll

O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\Office12\REFIEBAR.DLL

O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)

O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O11 - Options group: [JAVA_IBM] Java (IBM)

O16 - DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} (WUWebControl Class) - http://www.update.microsoft.com/windowsupdate/v6/V5Controls/en/x86/client/wuweb_site.cab?1206912169226

O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab

O22 - SharedTaskScheduler: Browseui preloader - {438755C2-A8BA-11D1-B96B-00A0C90312E1} - C:\WINDOWS\system32\browseui.dll

O22 - SharedTaskScheduler: Component Categories cache daemon - {8C7461EF-2B13-11d2-BE35-3078302C2030} - C:\WINDOWS\system32\browseui.dll

O23 - Service: Ad-Aware 2007 Service (aawservice) - Lavasoft - C:\Program Files\Lavasoft\Ad-Aware 2007\aawservice.exe

O23 - Service: Apple Mobile Device - Apple, Inc. - C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe

O23 - Service: Bonjour Service - Apple Inc. - C:\Program Files\Bonjour\mDNSResponder.exe

O23 - Service: EvtEng - Intel Corporation - C:\Program Files\Intel\Wireless\Bin\EvtEng.exe

O23 - Service: FLEXnet Licensing Service - Macrovision Europe Ltd. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe

O23 - Service: IBM Rapid Restore Ultra Service - Unknown owner - C:\Program Files\IBM\IBM Rapid Restore Ultra\rrpcsb.exe

O23 - Service: IBM PM Service (IBMPMSVC) - Unknown owner - C:\WINDOWS\system32\ibmpmsvc.exe

O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe

O23 - Service: IBM PSA Access Driver Control (PsaSrv) - Unknown owner - C:\WINDOWS\system32\PsaSrv.exe (file missing)

O23 - Service: QCONSVC - IBM Corp. - C:\WINDOWS\System32\QCONSVC.EXE

O23 - Service: RegSrvc - Intel Corporation - C:\Program Files\Intel\Wireless\Bin\RegSrvc.exe

O23 - Service: Spectrum24 Event Monitor (S24EventMonitor) - Intel Corporation - C:\Program Files\Intel\Wireless\Bin\S24EvMon.exe

O23 - Service: PC Tools Auxiliary Service (sdAuxService) - PC Tools - C:\Program Files\Spyware Doctor\pctsAuxs.exe

O23 - Service: PC Tools Security Service (sdCoreService) - PC Tools - C:\Program Files\Spyware Doctor\pctsSvc.exe

O23 - Service: IBM HDD APS Logging Service (TPHDEXLGSVC) - IBM Corporation - C:\WINDOWS\System32\TPHDEXLG.EXE

O23 - Service: IBM KCU Service (TpKmpSVC) - Unknown owner - C:\WINDOWS\system32\TpKmpSVC.exe

O23 - Service: Protector Suite Virtual Token (vtserver) - UPEK Inc. - C:\Program Files\Common Files\Virtual Token\vtserver.exe

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...