Jump to content

Not connecting to peers/seeds properly


Recommended Posts

I've been having huge problems connecting to peers, i currently opened a torrent as a test, which has 16000 seeds and 4000 peers, im connected to 11 seeds and 8 peers out of a maximum of 225 peers max per torrent after running the torrent for 10minutes... ive tried disabling my firewall, other torrent programs, but its always the same, and its VERY annoying. I've triple checked every option limits, and everything seems fine.

Also, on my old computer i had Norton, but on the new one i have NOD32.

This problem as also existed on my old computer, which i just replaced a few weeks ago, so its probably not my computer, i replaced my cable modem as well, but im still having the same problem, so now im clueless as to what to do. Otherwise than that, my internet is perfectly fine, im starting to think its probably just my ISP thats doing its thing, but before i come and whine at them id rather check out if its on my end somehow.

Link to comment
Share on other sites

Have you tried changing the encryption options? I had trouble with this and changed the encryption options just now and my d/l speed is much improved (2.2kb/s to 124kb/s)

Go to Options->Preferences->BitTorrent

Then in the bottom section called Protocol Encryption set it to enabled and make sure "Allow incoming legacy connections" is checked.

Hope this helps.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...