Jump to content

WebUI JavaScript trouble


Recommended Posts

On the host computer I'm using µTorrent 1.8 (build 11813) on Windows XP (with the latest updates etc).

On the client computer I'm using Linux 2.6.26 with Firefox (or Gran Paradiso to be precise) 3.0.1.

Now, I'm trying to connect to the WebUI on the host computer. I enter my login information which validates and then I see only the "Loading..." screen and it gets stuck there. Using Firebug I see that there is a JavaScript error in stable.js. It tells me the following:

document.styleSheets[n].href is null

Line 1

After debugging for a while, it seems that document.styleSheets.length == 2, but document.styleSheets[1] is indeed regarded as null by at least this version of Firefox. Tried this in Opera 9.52 and Epiphany 2.22.3 as well, where I don't have any JavaScript debugging tools, but I still get the infinite "Loading..." screen.

I looked in the changelog to see if any changes directly related to this issue were made in the later "unstable" versions of µTorrent, but couldn't find any.

Link to comment
Share on other sites


I got this same problem.

So I deleted webui.zip.

and reloaded the page.. and it loaded stright away fine...

I checked my webui folder, and the zip hadnt recompiled..

and the problem was still going on.

I opened %appdata% and went to utorrent>webui, and removed it there.

reloaded the page.. and it still loads fine in ie, and not firefox..

i cannot remove/recompile webui.zip (which no longer exists..).

I have ran a full system scan. and even indexer scan..

What you do reckon?

edit:Alright quick update...

I removed utorrent from appdata, so now all my settings got wiped.

I have set alot of them back up, but currently unable to get onto webui after downloading it again.

it loads the page (on the utorrent port) but freeze's completely on ie now.

and its not working from the alt port.

latest edit:

K I got everything redone, messed around with enableing and disableing, turned off alt port.

and got everything working, and works in ff.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...