Jump to content

Unbelievable bug!..


Recommended Posts

I REALLY don't know how this could happen.. and you guys probably won't either.. but here it goes..

I just spent about 18 hours straight.. up all night before last working this out. Where do I begin? Perhaps a little background.

I have a home-built PC running XP Pro w/SP3. I don't suppose the whole gamut of specs would be of any import so I won't go into them except my mobo is an Asus P5N32-SLI Deluxe and it has TWO gigabit ethernet controllers incorporated into it. One (the one in the N4 chip) is disabled and the one I use is a Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller. The cable comes out of the back of my PC and passes through an InexQ ISO50t router and then to my cable modem. I just built the PC a little over a year ago, at which time I wanted to network my 98PC with this one and I got cable broadband last Jan so I bought this "cheap" (company defunct) router.. but honestly.. for $20.. it's been working like a charm and has many upscale features.. so I'm happy. The company's gone.. and I can't find any firmware updates anywhere anyway (the current one is dated 2004).

I just got into P2P about four months ago. When I try something new I just don't dive in.. I study and learn about it ravenously before I stick my foot in the water. So I read everything I could about protocols, how P2P works and most importantly.. port forwarding. Started out with µtorrent 1.7.7 and have been doing the "sharing" thing with basically a smooth ride for the last four months across limited private trackers and semi-public ones with no problems whatsoever.

About once a month I change ports and even my static IP basically.. because I "can" and just to keep in practice so I don't have to rely on portforward.com all the time. Everything has worked smoothly except for that every couple of weeks the throughput bogs down and I simply unplug both the modem and router for a few minutes and "reboot" them and that cures that problem.

I know that v 1.8 came out awhile back.. but I'm the kind of person that is reluctant to try new builds (even if they are "stable") right off the bat, besides.. "If it ain't broke.."


Four days ago I decided to do a clean install of my OS.. which means a format. So I decided now would be a good time to upgrade to a clean install of 1.8!

Keep in mind that the router retains it's settings as to ports, addresses and such. So it was just a matter of installing the new build of µtorrent and telling it to use the same port as before, still set in the router and such. No problem.. everything seemed fine, though honestly during those first 24 hours I did no torrenting as I was too busy reinstalling apps and such. The port check in the speed guide gave me a green thumbs up. Surfing was fine.

Day two I load up a few torrents and they are up & running. A short time later.. I notice the network status icon change to yellow.. and then red.. but the torrents SEEM to be still be running at full speed (just a little degradation). Then I start losing trackers. I shut down the client, reboot, did the "unplug" thing.. but NOW the port test shows fails consistently! I was getting ready to call my ISP and then I remembered the last time I did I let it out that I had set a static IP and they become a little suspicious. I weaseled my way out by changing the subject quickly and making some excuse (the modem-router combo actually "fixed" itself at that moment.. so I hastily said goodbye) and decided I would tackle this on my own.

Several release/renews, settings changes, and reconfiguring of static IPs later I came to the conclusion that something was wrong with the router. To test the theory.. I took it out of the line and ran my cable modem directly to PC and everything was seemingly OK. So I left it out of the equation overnight. The next day.. before tossing it and going out to purchase a more reliable, expensive router.. I decided to give it one last try and put it back in. This time.. new port choices and obviously.. a resetting of them through the "advanced" HTTP GUI by logging into the router.

Everything worked fine for a short while. In ALL the fiddling and resetting of various parameters/settings in the router itself.. I suddenly noticed that the settings for port forwarding in the virtual server section of the NAT section of the interface.. weren't being retained. If I logged out of the router and then back in moments later.. they were totally gone! Which would explain WHY my port tests in µtorrent were failing on and off. The minute I went back into the router and resaved them.. the client would work again. Soon after I logged out of the router the ports would become closed again. Obviously.. I once again blamed the router as faulty.. since whenever I removed it.. the problem was gone.

I really couldn't see how a router only used for less than a year without problems.. could suddenly die.. so I did more experimenting. By THAT time.. I had muddled and fuddled the network settings so much that I opted for another clean install and a fresh start.. ONLY setting up the network, router and µtorrent first and nothing else to rule out those three things.

Oddly.. things seemed to work on first configuration but would soon deteriorate back to abnormal. Whilst trying to figure out what, where and when exactly the router would lose it's settings. I tried various combinations of leaving the router interface open, saving-not saving, leaving µtorrent open.. exiting out and such. At which point I noticed that it was when I shut down µtorrent and restarted it.. that the router LOST it's port settings altogether! If I left µtorrent open and running.. I COULD log in and out of the router and the settings remained saved, but whenever I DID shut down the client and restart it.. the ports were lost.

Using my clever powers of deduction and elimination I wondered what had changed right when this had happened. Yup.. I switched to version 1.8. Uninstalled v1.8 and put back in 1.7.7 (At this point I had done so many OS re-installs, tweaks, network resets and I'd been up for almost 48 hours that I could barely think and went the lazy route.).

Guess what? Everything's been running fine now (router settings remain saved) for over 24 hours through several reboots.. torrent sessions and client stops and restarts. My network icon remains green.. I get full throughput and every port test comes up fine.

During all this time.. as I usually do.. I did a LOT of reading up on routers and such again on various websites so knowing what I know now about a router, a modem, and P2P software I REALLY can't see how a client (software) such as µtorrent could affect the "inside" of my router's internal settings (but also software.. I guess) and make it delete those settings.. but the proof is in the pudding.

One last thing to make this even more palatable. I tried these various tests with Windows firewall (only one I use since the router has a built-in hardware firewall as well.. IT has always remained enabled) turned on AND off. I also tried manually opening the specific ports themselves as exceptions in Windows firewall.. nothing made a difference.

As one last confirmation I suppose I COULD go back to 1.8 again.. but.. uhm.. no. ;)

Awaiting the expert's opinion.

Link to comment
Share on other sites


Uhm.. you didn't read my post.. did you. Switching to the new version is what got me into this mess. Going back to 1.7.7 is what saved me.


I believe I may have. Back before my format I seem to remember having both UPnP and NAT-PMP disabled. Don't know what would have prompted me to do it.. but maybe I read it somewhere in some setup advice or a thread when I was having disk cache problems.. but I'm pretty sure it wasn't on.

Of course.. reformatting would really start me fresh with no settings saved. I DID notice the same two settings (worded a little different if I recall) in 1.8 but I DO remember unticking them as one of the possible "fixes" during my experimentation.. and it didn't seem to help anyway.

I'm pretty sure my router doesn't support it.

Lastly.. after installing 1.8.. I DID notice a new exception in Windows firewall that I had never seen before come to think of it.. it was for UPnP Framework. I deleted that too somewhere along the way.

I think I see where you're going though.. could µtorrent have been trying to "trigger" (so to speak) or change my ports? How could it do that if my router log-in is password protected?

Link to comment
Share on other sites

More than likely, your router was probably broken from the start, but UPnP was mapping your ports correctly (password isn't required to do this). UPnP would've stopped working in 1.8 if you removed the UPnP exception from the windows firewall.

Or, your router was crashing and losing its settings.

Link to comment
Share on other sites

Ok.. thank you.

"UPnP would've stopped working in 1.8 if you removed the UPnP exception from the windows firewall."..

I don't think that caused the problem because right after the format and new µtorrent install.. I didn't even notice the UPnP exception until AFTER the problems started, and I disabled it thereafter.

So I'll go ahead and try v1.8.1 then. After all.. as I already found out.. uninstalling a newer version and going back to an older one is a simple and conflict free matter.

A few questions though..

Are you saying I should or should not enable UPnP with the new install? Doesn't it depend on whether your router supports it or not? Isn't UPnP the thing your router has to have in order to enable "dynamic configuring" or the "PFConfig" utility they tout on PortForward? In other words.. if UPnP DOES work on my router and in µtorrent.. do I "still need a static IP or to configure port forwarding myself? Do I need to "pick' a port and stay with it.. or can I choose the random port assignment?

Thanks to everyone so far for your time & attention.

Link to comment
Share on other sites

There are two general ways to do forwarding, automatic (UPnP/NAT-PMP) and manual (static LAN IP). They are mutually exclusive. Only try to do one. If you have UPnP enabled on the router, enable it in uT and let it map the port for you. If this fails (no PFConfig won't "make it work" if it doesn't with you setting it enabled yourself just by magic) then you need to try and do it manually. The PORT you choose must be in the rule. You can change it whenever you want, as long as the rule is kept current (via UPnP or manual rule) you're good to go.

Link to comment
Share on other sites

Thanks again for the help.

Ok.. so tonight I went into the router's advanced setup again. I've seen it a hundred times and I swear I looked at every config page. Lo and behold though.. I see this!:

"You can setup this router's local parameters. Such as setup this router IP Address and Subnet Mask. Or if your PC supports UPnP function, you can find this router in "My Network Places" by enable UPnP."

..And yes.. at this moment.. it's enabled in the router.

So more questions arise.. (sorry)

So it appears my router is capable of UPnP.. how do I tell if my PC is? Would it be JUST by the fact that I'm using XP and saw it as an enabled exception? Because honestly.. before v1.8 (I check my exceptions quite often) I never even saw an entry for it in the exception list and I didn't manually put it there.

Here comes the part that excites me ;) .. so I am to understand that all along in the past year or so whenever I would forward ports manually and assign a static IP.. I DIDN'T have to?! If I had set this up right? :lol:

So I can reinstall v1.8.1.. enable UPnP in the client.. pick a random port or even let it generate a new one each start.. enable UPnP in my router.. kill my static IP and go back to dynamic.. and basically.. set and forget?.. AWESOME!

<sigh>.. well.. it was a learning experience.. and I can now manually forward ports and set static IPs with my eyes closed.. so to speak.. but it is a little disheartening.

BTW.. my router is not one of the listed ones supported by PFConfig.. so I know it won't work for me.. but what I was kind of trying to say was that I thought in order for PFConfig to work at all on ANY router.. it had to be UPnP capable.

I suppose one could ask the authors to add support.. but if the UPnP in µtorrent and my router is all that's needed anyway.. why spend $30 on it?

Lastly.. I did notice that this particular setting is under the LAN tab and not the WAN tab.. would that make a difference?

Can anyone refer me to a webpage that explains UPnP more? I swear I thought I first read about it on portforward.com but I've searched several times in the past and can't see it mentioned anymore. As I recall somewhere it said something about if your router was UPnP capable.. then you really didn't even need all their tutoring; nor any need to forward ports.

Sorry for all the questions all.. and I really do appreciate all the help. I just enjoy learning from savy people and being pleasantly surprised.

Link to comment
Share on other sites


UPnP is a function to automatically forward a port without a user's intervention. µTorrent has its own implementation AND it also falls back to the built-in Windows one when its own fails to map a port (some routers are kind of broken in their UPnP implementation and only work with one or the other).

Technically, it's best to setup the static IP because not every program supports UPnP, and they may not be able to map a port on your router In those cases, you'd have to forward manually anyway.

Link to comment
Share on other sites

Ok.. thanks for the info Firon.. and I also discovered where it was I'd seen info about it before. It wasn't on portforward.. it was right here on the µtorrent site in the FAQ section.

So here's where I stand right now..

It's NOT enabled in the client (µtorrent) but it STILL remains enabled in my router. The exception for UPnP is still mentioned in my Windows firewall config (How/when it got there.. I don't know), it won't let me delete it (like some) but I CAN untick/disable it.. and it is.

The FAQ also said that some people debate over the "security" of UPnP and since I know how to, can and already right now have a static IP and ports forwarded.. I guess it wouldn't hurt anything to disable it in the router as well (as it should be). It's been over 2 days now and everything appears to be running hunky-dory.

I also scoured the PF forums last night and in 100% of every case where people were having forwarding problems they were either advised or already stated.. that they had UPnP disabled in their router.. so that's what I'll do. Like I said I'm well versed in setting static IP and setting forwarded ports in the router interface so should I choose to change them again manually.. it's no problem.

Thinking back last night I also realized that I had actually reset the router using the manual-hardware reset button (I didn't even know it had one till now) a couple times during all this, hoping it would help. Maybe the factory defaults enabled it.

Thanks to all for your help. I'm glad this is resolved, glad it wasn't a bug (sorry for posting about it here), and glad I'm now a little bit more knowledgeable.

I'll go ahead and upgrade to 1.8.1 now and just make sure all the settings are right. I don't anticipate anymore problems and consider this closed. Please lock the thread if appropriate.

I'm in your debt.

Link to comment
Share on other sites

I think I see where you're going though.. could µtorrent have been trying to "trigger" (so to speak) or change my ports? How could it do that if my router log-in is password protected?

Days late, but yes, that's what I was hinting at :P Other routers have been known to not play so nicely with UPnP either, like ZyXeL routers. They need special cases such that UDP doesn't get forwarded, otherwise, port forwarding gets screwed up. I've tried googling your router, and all indications point at it being a really crappy router, so I'm not too surprised it got a little confused by UPnP ;D

It can forward the ports without your password because that's what UPnP was designed to do -- get around router protections to make it easier for applications to get their ports forwarded without user intervention.

Link to comment
Share on other sites

"Other routers have been known to not play so nicely with UPnP either"

..This one definitely doesn't. As of right now.. it's kind of running b*ck*sswards from the way it was configured before.. go figure. I have UPnP disabled in µtorrent, it's disabled in the router and my IP is static and port is forwarded manually. However when I disable UPnP last night as an exception in Windows firewall.. it once again stopped working!

I mean I figured if I'M NOT using it.. then why would it have to be enabled as an exception in the list.. right? But like I said before.. I never had that protocol in the list and now I do and can't actually delete it.. so I guess I have to enable it even though relatively speaking.. it's not there. When it wasn't there at all.. everything was fine.. sheesh!

"all indications point at it being a really crappy router"

..LOL.. yeah I know.. I only paid $20 for it last year.. 3 years after it's firmware upgrade indicates.. and when I got it.. the company was already defunct. It seemingly works OK though as long as I don't fiddle with UPnP.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...