Jump to content

torrent downloads to 100% but then rechecks to 99% -disk cache problem


Recommended Posts

I did not have the following problem until 1.8. It occurs only on one of my four computers.

On about 1 out of 3 torrents on the problem computer, I download and eventually go to 100% and seeding. I stop it and do a recheck and only get to 99 or so percent on the recheck. Sometimes it is only 1 piece missing and other times it is several pieces missing scattered over the various files. I restart the torrent and it completes correctly the second time. The other 2 out of 3 torrents finish fine the first time.

My other 3 computers do not have this problem running 1.8 but are not under same load stress. All run XP sp3.

The problem computer is most powerful with 4 processors. It also differs from the others in that it has a raid 5 hard drive (Dell Perc 5/I and scsi 10k). It also has a faster download connection that sometimes get 1.2MBs where the others are limited to 300kBs. During the torrent, the computer is in use sometimes copying files or decompressing downloaded files or doing email and virus scans or burning dvds. These other activities do not have problems except slowing down the pc some. There are no errors appearing in utorrent on the torrent or in event viewer.

So far I have not been able to narrow down when the problem occurs. I suspect the computer gets too busy and the utorrent caching gives up and drops writes to the disk but thinks it made them.

The problem occurred when I used the default disk cache parameters. I tried pre-allocate and it made no difference.

When I unchecked the settings for enable disk caching, I no longer had problems

This may be same problem being discussed in topic "Large amount of CFC errors since 1.8 upgrade" as it also involved a Dell Perc card

Link to comment
Share on other sites

Use 1.8.1. You likely have http://utorrent.com/faq.php#Incompatible_software installed. Please list your type of hardware and post a HiJackThis logfile for the affected computer. You can do so for the other computers so we can compare for you... but it isn't necessary. For future reference you can post the URL in the thread and it will auto-link :D

What happens when you limit utorrent.exe to one processor via affinity? What does your Ctrl-P > Advanced > Disk Cache pane look like now?

Link to comment
Share on other sites

I did not see any incompatible software listed in the faq

The HiJackThis logfile is at the bottom

I am running 1.81

I do not know how to "limit utorrent.exe to one processor via affinity". Another unaffected computer is a 2 processor and runs same application software. The problem computer is 2 dual core processors. No problem like this occurred until 1.8. Were changes made in disk caching going to 1.8?

When it works, all checkboxes in Dick Cache are off except Reduce memory usage


Logfile of Trend Micro HijackThis v2.0.2

Scan saved at 8:40:34 PM, on 10/13/08

Platform: Windows XP SP3 (WinNT 5.01.2600)

MSIE: Internet Explorer v6.00 SP3 (6.00.2900.5512)

Boot mode: Normal

Running processes:







C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe


C:\Program Files\Symantec\LiveUpdate\AluSchedulerSvc.exe


C:\Program Files\Dell SAS RAID Storage Manager\Framework\VivaldiFramework.exe


C:\Program Files\Dell SAS RAID Storage Manager\JRE\bin\javaw.exe

C:\Program Files\Dell SAS RAID Storage Manager\MegaMonitor\Monitor.exe


C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe


C:\Program Files\Logitech\SetPoint\SetPoint.exe

C:\Program Files\Common Files\Sonic Shared\CineTray.exe

C:\Program Files\Common Files\Logishrd\KHAL2\KHALMNPR.EXE

C:\Program Files\Internet Explorer\iexplore.exe

C:\Program Files\Microsoft Office\Office10\MSACCESS.EXE

C:\Program Files\FLAC\FLAC frontend.exe


C:\Program Files\Cool2000\cool2000.exe

C:\Program Files\Internet Explorer\iexplore.exe

C:\Program Files\Internet Explorer\iexplore.exe

C:\Program Files\Cool2000\cool2000.exe

C:\Program Files\Cool2000\cool2000.exe


C:\Program Files\Cool2000\cool2000.exe


C:\Program Files\uTorrent\uTorrent.exe

C:\Program Files\Internet Explorer\iexplore.exe

C:\Program Files\Microsoft Office\Office10\MSACCESS.EXE

C:\Program Files\Internet Explorer\iexplore.exe


C:\Program Files\Logitech\Profiler\LWEmon.exe

C:\Program Files\Michael K. Weise\mkw Audio Compression Toolkit\mkwACT.exe


C:\Program Files\Cool2000\cool2000.exe


C:\Program Files\Cool2000\cool2000.exe

C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = www.google.com/ig/dell?hl=en&client=dell-usuk-rel&channel=us&ibd=1070330

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = about:blank

R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://www.dell.com

R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.dell.com

R1 - HKLM\Software\Microsoft\Internet Explorer\Search,Default_Page_URL = www.google.com/ig/dell?hl=en&client=dell-usuk-rel&channel=us&ibd=1070330

O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll

O2 - BHO: DriveLetterAccess - {5CA3D70E-1895-11CF-8E15-001234567890} - C:\WINDOWS\System32\DLA\DLASHX_W.DLL

O2 - BHO: NCO 2.0 IE BHO - {602ADB0E-4AFF-4217-8AA1-95DAC4DFA408} - C:\Program Files\Common Files\Symantec Shared\coShared\Browser\2.0\coIEPlg.dll

O2 - BHO: Symantec Intrusion Prevention - {6D53EC84-6AAE-4787-AEEE-F4628F01010C} - C:\PROGRA~1\COMMON~1\SYMANT~1\IDS\IPSBHO.dll

O2 - BHO: SSVHelper Class - {761497BB-D6F0-462C-B6EB-D4DAF1D92D43} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\2.0.1121.2472\swg.dll

O2 - BHO: Browser Address Error Redirector - {CA6319C0-31B7-401E-A518-A07C3DB8F777} - C:\Program Files\BAE\BAE.dll

O3 - Toolbar: Show Norton Toolbar - {7FEBEFE3-6B19-4349-98D2-FFB09D4B49CA} - C:\Program Files\Common Files\Symantec Shared\coShared\Browser\2.0\CoIEPlg.dll

O4 - HKLM\..\Run: [NvCplDaemon] RUNDLL32.EXE C:\WINDOWS\system32\NvCpl.dll,NvStartup

O4 - HKLM\..\Run: [sigmatelSysTrayApp] stsystra.exe

O4 - HKLM\..\Run: [iSUSPM Startup] C:\PROGRA~1\COMMON~1\INSTAL~1\UPDATE~1\ISUSPM.exe -startup

O4 - HKLM\..\Run: [iSUSScheduler] "C:\Program Files\Common Files\InstallShield\UpdateService\issch.exe" -start

O4 - HKLM\..\Run: [ccApp] "C:\Program Files\Common Files\Symantec Shared\ccApp.exe"

O4 - HKLM\..\Run: [osCheck] "C:\Program Files\Norton Internet Security\osCheck.exe"

O4 - HKLM\..\Run: [Logitech Hardware Abstraction Layer] KHALMNPR.EXE

O4 - HKLM\..\Run: [DeltTray] DeltTray.exe

O4 - HKLM\..\Run: [nwiz] nwiz.exe /install

O4 - HKLM\..\Run: [NvMediaCenter] RUNDLL32.EXE C:\WINDOWS\system32\NvMcTray.dll,NvTaskbarInit

O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files\Adobe\Reader 8.0\Reader\Reader_sl.exe"

O4 - HKLM\..\Run: [Kernel and Hardware Abstraction Layer] KHALMNPR.EXE

O4 - Global Startup: Logitech SetPoint.lnk = C:\Program Files\Logitech\SetPoint\SetPoint.exe

O4 - Global Startup: Microsoft Office.lnk = C:\Program Files\Microsoft Office\Office10\OSA.EXE

O4 - Global Startup: Sonic CinePlayer Quick Launch.lnk = C:\Program Files\Common Files\Sonic Shared\CineTray.exe

O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office10\EXCEL.EXE/3000

O9 - Extra button: (no name) - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O9 - Extra 'Tools' menuitem: Sun Java Console - {08B0E5C0-4FCB-11CF-AAA5-00401C608501} - C:\Program Files\Java\jre1.6.0_03\bin\ssv.dll

O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe

O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - C:\WINDOWS\Network Diagnostic\xpnetdiag.exe

O9 - Extra button: Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O9 - Extra 'Tools' menuitem: Windows Messenger - {FB5F1910-F110-11d2-BB9E-00C04F795683} - C:\Program Files\Messenger\msmsgs.exe

O16 - DPF: {6A344D34-5231-452A-8A57-D064AC9B7862} (Symantec Download Manager) - https://webdl.symantec.com/activex/symdlmgr.cab

O16 - DPF: {6E32070A-766D-4EE6-879C-DC1FA91D2FC3} (MUWebControl Class) - http://www.update.microsoft.com/microsoftupdate/v6/V5Controls/en/x86/client/muweb_site.cab?1189661639359

O17 - HKLM\System\CCS\Services\Tcpip\..\{F43C207E-5698-4FF9-B029-78BD5F572426}: NameServer =,

O23 - Service: Automatic LiveUpdate Scheduler - Symantec Corporation - C:\Program Files\Symantec\LiveUpdate\AluSchedulerSvc.exe

O23 - Service: Symantec Event Manager (ccEvtMgr) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe

O23 - Service: Symantec Settings Manager (ccSetMgr) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe

O23 - Service: Symantec Lic NetConnect service (CLTNetCnService) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe

O23 - Service: COM Host (comHost) - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\VAScanner\comHost.exe

O23 - Service: InstallDriver Table Manager (IDriverT) - Macrovision Corporation - C:\Program Files\Common Files\InstallShield\Driver\11\Intel 32\IDriverT.exe

O23 - Service: Logitech Bluetooth Service (LBTServ) - Logitech, Inc. - C:\Program Files\Common Files\Logitech\Bluetooth\LBTServ.exe

O23 - Service: LiveUpdate - Symantec Corporation - C:\Program Files\Symantec\LiveUpdate\LuComServer_3_4.EXE

O23 - Service: LiveUpdate Notice - Symantec Corporation - C:\Program Files\Common Files\Symantec Shared\ccSvcHst.exe

O23 - Service: MRMonitor (MegaMonitorSrv) - Unknown owner - C:\Program Files\Dell SAS RAID Storage Manager\MegaMonitor\Monitor.exe

O23 - Service: SSMFramework (MSMFramework) - Unknown owner - C:\Program Files\Dell SAS RAID Storage Manager\Framework\VivaldiFramework.exe

O23 - Service: NVIDIA Display Driver Service (NVSvc) - NVIDIA Corporation - C:\WINDOWS\system32\nvsvc32.exe

O23 - Service: Symantec Core LC - Unknown owner - C:\PROGRA~1\COMMON~1\SYMANT~1\CCPD-LC\symlcsvc.exe


End of file - 8109 bytes


Link to comment
Share on other sites

>So you can make the computer which does have the problem NOT have the problem by turning off the "enable windows bypass of disk cache" for reads and writes?

Yes, that fixes the problem for me. The problem occurred with the default settings and was frustrating since it was seemingly random, unpredictable, and not repeatable, but continued to occur.

>You did not install the nvidia firewall aka "forceware network manager" on any computer correct?

No, I am not familiar with that product. Nvidia Control Panel came installed but as far as I can tell that it is only for the video card as I don't see any network settings on it. I had Norton already so I had no need to try something else.

Link to comment
Share on other sites

The best I could determine was that the problem occurs when the computer gets stressed. It gets stressed by the processes copying files, decompressing flac files, or MS Outlook downloading mail and Norton scanning it. And it is probably a combination of those processes plus heavy bittorrent usage. This unfortunately is not easy to find as I have searched already for that trigger without results other than the stress. I may be downloading 5 torrents at a time and only one or two get damaged and then it is only a few scattered pieces of those torrents.

It is something introduced in going to 1.8. It is something that is relieved when the disk caching is unchecked. I suspect it has something to do with Raid 5 or the Dell version of it. And there is this workaround which is fine for me and can be tried by others who experience the same problem.

I do not know the benefit of uTorrents Advanced Caching but it seems to work fine without it and I do not notice performance degradation.

(And thanks for the pointer to setting affinity and priorities through task manager)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...