Jump to content

Linksys WRT54g v.5 port forwarding problem.. have read FAQ!!


Recommended Posts

I have been having issues with download speeds lately with uTorrent, and I've done everything there is to do.

To start, here are the specs of the situation:

OS: XP Service Pack 2

ISP: Embarq

Model of Router: Linksys WRT54g v.5

Port needing Forwarded for uTorrent: 45682

Static IP set?: Yes.

I downloaded the latest firmware from the Linksys website, the link being: http://www.linksys.com/servlet/Satellite?c=L_CASupport_C2&childpagename=US%2FLayout&cid=1166859837401&pagename=Linksys%2FCommon%2FVisitorWrapper&lid=3740141396B08&displaypage=download#versiondetail

It is in a .bin file, and I can't seem to figure out how to launch it to update my firmware. Does anyone have a guide or can tell me how to do this?

This may or may not resolve my issue, but I'm hoping someone can shed some light and help me fix my uTorrent for good.

Edit: Just to clarify my original problem, it says my port isn't opened on my router, yet I've configured it several times and have entered the correct information to open the port, yet it still says 'No Incoming Connections' on uTorrent... sorry for the mix up.

Link to comment
Share on other sites

My modem is the Sprint 660 Series. I'll give an update once I try making a new Static IP with the information you gave me.

Edit: I changed the IP address from .146 to .150, and my internet still works fine. I changed the port forwarding information on my router's page, but uTorrent still says that the port is blocked when I check to see if the port is forwarded properly.

Link to comment
Share on other sites

I'm waiting on my router configuration page to finally load. For some reason, it's god awful slow and it's just been doing this for the past few days.

Also, as a side note, my internet sometimes hiccups and my web pages won't load, programs won't connect, etc. etc.

So, it looks like my router configuration page will not load. IE says: Internet Explorer cannot display the webpage.

Mozilla says: The server at (router IP here) is taking too long to respond. I'm going to try restarting my router, be back shortly.

**EDIT**: Okay, I just reset my router and it's loading fine.

My connection is: Automatic Configuration : DHCP

The first two octets of my IP Address are: 192.168

Link to comment
Share on other sites

Our model router is bad for torrenting, you'll need to either go through a special firmware flashing procedure, or dial back your settings to prevent the pos from dieing out.

Also, there's another router in your setup, probably the modem. On that same status page check the gateway IPa, use it try and connect to your modem. If it doesn't work, post the gateway address and try bypassing your router for a bit.

You should be able to connect and configure it... the best route, since our router is crap, would probably be to make your Linksys router a switch instead. What kind of connection are you on and what speeds do you get?

Link to comment
Share on other sites

You reset only the router correct? The router can't handle the load because Linksys reduced the amount of memory available in versions greater the V4, the best thing to do would be to upgrade the firmware to DD-WRT. This would make the router work well with protocols like BitTorrent and prevent it from screwing up like earlier. With the upgrade though there is a very small risk the upgrade can screw up the router and require a special cable and program to fix, but as long as the instructions are followed correctly you shouldn't have any trouble. I have followed this procedure with my router (a v6).

An alternative is to TRY and make your Linksys router NOT a router, and then it shouldn't bug out, but I've never tried this so I can't confirm this will fix the issue, but if you'd like I can instruct you on how to do so. After that, you would configure your modem (actually an ADSL router) for port forwarding.

Trying to port forward or bridge the ADSL router right now would probably result in the Linksys router crashing a lot more. Reducing your settings in µTorrent might mitigate this problem with the Linksys.

Edit: Flashing procedure: http://www.dd-wrt.com/wiki/index.php/Version_5_And_6_Router_Information < Will also probably void your warranty, if your router still has one.

Link to comment
Share on other sites

Sorry for the wait for a response; duty calls me on weekends to become a party animal!

Anyways, is there anything else I need to do once I've upgraded my firmware to DD-WRT?

I'm reading the instructions now and I'll be flashing it soon I suppose.

**EDIT**: So, I upgraded my firmware and can log into my router with the new interface, but when I go to forward a port, I click on Add in the Port Range Forward section and the screen just goes blank... any way to fix this? It just takes me to a blank screen with the address

**EDIT 2**: Now, my router isn't working. I was able to browse the web, download music, and log onto chat clients for about an hour, then it suddenly died out. I've tried using a static IP and a dynamic IP to no avail. I can connect through my modem just fine, but when I try to connect with my router, it doesn't work. This isn't good :(

Link to comment
Share on other sites

Ok well from your other post you figured out you needed to set the timeouts. Change the connection type on the Linksys to Bridge Mode (Setup section), switch your computer to automatic IP addressing, then do port forwarding in your modem (it goes by device correct?). If you modem gives you trouble, look to see if it has a bridge mode instead. If its mode before that was PPPoA/PPPoE then after changing the modem to bridge you need to set the Linksys to PPPoE and enter the login details from the modems PPPoA/PPPoE page.

Link to comment
Share on other sites

Okay, so just to clarify, you want me to bridge the Sprint 660 first right?

My setup goes like this:

-Modem goes into DSL jack next to my phone jack

-Two wired cables go into this computer and a computer in the other room through the Linksys Router

-One wireless connection for another computer in another room through the Linksys Router

If you can, explain thoroughly what I should do. I'm not very computer savvy when it comes to routers and modems :P

Link to comment
Share on other sites

You need one of them bridged, but I'm not sure if the Sprint even has bridging, it may be easier to try to bridge the Linksys (on the Setup page, connection type), and then try forwarding in the modem.

If that doesn't work, see if you can bridge the Sprint (recommended action), and if the Sprint was originally on PPPoA/PPPoE then you need to set that in the Linksys as the connection type, as well as enter the appropriate logon details if any.

Link to comment
Share on other sites

As for the DD-WRT version:

DD-WRT v23 SP1 Final (05/16/06) micro

The sprint modem's capsulation is set to: ENET ENCAP


Here are some screenshots of my different configurations for both the router and the modem. Maybe this can help a little. Also, I'll attach my ipconfig /all from command prompt as well.





ZYXEL(My Sprint 660 Modem) LAN SETTINGS:






Link to comment
Share on other sites

Outdated version of DD-WRT, but it should be fine if the Sprint goes well. Set the Sprint to bridge (and hang on to that picture of the page), restart the Linksys and then go to the Status page, find and paste the first two parts of your WAN/Internet IP address like last time.

If your Internet access doesn't work while bridged, update to DD-WRT v24-SP1 micro and you should get the PPPoE/PPPoA connection type option you're missing.

Link to comment
Share on other sites

Before I go any further, just wanted to make sure you noticed I edited my last post by inserting a few screenshots of different settings for both the router and modem as well as an attached screenshot of my ipconfig /all in command prompt. I don't know if it will help, but I want to let you see those before I do anything.

Link to comment
Share on other sites

No I left all my settings the same minus changing the timeout settings.

So, you want me to upgrade my firmware on my router. After that, what else?

You might not hear back from me this evening due to lack of sleep lately, but I'll be sure to respond as soon as I wake up. Thanks for your help! :]

Link to comment
Share on other sites

When I upgrade it, do I have to do all the things I did when I switched from Linksys to DD-WRT such as vxworkskillers, etc? Or do I just download dd-wrt.v24_micro_generic.bin and use the "Firmware Upgrade" feature from the DD-WRT router configuration?

Link to comment
Share on other sites


I sent you an email through the forums regarding the WRT54G V6

I upgraded to DD-WRT 24 SP1 (the latest) and am having some issues that I did NOT have using the Linksys firmware.

I obviously want to keep using DD-WRT but need to figure out whats causing it

check the email address associated with your utorrent forum name..should be there

thanks a lot

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...