Jump to content

utorrent causing intermittent connection


Recommended Posts


i am using the utorrent 1.8.1 client

recently i have been facing the problem of intermittent internet connection when using utorrent

i am using at&t dsl service

since past 2 weeks, every time there is some download going on and i try to browse the internet i lose my dsl connection

this does not happen when im only browsing

i have spoken to at&t as well and this problem seems to happen only when utorrent is downloading

initially i had the default global number of connection 750 and peers per torrent of 300.

i reduced that amount to 100 and 50 respectively and am still facing this problem.

i want to know why i didnt face this problme before with more connection and peers and all of sudden faced it 2 weeks back?

i have also configured port forwarding on my router.

will reducing the connections and peers reduce my download speed?

any suggestions will be appreciated

bandwidth:6016kbps down 768kbps up

router:2wire 2701HG-B

firewall: only vista os firewall

Link to comment
Share on other sites

I get this same issue. It started as soon as I downloaded version 1.8.1, and ran it. After it is loaded, my net connection dies, but only for browsing (ie, port 80). uTorrent continues downloading, and I can ping websites.

I downloaded version 1.7.1 from <munched - don't link to old versions, we don't support it. that includes finding it>, and the problem went away...

Link to comment
Share on other sites

I can only presume you have marginal networking hardware and software that partially overload+crash while uTorrent is running.

Bad settings in uTorrent can definitely make the problems more severe.

What is uTorrent's net.max_halfopen value set to? (It should be 8...or less!)

1st and 2nd link in my signature.

1st one is for troubleshooting, and tells you what information you'll need to give us if the problem isn't solved quickly.

2nd link gives suggested settings for uTorrent based on your max sustainable UPLOAD speed.

Link to comment
Share on other sites

1.7.1 ? Seriously? You don't want to use 1.8.1 the latest in 1.8 series, fine. But you'll have to go elsewhere for help. There's a reason the developers update the application... to fix problems/bugs/features. Among what Firon said... 1.8 is more efficient at resource allocation and it works better over long periods as well as has fast_resume for those who need to recheck data it takes much less time.

Link to comment
Share on other sites

Had the same problem again with 1.7.1

Will go back to 1.8.1 as you suggest

Can someone please help me with the exact settings that I need to configure?

I use AT&T DSL connection

Download : 6016 kbps

Upload : 768 kbps

Here are the current settings:

Maximum Upload rate: 24kB/s

No alternate upload rate

Global maximum number of connections:250

Maximum number of peers per torrent:100

Number of upoad slots:5

net.max_halopen = 8

Port forwarding configured on router

Link to comment
Share on other sites

had to go down to 100 connection, 60 peers max upload of 22kB/s and halfopen to 4.

turned off dht and lpd

no problem yet so far. hope it stays.

what i dont understand is that i used my earlier default settings for more than a month without any problem and how come suddenly without making any changes this starts happening.

edited: just to try different scenarios tried increasing the halfopen back to 8 and rest of the settings untouched, still no problem.

maybe its the dht or lpd thats creating the problem?

Link to comment
Share on other sites

well it happened again!

this time even with dht, lpd turned off and halopen set to 4.

this is just too annoying.

can anybody suggest anything?

i also had at&t do a analysis of my dsl line and they said it was fine.

i tried using the lan connection. no problem.

so it seems that wireless connection has problem.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...