Jump to content

I've tried everything and UTorrent still doesn't work!!!


Recommended Posts

I'm a new member on this forum but I've been reading a lot of threads the past couple of weeks and have come to the conclusion that my utorrent is bust!!!

I recently upgraded to the new version of U-Torrent (1.8.1) and after doing so immediately my download speeds are non-existent, my uploads too and the little green tick icon has changed to a yellow (!). It keeps chaging though. It changes from a red icon to a yellow icon all the time.

I have read the port forwarding guide about 10 times and it still doesn't help me, I've done everything on it twice but to no avail.

I have a brand new router. A D-Link DSL-2640R. On the setup menu for it (the one which requires a username and password) it has a port forwarding menu but I can't make head nor tails of it. It asks for an isp address and I'm stuck for what to put in...

I tried upgrading back to an older version of Utorrent but that didn't work...

Its really frustrating, if anyone can help I will be chuffed!!!

Link to comment
Share on other sites

Thanks for the reply. The only firewall I have for my pc is the basic windows one and AVG anti-virus. How do I alter that?

I'll need a bit of help, I'm useless with all the fandangled terminology!!

Everything was peachy for a couple of years, downloading torrents was fine and now all of a sudden it decides its had enough!

EDIT: I believe I have sussed the situation now, I read in a different thread about writing out the ports for port forwarding and after configuring my router its all green now :D

I just hope the download speeds will be ok, if not then I guess you will see me again...

Link to comment
Share on other sites

Ok, I'm back, I managed to fix Utorrent but now its playing up again...

I've been using Utorrent for way over a year now and never had this problem before, why is it the new update has screwed everyone over??

Anyway... rant over...

On my router access page, the one where you type admin for username and password, I reached a port forwarding page... I set up a port for Utorrent to use and like magic it was back to good!!

Over the past few days though it's gone back to pulling its usual tricks again, I checked the port and its still fine but the icon has changed to yellow, even though it was green this morning. Both speeds are barely above 1.0 kbs...

I ran the port checker again but it says it isn't open, even though I've set it up manually with my router...

I use a D-Link DSL-2640R Wireless Router btw. Plugged straight into the back of my computer.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...