Jump to content

Speed drops then goes back up every 5-6 minutes


Recommended Posts

Whenever I'm downloading files using uTorrent, every 5-6 minutes my download speed drops suddenly to near 0 and then goes back up almost just as fast. This makes it very hard to reach really high download speed since the speed doesn't have time to get very high before it drops down again.

Here's a picture of my download speed graph to illustrate what I mean:


As you can see, the speed drops sharply on a very regular basis, it's like clockwork. No matter what I download, no matter how fast or slow my best download speed gets, the speeds drops at the same 5-6 minutes interval. If I have multiple torrents downloading at the same time, all of the downloads drop in speed at the exact same time.

I've tried using the recommended download settings, and changing them to something else, with no change to the situation either way. I've also updated my router's firmware (WRT54GC), figuring this was a firmware bug, but it didn't solve anything. My ISP, Videotron (Canadian), doesn't throttle Bittorrent download speed as far as I could find anywhere. I did some research online and couldn't find anybody with a similar issue. Rebooting the router doesn't solve this problem.

Does anybody have an idea of what might be causing this and how I might solve it?

Thank you in advance.

Link to comment
Share on other sites

Short of connecting my PC directly to my modem -- I'll try that later -- I've tried the things stated in the FAQ with no visible result. As for the router, I upgraded its firmware to make sure it wasn't the problem.

Glasnost's tests do not work for me tonight. When I press the "Start testing" button, I get an error message that my browser can't connect to the server after a few seconds, in Internet Explorer and Firefox.

I am, however, more and more thinking that my ISP is throttling my downloads even though they claim the opposite and even though the "Bad ISP" list on Azureus wiki doesn't list them. The pattern seem too regular to be a technical glitch: the first ~10 minutes of download seem to go fine, then the problem I mentioned starts ocuring at a very regular pace. Assuming their throttling works by somehow making me lose my connection to peers once every 5 minutes, it would be very hard to catch on a test like Glasnost since it's not constant.

Anyway, this is all conjecture right now and it may well be some sort of weird technical problem on my part...


I've run Glasnost this morning and it came out all green, no shenanigans discovered. The plot thickens...

Link to comment
Share on other sites

My line's download speed is 7 mbps and around 100 kBps for upload. Right now I'm using the settings the configuration assistant (in the options menu) set up. They're as follow:

Global maximum upload speed: 80

Maximum download speed: 0 (no limit)

Maximum number of connections: 800

Maximum number of clients per torrent: 125

Maximum upload slots: 25

I've tried various other settings in the past and none have made any noticeable change. I rarely download more than one torrent at a time.

I'll try the recommended settings from your signature to see if they help.

-- Update --

Not quite sure what did it: I changed a few settings and tried connecting directly to my modem (to see if it was router related) and my download came back to normal. I reconnected my router to the modem and it's still running properly (I've tried with two torrents). Odd since I rebooted my router recently and updated my firmware and none of those changes fixed anything. Maybe it was the few settings I tweaked or maybe disconnecting and reconnecting everything helped...

Anyway, thanks for the tips guys.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...